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Welcome to ADR Manager

ADR Manager is a comprehensive database system for audio professionals. It has been used worldwide on hundreds of feature
films and television shows.

For sales and support information, please visit our website at www.slanecon.com.

This online help system can be accessed at any time from within ADR Manager by choosing Help for ADR Manager under the
Help menu, or by clicking on the question mark button in most windows. For additional help, check out other resources.

If you don't like reading manuals and would rather dive right in, check out the quick start page.


http://www.slanecon.com/

Introduction

ADR Manager is a powerful way to manage Automatic Dialogue Replacement cues for any kind of professional audio project. It was
designed to be easy to learn, but fine-tuned to give you maximum speed and efficiency.

Spot cues in any time format by importing from files, grabbing times from Pro Tools, or manually entering times. Import from
Pro Tools session text files, Microsoft Excel documents and tab separated text files.

Conform by importing an Avid change list or creating your own list.
Search cues by keywords, status, or priority. Perform complex searches with ease.

Audition takes and circle them. Place selected takes in a Pro Tools session. Build a library of all the takes in your project by
dragging and dropping files, importing from a Pro Tools session, or creating takes as you record them.

Print reports for different audiences, such as actor, director, post supervisor, mixer and editorial crew. ADR Manager comes
with default reports for cues, cue count tables, LFOA lists, continuity lists, and change lists, or you can customize to your
liking. Batch print multiple reports with a single click of the mouse.

Track characters, reels and scenes. Store cues for different dupes of the same reel, so you can refer back.
Name cues so that they are unique. Batch rename all cues.

Integrate with Pro Tools by grabbing times and importing from session text files. Locate and play Pro Tools by clicking on
cues in ADR Manager.



Who should use ADR Manager

This application is designed for ADR supervisors, editors, assistants, mixers, and recordists. It assumes familiarity with the
nomenclature and processes used in film and television ADR. A basic understanding of your computer is also required.

Changing font sizes and styles, or adding, deleting, or moving things around on reports is easy to do. An intuitive graphical interface
is available to let you change things quickly. However, if you wish to write your own scripts for the reports, you will need some
knowledge of the 4th Dimension programming language. Contact Slanecon Digital for more information.



What's new in ADR Manager 7

New features in version 7 of ADR Manager include:

e Big Sur macOS 11 compatible

e Compatible with the latest iLok technology
e Print reports to PDF files

e Batch print multiple PDFs with one click

e Export cues, takes, scenes and change lists to Pro Tools tracks. Split cues on to different Pro Tools tracks based on
character, priority, or status

e Complete overhaul of import and export functionality. including saved settings, custom delimiters for fields, and text
substitutions

e |mport Microsoft Excel documents

e |mport markers from Pro Tools

e |mproved transport control of Pro Tools
e Condense Avid change list

e Support for font styles and colors

e Support for non-Roman characters (e.q. Kanji. Hebrew. etc.

e Batch spell checking



If you need help

There are several ways to get help if you have problems or questions about ADR Manager. The first way is by referring to this
manual. The second way is to use our web site and the user group. If all else fails, you can get further support by contacting
Slanecon Digital technical support.

Using online help

Great care has been taken to make the online help comprehensive and accurate. It is your best resource to answer questions and
help you learn how to use ADR Manager. You can access online help by choosing ADR Manager Help under the Help menu at any
time.

You can also get help for a specific window or command by clicking on the Help button 7 available in most windows.

We welcome feedback on the documentation.

Web site

Check out our web site for software updates, frequently asked questions, free reports, and other information regarding ADR
Manager:

http://www.slanecon.com/support.php

Submit a technical support ticket

Most error alert windows contain a button that lets you submit a technical support ticket. Click on the button to fill out and submit an
email to technical support. If possible, please include your current datafile, relevant external files (i.e. the file you are trying to
import), and other information that might help us troubleshoot the issue.

Technical support

If you are having trouble with the program, please refer to the manual first. In most cases, the manual will answer your question. If
not, check the Read Me file that was installed with the program. If the web site doesn't help either, technical support is available by
e-mail. Replies generally take 2-3 business days. Please send your data file along with the following information:

e What version of ADR Manager you are running
e What version of macOS you are running

e Your name, company name, and phone number and e-mail address where you can be reached

The technical support email address is support@slanecon.com.


http://www.slanecon.com/public_html/support.php
mailto:support@slanecon.com

Quick start

For people who don't like reading manuals, here is a brief rundown of what to do to get started with ADR Manager. Click on links for
more information.

1.

10.

Create a new database by double-clicking on the ADR Manager application. A dialog appears asking you whether you want
to create a new database or open an existing one. Click on the Create button, give your project a name, and save it to disk.
The application will quit and relaunch with the new database.

. Enter the name of the project and setup the time formats you'll be using in the Welcome dialog.

. Enter the reels for your project. Open the Reel List window under the Windows menu and select Create new reel under the

Manage menu. If you are working in episodic TV, think of each reel as an episode.

. You can enter the list of characters in your project now or later. If you want to do it now, open the Character List Window

(choose Windows > Characters) and select Add character under the Manage menu. You can also add characters on the
fly as you enter cues.

. You may want to enter the continuity list before you begin spotting cues, although this is optional. Open the Scene List

Window under the Windows menu. You can enter the scenes one at a time by opening the New Scene window, or you can
import a text file with a list of the scenes. You can do this before entering cues so that ADR Manager automatically looks up
what scene the cue is in while you enter the cue's information, or you can overlay scenes later.

. Once you've entered the project info and reels, open the ADR Cue List Window. Add cues by opening the New Cue window.

You can grab times from Pro Tools using MIDI or an automation utility such as Keyboard Maestro. Add characters by
entering them into the Character field. If they have not been defined yet, the New Character window will appear and you can
enter info about the character there.

To search for cues, open the Search Window. Check the character and reels you wish to search in, as well as other criteria,
then click on Search.

To modify a cue, double-click on it. To modify several cues at once, select them and choose Modify selected cues under
the Manage menu. To rename cues, select them and choose Rename selected cues under the Manage menu.

When it comes time to generate a report, make the Cue List window active and do a search on the cues you want in the
report. Choose Preview PDF under the File menu. The report opens in Preview, where you can print it or save it to disk. To
print a cue count table, make the Character List Window active and repeat the process. To print an LFOA list, make the Reel
List Window active. To print a continuity list, make the Scene List Window active.

To conform picture changes, create a new dupe of a reel by highlighting it in the Reel List window and choosing Manage >
Create new reel dupe. Give the new dupe the new version and dupe date. You cannot change the LFOA here - you must
close the window and perform the changes, which will automatically update the dupe's LFOA. Choose Manage > Conform
selected dupe to open the Change Event List window. You can add changes manually or import them from an Avid change
note. In any case, once you've entered them, you can step through the changes one at a time or in batches. For each
change, ADR Manager will ask you to choose what to do about cues that overlap the changed segment of time.



System requirements and installation

ADR Manager runs on any Macintosh desktop or laptop computer with the following requirements:
e MacOS 10.14 Mojave through 11 Big Sur
e 4GB RAM minimum (8GB RAM recommended)

e 600 megabytes of hard disk space to install the application and other files, and an additional 30MB for each project
(typically).
e iLok USB copy protection key (generation 2 or greater)

Installation

The ADR Manager disk image can be downloaded from the Slanecon Digital website at http://www.slanecon.com/support.php. To
install, simply double click on the disk image to mount the ADR Manager volume, then drag and drop the application into the
Applications folder.

You will need an iLok (generation 2) USB copy protection key with an ADR Manager authorization in order to run the application.
ILok keys can be purchased at http://www.ilok.com. Authorizations for ADR Manager can be purchased at

http://www.slanecon.com/buy-now.php

IMPORTANT: Do not lose the iLok copy protection key. If you lose it (and the authorization within it), you will have to
purchase another copy of the program, since the purpose of the key is to prevent software piracy.

Using the iLok copy protection key

You can install the ADR Manager application on as many computers as you like (i.e. work and home), but the application will run on
only one computer at a time. This is enforced by a device called a copy protection key. Whenever you use ADR Manager, the
software checks to see if the copy protection key is plugged in. If it is not plugged in when you start up, the program will ask you to
plug one in. If the key is unplugged while you're using ADR Manager, the program will quit.

The copy protection key must be plugged into a powered USB port. For more information about the iLok copy protection key, please
visit www.ilok.com.


http://www.slanecon.com/support.php
http://www.ilok.com/
http://www.slanecon.com/buy-now.php
http://www.ilok.com/

Database basics

This chapter introduces basic concepts about what an ADR Manager database looks like on disk, how to create or open a datafile,
how to backup and restore a datafile, and some basic concepts about data entry. It also describes how to troubleshoot issues.



Where the information lives

When you create a new database with ADR Manager, several files are created. All of the information for a particular project - its
characters, reels, cues, takes, scenes, reports, etc. - lives in a set of files collectively referred to as the database. To move the
database from one computer to another, move all of the files together.

B myProject.4dd
H My Project. 4DIndx
E My Project.Match

Database files share the same name, followed by different suffixes. Note that some files may have their suffix hidden when viewed
in the Finder.

o The .4dd file stores all of the records for all tables in the database. This is called the data file. Note the terms database and
data file are used interchangeably throughout the application and this manual.

o The .4DIndx file stores the indexes for the records. Indexes are used to search and sort records. If this file is removed, it will
be recreated the next time you open the database.

e The .Match file stores information that is used to rebuild a corrupted database. If this file is removed, it will be recreated the
next time you open the database.

For convenience, you can put the database files in a folder whose name ends in .4dbase. The Finder will then recognize the folder
(called a "package" in Apple terminology) as a single, complete ADR Manager database. You can move and copy the package as if
it were any other file. You won't be able to open it as you would other folders, because the Finder treats it as a single document (you
can still open it using right-click or control-click).

MyProject.4dbase

Reports are also stored within the database. To use a report template, it must be imported. Default reports are automatically
imported when you create a new database.



Launching the application for the first time

ADR Manager requires a license to run. This license is stored in an jLok copy protection key (Generation 2 or greater). You can
download the license to your iLok key using the iLok License Manager (in the Applications folder), or by running ADR Manager and
activating from within the app.

To activate from within ADR Manager, make sure you are connected to the internet. Plug in an iLok key into a powered USB 2.0 or
3.0 port, and launch the app.

Activation is required

Product Name: ADR Manager 6
Publisher: Slanecon Digital
Product Number: ADRMgré

This product requires activation. Please click one of the buttons below to begin.

Click on Activate. The Login dialog appears:


https://www.ilok.com/

License Account Login

Please enter your ilok.com account credentials.

User ID: || |

Password:

| Remember Me

Forgot Password or User ID?

Create new account

[ Back J [ Next J

Enter your iLok User ID and password. The User ID must match the ID you gave to Slanecon Digital when you purchased ADR
Manager.



Select License to Activate

Select the license that you would like to activate:

Mame Type Rale Expires A Deposit Date
ADR Manager 6 License Product Mo 8/22/18 2:33 PM

Allowed Locations:

[ Show Locations ] [ Quit ] [ Mext ]

Select the ADR Manager 7 license and click Next. Wait a minute while the license is downloaded to your iLok. If successful, a dialog
appears and you can continue to launch ADR Manager. If no license appears, contact Slanecon Digital.



Launching the application

To launch the application, double-click on the application icon. If you have not plugged in your iLok key with an ADR Manager 7
license, you will get the following dialog:

Do you have this iLok?

Product Name:  ADR Manager 6
Publisher: Slanecon Digital
Product Number: ADRMgri

The most recently used license that authorizes this software was on the iLok with serial
number

If a second {or later) generation iLok with a valid license for the software is available,
please plug it into a USB port on this computer.

If you need to activate or purchase a license, click the Activate button.

[ Quit ] [ Activate

If you get this dialog and you have an authorized iLok key, check to make sure the key is seated properly in the port, the port is
adequately powered, and the latest iLok extensions are installed. Instructions on how to install iLok extensions will appear if you do
not have them installed properly. ADR Manager will not run until the iLok is installed properly.

You can launch the application by double-clicking on a database, but be aware that this may not open the database you double-
clicked. Instead, ADR Manager always tries to open the last used database, regardless of how the application was launched (see
Opening a database for more information). You can force ADR Manager to present an Open File window during startup by holding
down the option key while the app starts up. This gives you the opportunity to manually select the database you wish to open. If
ADR Manager has already opened a database, the Welcome window gives you an opportunity to choose a different one.

Software updates

By default, ADR Manager will check to see if there is a newer version of the program available on the Slanecon Digital website each
time it launches. You can turn off this setting in the Preferences window. If there is a new version available, a window will appear
describing what improvements have been made in the new version, as well as a button to direct your web browser to the downloads

page.



Creating your first database

Double-click on the ADR Manager application icon to launch the application. If this is your first time using ADR Manager, the
Open/Create dialog appears.

Would you like to open an existing datafile or create a new one?

You can either open an existing database or create a new one. Click on the Create button to name and save the new database:

Save
Save As: | Untitled e
Tags:
Where: | [l Documents

Cancel Save

Name the datafile (such as your project name) and save it in an appropriate place, such as your Documents folder. Several files will be
created in the folder.




You can also create a new database after you start up ADR Manager by clicking on the Create new button in the Welcome screen, or
by choosing the New database menu item under the File menu once a data file is open.

ADR Manager

Version 7.0.2

Build 1608

Datafile: MyProject.ddd

Location: Sam:Users:5teve:Documents:ADR Manager
projects:

oo

Create new-. I Quit |

Copyright 1997-2020 Slanecon Digital, Inc.

The Welcome dialog displays the newly created datafile name and location.



Opening a database

When launching ADR Manager by double-clicking the application icon or clicking from the dock, the last used datafile will automatically
be chosen:

ADR Manager

Version 7.0.2

0. Build 1608

” Datafile: MyProject.ddd
II// Location: Sam:Users:5teve:Documents:ADR Manager

projects:

Open
CCreatenew.. I Quit |

Copyright 1997-2020 Slanecon Digital, Inc.

Note: Dragging a datafile on top of the ADR Manager application icon is not currently available.

The Welcome dialog displays the currently selected data file name and location.

If you want to open a different datafile, click on Open other.... You can also choose File > Open recent to select from datafiles
previously opened on this computer. If you are having trouble opening a data file, see Eixing database problems.

Click on Create new... or choose File > New datafile ... to create a blank datafile.



Saving your database

ADR Manager automatically saves the data file every 20 seconds. There is no File > Save menu item.



Editing records

Adding, deleting, and modifying records is done by opening the record's List window and making it active. Once a List window is
active, the Manage menu will change to reflect the things you can do to that table. For instance, when the ADR Cue List window is
active, the Manage menu looks like this:

Edit Windows Help

Add cue... EN
Add cue with clipboard times... {34
Duplicate selected cues... gD

Modify selected cues...
Delete selected cues...

Split cue...
Merge cues...
Spell check cues...

Rename selected cues...
Clear selected cue names...

Lock selected cues L
Unlock selected cues skl
Create take for selected cues {r3EA

Show related takes

The Manage menu will change each time you make a different window active. All other menus remain constant. Common menu
items can also be triggered by clicking the toolbar buttons at the top of a List window. Sometimes menus may disappear when you
open an editing window, such as the New Cue window. The menus will return to normal if you close the editing window or make a
list window active. In some cases, you must close certain editing windows before you can perform an action (i.e. conforming). This
is to prevent data corruption.



Entering field values

There are several ways you can quickly enter data in boxes:

Hitting the return key will deposit the value you just typed and then select the entire field, unless you are in a text field, in
which case the return key adds a new line.

Hitting the tab key will deposit the value you just typed, and then go to the next field in the window.
Hitting command-tab will deposit the value you just typed, and then go to the previous field in the window.
Hitting the enter key will deposit the value you just typed, and then click the OK button in the dialog for you.

Typing command-period or the escape key is the same as clicking the Cancel button in most dialogs.

For text fields, you can apply font styling by highlighting the text and control-clicking or right-clicking. A popup menu appears,
allowing you to change the font name, style, size, color, and background color.

Dialogue

I reallv need vou to do this.

Cut Private noi

Copy
Paste

Fonts...

v

Bold

Size g raic
Color > Underline
Background color [ Strikethrough

71

You can cut, copy, and paste from the macOS clipboard when entering data in any window. If you copy text from a word processor,
it will retain the font, size, and style when you paste it into an ADR Manager text field. The special menu item Edit > Paste and
match style pastes as plain text (it matches the font style in the text box you are pasting into). You can clear the styles in certain
text fields by selecting Manage > Clear styles while the cursor is in the field.

As of ADR Manager 7, unicode characters are now supported. This means you can store non-ASCII characters, such as Kaniji or
Hebrew, in text fields. If you are copying or importing text from another application, be sure the text document you are copying from
is stored as unicode (aka UTF) as opposed to Mac Roman, for instance.



Entering project times

There are many places in ADR Manager where you must enter a timeline value, or project time. You may be creating a cue, or
entering the LFOA for a reel, or inserting time into a reel. Before you enter project time, you should be aware of what format you are
using. If you are unsure, open the Project Info window by choosing Project under the Windows menu to see what the "preferred”
time format is.

Project time fields will accept values in several ways. You can:
e Enter a time with complete punctuation (i.e. "01:02:12:17" or "212+10")
e Enter a time using shorthand (see below)
e Paste a time from the clipboard

e Grab the current time using a menu command or keyboard shortcut. The current time is displayed in the Transport Control
window.

e Run a macro that copies both the start and end times from the Pro Tools Edit window and pastes them into the start and end
times for a cue in ADR Manager.

Entering times using shorthand

You can enter times using shorthand. Type only the digits, hit return or tab, and ADR Manager will put in the appropriate
punctuation. For example, if you are entering a SMPTE time of 03:13:22:00, simply enter 3132200 and hit return or tab:

BE= becomes 03132200

If want to enter feet and frames of 212+10, enter 21210 and hit return or tab:

Sz becomes 212+ 100

Note you must always enter digits for the frames in timecode or feet and frames. In other words, if you wanted to enter 1 foot and 0
frames, you must enter 100, not just 1.

The shorthand method allows you to enter data faster, especially if you have a numeric keypad. You can only use the shorthand
method when in a time field, not in a text field.

If you type an invalid value in a time field, ADR Manager will display an error and revert the field to its previous value. If you'd rather
have the application attempt to correct the value by recalculating subfields, check the Normalize time values preference under the
Data Entry tab in the Preferences window. For example, if you are spotting in non drop timecode and you enter 01:00:00:45, the
value would be replaced with 01:00:01:15 and no error would be posted.

Entering times by pasting from the clipboard

You can cut, copy, and paste from the macOS clipboard to a time field. In the New Cue and Modify Cue windows, you can paste
both start and end times from the clipboard in one command, if the clipboard holds two times.

Entering times by grabbing the current time

The current time is a time value that is available throughout ADR Manager for stuffing into time and text fields. It is always in the
preferred time format. The current time is updated using MIDI messages received from an external MIDI source such as Pro Tools.
You must setup MIDI communication between ADR Manager and Pro Tools in order to enable the use of current time. See
Transport Control for more information.



Entering times by running a macro

You can grab times from Pro Tools using the automation utility Keyboard Maestro. A macro is found in the ADR Manager > Macros
folder. See Grab times from Pro Tools using a macro for more information.



Entering dates

You can enter full or partial dates. If you enter only the month and day, the year will be assumed to be the current year. If you enter
a full date, the year can be 2 or 4 digits. If you enter 2 digits for the year, ADR Manager will interpret any number from 60 through 99
to mean the years 1960 through 1999. Any number from 0 through 59 will be interpreted as the years 2000 through 2059.

You can also use a calendar popup to select a particular day.

—

- March 2018 »
Su Mo Tu We Th Fr S5a

25 (26|27 28 1 3l

thEﬁ?sgm'

11 12 13 14 15 16 17

: |
This 19 20 21 22 23 24 |

= @l 35 35 27 28 29 30 31

9 3|2 |3|a|5]|6|7
@2 3891 w5
@240 0008 |

Dates are displayed throughout ADR Manager according to your regional settings. You can access your regional settings in macOS
by going to System preferences > Language & Region > Advanced > Dates.



Spell checking

ADR Manager provides several ways to spell check your work:

e You can check your spelling as you type in a text field

e You can select multiple records and check them all for spelling mistakes
To check your spelling as you type, make sure the "Enable spell check in text fields" preference is turned on under the Data Entry
tab in Preferences. The spell checker will underline misspelled words in the current text field.

To check multiple records at once, highlight the records in the List window and choose Manage > Spell Check. A dialog will appear
for each misspelled record, directing you to the field containing the error and giving you a chance to fix it.

To fix a misspelled word, right-click (control-click) on it. A popup menu appears:

Private notes

This is a priavie note

privet

Learn
Ignore

v Spell checking
Spell settings (2
Display spell checker dialog

Cut

Copy
Paste

Fonts...

Style

Size

Color
Background color

L A

Possible replacement words are listed at the top of the menu. See below for a description of the Learn, Ignore, and Unlearn menu
commands. To turn spell checking on or off in the field, check or uncheck Spell check (this will reset when window is closed).

The Spell settings submenu contains more options:

e Automatic Language: Automatically identifies dictionary language to be used based on text contents.
e Check grammar: Enables grammar checking of text. Grammar errors are underlined by a dotted green line.

e Automatic correction: Enables or disables automatic correction mode in the field while the window is open. In this mode,
unknown words are automatically replaced by the closest known word (except when the ambiguity is too great). Corrections
are performed during input. By default, automatic correction is disabled.

e Text substitution: Enables or disables text substitution. This consists in replacing one word by another. For example, you
can choose to replace the word "Mr" with "Mister". To create "to be replaced"/"replaced by" word pairs, you must use the
spell checker dialog box (see below): enter the word to be replaced in the "Not in dictionary" area and the replacement word
in the "Replace with" area, then click the Replace Always button. Replacements are performed throughout the application.



This table is merged with the system substitutions ("Use symbol and text substitution" option in the System Preferences). The

substitution process differs depending on whether or not the Show text substitutions option in the Spell settings submenu
is checked (see below).

e Show text substitutions (This option is only shown when the Text substitution option is checked): When this option is
checked, the spell checker underlines possible substitutions in the text with a blue line and the user must right-click on the

word to select the value to be substituted. When this option is not checked, substitutions are performed automatically, without
any user intervention.

e Smart dashes: replaces double hyphens (--) with em dashes (—) during input
e Smart quotes: replaces straight quotes with smart quotes adapted to the current language

e Clear list of ignored words: Erases the list of words chosen to be ignored in the database.

For other options, select Display spell checker dialog from the popup to open the Spell Checking window.

@ & Spell Checking
Mot in dictionary
priavte
Learn lgnare Previous Mext

Replace with

private

Replace Always

Suggested correct spelling

private
privet

In the Spell Check window, you can:

e Learn - Leaves the word unchanged and adds it to your dictionary.

Ignore - Ignores the word for now but will treat it as misspelled in the future.
e Previous - Ignores the word and go to the previous error within the field.

e Next - Ignores the word and go to the next error within the field.



e Replace - Replaces the word with another word found in the dictionary (if any).

e Replace all - Replaces all occurrences of this word in the field

The spelling dictionary is saved in ~/Library/Spelling/en, so any additions you make will be used when checking other records in
ADR Manager, as well as text in other applications.



Backing up

You can backup and restore special "backup" files. Because ADR Manager saves changes constantly, you may want to make a
separate backup of the datafile at certain milestones, such as:
e Before performing a change that will affect many records, such as changing the time format

e During a lengthy conform, in case you want to roll back to an earlier intermediate version (you can always start a conform
over again)

e As regular maintenance

You can make a backup of the currently open database by choosing File > Backup database.

O Backup

Choose,..

Backup folder:
Sam:Users:Steve:Documents: ADR Manager projects: Backups:

Backup note:

Existing backups:

Name When Motes
My Praject[0001].4BK Today 4:4%9 PM Finished temp mix 1
Cancel Advanced...

Choose a folder to store your backups by clicking Choose... above the Backup folder box. Optionally enter a note associated with
the backup. Click Backup Now. A compressed backup file is created with the same name as the datafile, followed by the backup
number in brackets, followed by the suffix .4BK.

— 3
MyProject[Q001].4BK

By default, 6 backup files can be created in backup folder before ADR Manager deletes old backups. In other words, when you
backup a seventh time, the first backup will be deleted, leaving you with backups 2, 3, 4, 5, 6, and 7. You can change this setting



and others, including creating a scheduled backup routine, in the Advanced Backup Settings dialog.



Restoring a database

You can restore a data file to a previously backed up state by selecting File > Restore database.

2] Restore

Backups folder:
Sam:Users:Steve:Documents: ADR Manager projects: Backups:

Available backups:
MName When Notes
My Praject[0001].4BK Today 4:4%9 PM Finished temp mix 1

Backup note:

Destination folder:

Sam:Users:Steve:Documents: ADR Manager projects:

" Restore | Cancel

LIVDOGE, .,

LIVDOGE, .,

Select the folder that contains the backup files by clicking Choose above the Backup folder box. All backup files appear in the
Available backups box. Click on the backup you want restored and select where you want it restored by clicking Choose above

the Destination folder box. Click on Restore.

Restoring a backup when launching ADR Manager

You can also restore a backup file by holding down the option key while launching ADR Manager. This presents a dialog:



You pressed the "Option" key.

Select the operation you want to do:

© Open the application with the default data file
I Select another data file

| Create a new data file

| Restore a backup file

| Open the Maintenance and Security Center

Cancel Continue

Choose Restore a backup file and click Continue to choose the appropriate backup file.




Advanced backup settings

You can modify the default backup settings by clicking on Advanced in the Backup dialog. Several pages' worth of settings are available.

The first page allows you to setup scheduled backups on an hourly, daily, weekly or monthly basis:

ADR Manager - Structure Settings

gt

General Interface Compiler Database Moving E-acl:p Client-server  Web SQL PHP Security  Compatibility
m Configuration Backup & Restore
Automatic Backup: = Persenalized
O Every 1| hour(s) at 00:00
() Every 1| day(s) at 00:00
() Every 1 week(s)
Monday at 00:00
Tuesday at 00:00
Wednesday at 00:00
Thursday at 00:00
Friday at 00:00
Saturday at 00:00
¥| Sunday at 00:00
) Every 1 month(s) at 00:00

Date: | First day

<>

Factory settings Cancel “

The second page lets you designate which parts of the database you want to backup. The Data File contains all your records. The Structure File is the application
itself. The User Structure File is not used. You can also store other files as Attachments. The Backup File Destination Folder is set in ADR Manager's Backup dialog
- no need to set it here. You may leave the Log Management checkbox (log files are beyond the scope of this manual).



& & 8 W

General Interface Compiler Database Moving Client-server  Web saL PHP  Security Compatibility

Backup & Restore

| Factory settings | . Cancel

The third page lets you set the number of backups you can create before they get recycled (i.e. oldest get deleted to make room for newest). You can also direct ADR
Manager what to do in case of backup failure. Ignore the settings under Archive as well as the Automatic Restore area.



& & 8 W

General Interface Compiler Database Moving PHP  Security Compatibility

| Factory settings | . Cancel |




Database issues

Here are some issues you may encounter when opening a data file.

o If you attempt to open a data file that is already open, you may see the following message:

You cannot open this database because the data file (or one
of its segments) is locked.

Q

OK

This could happen, for example, if you are opening a data file that lives on a server, and another user already has it open on
another machine.

e If ADR Manager shuts down abnormally, such as Force Quitting or crashing, the next time you open the datafile you will get
the following message. You can also get this message if you open a datafile that was previously copied while it was open in
ADR Manager.



The database was not shutdown properly last time. Do you
want to check the datafile for corruption?

mEa. -

Click Yes to run a low level check on the datafile to make sure no records were corrupted during the last shutdown.

e If you start noticing strange behavior or incorrect data, you may need to check the database for further corruption or
inconsistencies. These issues can be caused by operator error, bugs in the software, or hardware malfunctions. In most
cases, you can open the data file and run diagnostics. See Running diagnostics for more information.

In some cases you may not be able to open the data file, in which case you will need to circumvent the "automatically open last data
file" feature. Hold down the option key while the application is launching to access the Maintenance and Security Center tool.



Opening another data file

If are having trouble getting ADR Manager to open the proper data file, try using the "option key" method. ADR Manager has a
mechanism that automatically opens the last used data file. To override this feature, hold down the option key while the application
is launching. The following dialog will appear:

You pressed the "Option" key.

Select the operation you want to do:

o Open the application with the default data file
Select another data file
Create a new data file
Restore a backup file

Open the Maintenance and Security Center

Cancel | LU

This dialog gives you several options:

Open the default data file - The "default data file" is the last opened data file. This is the same file that would have opened if
you had not held down the option key.

Select another data file - This allows you to override the "automatically open last data file" feature and choose a different
data file to open.

Create a new data file
Restore a backup file - Lets you choose a backup file to restore. See Restoring a database for more details.

Open the Maintenance and Security Center - This is a built-in tool that lets you perform advanced diagnostics and repair
on any data file. See Using the Maintenance and Security Center for more details.

Choose Select another data file and click Continue to open the desired data file.



Running diagnostics
You can run diagnostics on the records in the database to detect and fix high level logic corruption that may have been caused by
bugs in the software or user error. You can also verify that there are no low level problems in the datafile.

To run diagnostics, choose Diagnostics under the Windows menu. The Diagnostics window opens with the high level diagnostics
tab:

e Diagnostics
Done
?
Datafile  Log
Check the tables you want to analyze, Run diagnastics

then click "Run diagnostics”

Table Number of records
~||Cues 161
~ ||Reels 2
||Reel sets 2
~ ||Scenes 2
||Characters 22
" ||Reports 34
|| Takes 0

Check the tables you want to analyze, then click Run diagnostics. ADR manager runs a specific set of diagnostics for each table
and displays the results under the Log tab. These tests are done on a high level. Repairs are made in memory, however any
changes are not actually saved until you click Done or close the window. This gives you the opportunity to see what is wrong with
the database first before fixing it.

For more severe issues, choose the Datafile tab:



[ JON Diagnostics

Done

| Tables Dataﬂle Log |

To perform a low level check on the records

and indexes of the datafile, click Verify datafile. Vestly datalile

To repair more advanced issues, contact
Slanecon Digital tech support. They will guide
you on using the Maintenance And Security
Center, accessible here.

Open MASC

Click on Verify datafile to perform a low level scan or record integrity and indexes.
Click on Open MASC to open the Maintenance and Security Center. See Using MASC for more information.

Once diagnostics tests are finished in the Tables tab, the window automatically switches over to the Log tab to show the results:



®_@® Diagnostics

Done
?
Tables  Datafile R
hﬂIEDIEDIB 15:39:18 === Start diagnostics ===
10/20/2019% 15:39:18 Checking ADR cues
10/20/2015% 15:39:18 Test: Time fields
10/20/2019 15:39:19 Test: Status and priority validit
10/20/2019% 15:39:19 Test: Reel info
10/20/2019 15:39:19 Test: Name unigueness
10/20/2015% 15:39:20 Test: Cue lineage
10/20/2019 15:39:20 Test: Start time unigueness
10/20/2019% 15:39:20 Test: ID index
10/20/2019% 15:39:20 Checking takes
10/20/2015% 15:39:20 Test: Take lineage
10/20/2019 15:39:20 Test: Take timestamp is within re

Most data errors can be corrected, but some cannot. In the case of a low level verify (under the Datafile tab), no changes are made
to the database. If there are errors detected, you must reopen the database and run the Maintenance and Security Center tool. In
the case of a high level verify (under the Tables tab), most data errors are corrected automatically but data inconsistencies that
require manual correction are noted with "NO ACTION TAKEN." Be sure to check these records after running the diagnostics test
and correct any anomolies. For instance, if the log says a cue name is used in more than one cue lineage, you should change the
current reel set to the "All reel dupes" set and search for that cue name in all reel dupes, then take appropriate action for the
different cues that have the same name.

You can copy and paste the text in this text box to the clipboard for use in another program. The log is also stored in the Logs List if
you want to view it later.

To close the window, click Done.



e

21 changes were made to the database but not saved. Would
you like to save the changes?

If errors were fixed in the database, you will be asked whether you want to save the fixes or discard them. To discard the changes,
click No.



Using the Maintenance and Security Center

ADR Manager has a built in tool to correct problems that the other diagnostics tests do not. It is called the Maintenance and Security
Center (MASC). The utility checks the low level datafile structure, looking for problems in the tables and indexes. Some issues it may
correct include:

e Restoring records that have "disappeared”
e Resolving issues that are flagged by errors when starting up ADR Manager

e Restoring loss of data when moving a database between workstations

It is generally best to use this utility under the guidance of Slanecon Digital tech support, but if you are in a time crunch, this
page describes how to use it.

You can open the Maintenance and Security Center in two ways:

e From within ADR Manager. Open the datafile and choose Windows > Diagnostics > Datafile. Click on the Open MASC button.

[ NN Diagnostics

Done

Tables RECION Log

To perform a low level check on the records

and indexes of the datafile, click Verify datafile. Verify datafile

To repair more advanced issues, contact

Slanecon Digital tech support. They will guide Open MASC
you on using the Maintenance And Security

Center, accessible here.

e When launching ADR Manager. This is useful if the datafile is so corrupted that it cannot be opened. Hold the option key down
while ADR Manager is launching. Select Open the Maintenance and Security Center and click Continue.



You pressed the "Option" key.

Select the operation you want to do:

o Open the application with the default data file
I Select another data file

| Create a new data file

| Restore a backup file

| Open the Maintenance and Security Center

Cancel Continue

Several options are available to you in this tool. You can browse general information about the datafile by clicking on the Information tab.
The Verify tab checks records and indexes without making any changes. The Backup and Restore tabs let you backup to a .4DK file, or
restore from a .4BK file. If your database has lots of free space scattered throughout, you can make the datafile smaller by clicking on the
Compact tab.

However, to repair the datafile, follow these steps:

1. Choose the Repair tab in the bottom left corner of the window.



[ ] [0 Maintenance and security center

Repair

Repair the data fila

Infarmatian
Data file to be repaired: Sam:Users:Steve:Documents:ADR Manager projects:MyProject.
ddd
il Original files backup folder: Sam:Users:Steve:Documents:ADR Manager projects:
The “Replaced files (repairing)" folder will be created at this location
Verify Repair data file options: () Standard repair
Use this methed if only a few records or indexes are damaged.

é "I Recover by record headers
Backup Use this method if the data file cannot be opened and verified first, or if the data

is severely damaged.

Repair

Compact
Repair the structure file
Structure file to be repaired: Sam:Applications:ADR Manager:ADR
Manager.app:Contents:Database:ADR Manager.4DC

ﬁ Original files backup folder: Sam:Applications:ADR Manager:ADR

— Manager.app:Contents:Database:
Restore

The “Replaced files (repairing)" folder will be created at this location
Repair
Repair

2. If you want to repair a different data file, change it by clicking on the "..." button beside the pathname of the data file to be repaired.
3. Choose the "Standard repair" option.

4. Click on the Repair button in the "Repair data file" section. The program will attempt to repair the database. When it is done you can
view what changes were made, if any, by clicking on the "Open log file" button.

5. Close ADR Manager.
6. Reopen the database with ADR Manager (without holding the option key down).
7. Check to see if the problem has been fixed.
You can run the maintenance tools more than once on a data file. Sometimes repairing a data file will bring other problems to the surface
and require another pass with the maintenance tools.
If there still seems to be corruption with the datafile after repairing it, you can try a more drastic approach:
1. Follow steps 1-6 above.
2. Choose the "Recover by record headers" option. This does a low-level reconstruction of the database file.
3. Close ADR Manager.
4. Reopen the database with ADR Manager (without holding the option key down).
5

. Check to see if the problem has been fixed.



Viewing logs

Logs are created when ADR Manager updates a data file to a new version of the program, runs diagnostics, or imports records. You
can view the results of these actions by opening a log in the Logs List window. The Logs List window is opened by selecting Logs
from the Windows menu.

800 Logs
Created Name

1/1/90 00:00:00

11723710 21:50:44 Datafile update to v4.3.9
11/23/10 21:50:56 Datafile update to v4.5.1 beta
11723710 21:50:56 Datafile update to v4.5.2 beta
11/23/10 21:52:39 Diagnostics log 1

Double click on a log to view it:

ano View log
Name : Datafile update to v4.3.9

Created : 11/23/2010 at 9:50 PM

1152372018 21:58:44
Dotafile updaoted to vi.3.9 on Tuesday, Movember 23, 2018 ot 9:58 PM m

Updating cue names:
"ED281" (RZ dupe 2/26/18)
"ED2@2" (RZ dupe 2/26/18)
"ED223" (R2 dupe 2/726/18)
"ED2@s+” (RZ dupe 27264180
"ED2@5" (R2 dupe 27267187
"ED2@E" (RZ dupe 2/26/18)
"ED287" (RZ dupe 2/26/18)
"ED228" (R2 dupe 2/26/18)
"ED289" (RZ dupe 2/26/18)
"ED481" (R4 dupe 2/26/18)
"EDd22" (R4 dupe 25264180
"ED423" (R4 dupe 27264180
"EDB4” (R4 dupe 25264187
"ED4@5" (R4 dupe 2/526/18) ¥

ﬁ j /él

The log shows when it was created and what it was named. You can copy the text in this window to the clipboard, then paste it in
another program. Any changes you make to the text in this window are not saved.



Migrating data from old versions

The data file format has changed in version 7. If you open a data file in ADR Manager 7 that was created in ADR Manager 6 or
earlier, it will be converted. Once a data file is converted, you will no longer be able to open it in version 5 or older. Therefore, it is
important to backup your data files.

If the last version of ADR Manager you used was pre-v5.3.12 (the latest v5 version), update it by opening it in v5.3.12 first. You can
download ADR Manager v5.3.12 from the Slanecon website here.

Once you convert a datafile to v7 you will no longer be able to open it in older versions. Its a good idea to back it up
before opening it with v7!

To migrate databases from really old versions, you must first update them to version 5.3.12 before moving to version 7.
Conversion utilities are installed with ADR Manager v5 to convert databases older than v4.

To update your data file to v7, open the data file:

What are "4D v18" and "v17"? These are versions of the underlying database engine. ADR Manager is built using a database
engine called 4D. ADR Manager version 7 is built on 4D v18 (ADR Manager v5 was built on 4D v12).

Click OK. After conversion, a confirmation dialog appears to ask you whether you want to update the data file:

The database will be updated to the latest version. You can see the changes that were made by viewing the log files. A log file is
created for each intermediate version.


http://www.slanecon.com/support.php

List windows

An ADR Manager database consists of many different tables. Each table has its own List window in which you can view its records.
For instance, character records are displayed in the Character List window and cue records are displayed in the ADR Cue List
window. List windows can be opened using the Windows menu.

[Windows [T

Project

Reels ¥R

Scenes 28]
v ADR cues #G

Takes ¥T

Characters FE K.

Reports H#=M
v Search window 3B F

Transport control 31
Keyboard shortcuts

Diagnostics
Logs

At the top of each List window is a set of buttons, many of which you can use as shortcuts to using the Manage menu:

Lock to
Duplicate Modlﬁf Delete transport Customize Help

PR

+ 4|7 X

Buttons exist to Add, Duplicate, Modify, and Delete records. They apply to what is currently highlighted in the List window.

TIP: In some windows you can batch modify multiple records at once by highlighting them and clicking on the Modify button.

The Lock to Transport button lets you send transport messages (locate, play, stop) to Pro Tools when you click on a record in the
window. See Locking List windows to Transport Control for more information.

You can customize the look of the window by clicking on the Customize button, and get help for a List window by clicking on the
Help button.



Customizing a List window

A List window consists of rows and columns for a particular table. You can customize how the rows and columns look by clicking on
the Customize button at the top of the window.

The Customize List dialog opens:

Settings for ADR Cue List window

Gridlines:

Row height: () Fixed at

[ List | Columns

Sarting '

["] Horizontal
st

Vertical

40) pixels

@ Rows have alternating colors

N

( Alternate colar... )
L. o

@ Adjusted based on data in cells

Sample:

Column A Column B
Cell 1A Cell 1B
Cell 2A Cell 2B
Cell 3A Cell 3B
Cell 4A Cell 4B
Cell 5A Cell 5B
Cell 6A Cell GB
Cell 7A Cell 7B
Cell BA Cell 8B
Cell 9A Cell 9B
Cell 10A Cell 10B

The Customize List Window dialog is divided into 3 tabs.

Under the List tab, you can set general settings for the list and rows:

e You can show horizontal or vertical gridlines by checking the Gridlines boxes.

e To display a different background color on every other row check the Rows have alternating colors checkbox. This can
make the list easier to read. If you click on Alternate color... button you can set the background color. By default the color is

light grey.

e Rows can be a fixed height, specified in pixels, or the height can vary from row to row based on the amount of text in the
cells. In the Columns tab, you can choose which cells will control row height (see below).

A sample of what the list might look like is shown under the settings.

Under the Columns tab, you can select which columns are displayed and what they look like:



Settings for ADR Cue List window

[ List - Columns | 5orting '

Check the columns you want displayed. Highlight a column to change its appearance.

Modified date time

Columns
™ Locked Column: Dialogue
™ Reel name Font: " Geneva =
™ Scene name
E Cue name Size: 10
™ Startand end times Style: [ Bold [ ltalic [ Underline
M Character name
o, G \
& Dialogue Color: [ Text color... )
[ Public notes i Background color... :'
[ Private notes .
™ Public+private notes Hor justification: Default m
O Status Ver justification: Top m
[] Priority
™  Status+Omit+Priority Format:
= . i
€ heetion e inte @ Wrap text @ Resize rows to fit
=

Sample:

Dialogue

Columns you can display are listed on the left side of the window. To make a column visible, check its box. To setup how the
column looks, click on the name to highlight it. Depending on the type of column (text vs. picture), options are displayed on the right
side of the window:

For text fields, you can set the default font name, size, style, and color. Note that you can always apply styles to words
within the text fields of certain records in New or Modify windows. Styled words override List window column styles.

For text and picture fields, you can set the background color, horizontal and vertical justification.
The format setting differs depending on whether the field is a picture, a text field, a number, or a date.
For text fields, you can choose to have the text wrap within the cell rather than continue to the right

For all types, you can choose to have the cell resize the row height so that the entire field is displayed (see List tab above).
If the list rows are set at a fixed height, this option is disabled.

A sample of what the column looks like is displayed at the bottom of the pane.

Under the Sorting tab, you can set how you want the rows ordered in the list:



Settings for ADR Cue List window

[List Columns Snrtin-g]

Drag column names to change how rows are sorted.
Rows are sorted by the first column, then (within that
order) sorted by the next column, etc.

Sort Columns
Up - Reel name

Up = 5tart and end times

Up = Character name

Up » Cue name

Up - Dialogue

Up - Locked

Up - Public+private notes

Up * S5Ccene name

Up - Status+Omit+Priority

Rows are sorted in order of the columns listed. In the example above, the cues would be sorted first by reel name, then by start and
end time, then by character name, etc. To change the order, drag a column name to a new position. You can specify whether you
want a column sorted in ascending or descending order by changing the Sort to Up or Down.



The Project

Each database you create with ADR Manager will hold all of the information for one project. The database is stored on your hard
disk as a set of files.

A project can be a film, TV series, commercial, video game, or any other entity that is contained within its own creative world. It
typically has a list of characters, and a set of reels, episodes, or other types of segments that break down the project into chunks of
time or story logic.

You create a project when you create a database. You can always change the name of a project or any of its attributes, including
its time format.



Creating the project

When you create a new database file, the New Project window opens.

O MNew Project Info
L LR ok ?
Untitled :
Quit
Code name:
Abbreviation: Director: ADR Supervisor:
| Timelines JITTE
Preferred time format Feet frames E

Timecode format: 24 frame timecode H running at = 24 fps u

Feet and frames format: | 35mm feet and frames E running at | 24 fps E

Sample rate: 48 kHz H

Enter the project info:

e Enter the project name. You can change the name later. As a default, the project name is set to the name of the database. It
is usually a good idea to have the name of the database and the name of the project match, so that you can tell in the Finder
which project resides in which database.

e If the project has a code name or working title, enter it it here (optional). If you enter a code name, it will be displayed at the
top of each report. Otherwise, the project name will be displayed at the top of each report.

e The abbreviation is used when creating the PDF filenames of certain reports.
e The Director name can be displayed in the watermark of reports for the director.
e The ADR Supervisor name can be used in the watermark of reports for the editor.

e Under the Timelines tab, select your preferred time format (project time) by choosing Feet and frames or Timecode. You
can change the individual time formats or the preferred time format at any time (see Changing time formats).

o Define the feet and frames format, timecode format, and sample rate you will be using. If you are using Pro Tools in
conjunction with ADR Manager, you should set your formats to match your Pro Tools session setup. See Creating reels for
more information on how to make timelines in ADR Manager match your Pro Tools sessions.

The following timecode formats are available:

o Non-drop timecode running at 30 fps or 29.97 fps

o Drop frame timecode running at 29.97 fps or 30 fps



25 frame timecode running at 25 fps or 24.975fps
o 24 frame timecode running at 24 fps or 23.976 fps

The following feet and frame formats are available:
o 35mm feet and frames running at 25 fps, 24 fps or 23.976 fps

The following sample rates are available:
o 44.1 kHz
o 48 kHz
o 88.2kHz
o 96 kHz
o 176.4 kHz
o 192 kHz

e You can store notes with the database under the Notes tab.

Click OK to initialize the database.

Once the database is initialized, it will import default reports and default keyboard shortcuts. Reports must live in the database in
order to be used. You can import additional reports at any time, including actor cue sheets, editor cue sheets, mixer cue sheets,

master cue sheets, cue count tables, reel lists, character lists, and continuity lists. See Importing a report from a record file for more
information.

After the default reports and keyboard shortcuts are imported, the Reel List, ADR Cue List, and Search windows will open.




Changing project information

Information about the project is displayed in the Project Info window by choosing Project under the Windows menu.

] Project Info

Project name: Apply changes ?
My Project |

Code name:
Secret Code

Abbreviation: Director: ADR Supervisor:
SC Alan Smithee Joe Supe

Timelines L[

Preferred time format: = Timecode
Timecode format: 24 frame timecode running at = 24 fps
Feet and frames format: 35mm feet and frames running at | 24 fps
Sample rate: 48 kHz

This window gives you general information about the project. See Creating the project for an explanation of each field.
The Timelines tab displays the database time formats. See Changing time formats for more information.
The Notes tab displays any text you may want to store with the project.

To modify project settings, change them in the window and click on Apply changes.



Changing time formats

In the Project Info window under the Timelines tab, the time format you are currently using, called the preferred time format, is
shown at the top of the tab area. This is the format used to input and display time for all records in the database.

Preferred time format: = Feet frames E
Timecode format: 24 frame timecode E running at = 24 fps E
Feet and frames format: 35mm feet and frames E running at = 24 fps E
Sample rate: 48 kHz E

Changing the preferred time format will cause all time-related records (cues, reels, and scenes) to be updated based on the new
settings. If you are changing the frames per second rate of the preferred time format, you can retain the time values for all records
or have the values recalculated based on the new rate.

You have changed the timecode type and frame rate. Do you
want to keep the start and end times you've entered for cues,
reels, scenes, etc, or do you want them to be recalculated based
on the new settings?

ﬁ Recalculate Cancel

Click on Keep to retain the displayed times, or click on Recalculate to recompute the displayed times. If you choose to recalculate
the displayed times, each time field will be converted to seconds relative to the beginning of the record's respective timeline, then
converted into the new time format. For instance, a cue's start time will be converted to seconds relative to it's reel's FFOS time,
then back to the new time format.

The project sample rate is used when importing and exporting to Pro Tools, as well as handling audio files. Set it to match the
sample rate you are using in Pro Tools.



Note that the Transport Control assumes that incoming and outgoing MIDI timecode is in the project's timecode format.



Cues

Cues are the records that contain information about each ADR line you wish to record.

® [ ] ADR Cue List
+| 47X < @ 2
L Reel Scene  Cue name Start/End Character Dialogue All Notes Status/Prty
o1 8 CS5H103 823+15 Carter Cushing Sir Thomas Sharpe. Welcome to our  production nolse Spotted
828+11 fair city. - Medium
o1 8 THMS111 230+04 Thomas Sharpe Sir! It's my pleasure. production nolse Spotted
833402 - Medium
i o 8 CS5H104 833+05 Carter Cushing 1 see you've already met my daughter production nolse Recorded
236:00 Edith. - Medium
ﬂ 01 a8 THMS112 £35+15 Thomas Sharpe =*inhale/exhale* production nolse Recorded
B48+15 - Medium
o1 8 EDTH107J 838+12 Edith Cushing *breaths* production nolse Spotted
B43+06 - Medium
01 2] THMS113 897+03 Thomas Sharpe This machine could revolutionize clay machine under DX Spotted
991+14 mining as we know It - Medium
01 2] LG101 934+13 Loop Group  Men laughing In background 10 men, older industrialists  Spoffed
949+01 - Medium
01 2] LG102 973+04 Loop Group  Men laughing In background 10 men, older industrialists  Spoffed
980+14 - Medium
01 2] 976+15 Ferguson *closed mouth laughing* additional Spotted
nAT0.AC - Merinm

2 of 76 ADR cues selected (329 cues in "Latest reel dupes' reel set)
w0y

ADR Manager stores the following information about each cue:

e Which reel and scene the cue is in

e The unique name of the cue

e What time the cue starts and ends

o What character the cue belongs to

o What dialogue the cue contains

e General notes about the cue

e Priority and status information about the cue

o Whether the cue is locked or unlocked
You assign cues to reels and characters when you create them. Reels must be created beforehand. A cue must start within the limits of the reel you've assigned it
to (between the FFOA and LFOA, inclusively). Cues are automatically assigned to scenes based on the cue's reel and start time. A cue's dialogue and notes can

contain virtually any amount of text. Cues also store priority and status information. You can lock and unlock cues to prevent them from accidentally being
modified.



Cue statuses

A cue always has a particular status. You typically change the status of a cue after you've done some action to it, such as spotting,
recording, or cutting. Keeping a cue's status up to date lets you search and generate reports based on those statuses. The status
"levels", in order, are:

e Spotted

e Printed

e Recorded
e Transferred
e Loaded

e Cut

e Premixed
e Final mixed
e Print mastered
e QCled

e Shipped

Each status represents an increasing level of completeness, so "Recorded" is considered a greater status than "Spotted". You can
find cues based on whether a cue's status is <, =, or > a specified status.

Omitted status

You can also mark a cue as omitted without deleting it from the database. This may be the case if the cue was spotted, then
omitted for various reasons, only to be recalled again later. Sometimes it is helpful to keep omitted cues in the database as a log of
what has already been spotted, whether or not it was recorded. Omitted cues are affected along with "normal" cues during
conforming. Some reports automatically leave omitted cues out when printing, or you can manually remove omitted cues from
reports before they are printed.



Cue lineage

When you create a new dupe of a reel, the cues are copied (not moved) into the new dupe. That means the original cues remain,
regardless of whether you change or delete the cues in the new dupe. However there are lineage ties created between the original
cues and the copies. A lineage tie ensures that certain changes you make to a cue in an old dupe get reflected in its descendants in
later dupes (a cue in an older dupe is considered the ancestor of a cue in a newer dupe).

For example, let's say you have three versions of reel 6 - v1, v2, and v3 - and you are recording an actor to v2. When the session is
done, you'll want to change the status of the actor's cues to "recorded". Then, you would have to open up v3 of reel 6, find the
corresponding related cue, and change it to "recorded" as well. You also may want to update the status of the ancestor cue in
version 1. Since ADR Manager knows what cues are related to other cues, it will save you time (and potential errors) by
automatically updating ancestor and descendant cues.

Changes are always propagated to descendant cues. Changes are propagated to ancestor cues only if you choose to do so by
setting a preference (see Cue status preferences). Changes that get propagated are:

e Cue name (always propagated to all ancestor and descendant cues)

e Dialogue, unless it has an embedded time

e Public notes, unless it has an embedded time

e Private notes, unless it has an embedded time

e Status

e Periority

e Omitted

e Locked/unlocked
Note that when cues are conformed, they may be split up into several pieces, such as when you insert time in the middle of a cue.
When a cue is split, the pieces may or may not remain in the "family tree" depending on whether the cue is recorded or not. If the
cue has not been recorded yet, the first piece remains in the family tree and the other pieces start new trees; that is, they are no
longer linked to the original ancestor and their cue names are erased. If the cue has been recorded, all pieces remain in the family

tree. In this case, be aware that if you modify a descendant piece and propagate the changes to the ancestor, the descendant's
siblings will not get the change.

Also note that imported cues are not inserted into any family trees even though they may have the same cue names as other cues
in the database.



Embedded times in text fields

Sometimes you may want to denote when a specific event occurs within the dialogue or notes fields of a cue. You can do this by
embedding a time within the field. Embedded times are recognized by ADR Manager and converted when you change time format.
They are also conformed when the cue is conformed.

For example, you could use an embedded time if a character is offscreen and then comes onscreen halfway through the cue. You
could denote the time when he come onscreen like this:

Dialogue

Mr. Cushing!
(Onscreen 568+15:) Please come in

There are several ways to embed times:

e You can enter a time manually by using the longhand method as described in Entering times. You cannot use the
shorthand method. If the time value is typed in shorthand, ADR Manager will not recognize it as a time value.

e You can select Insert current time from the Manage menu to grab the current incoming MIDI time (shown in the Transport
Control window) and insert it at the cursor location. If text is already selected in the field, it will be replaced by the inserted
time. If the cursor is not in a time or text field, the command is ignored.

e You can grab time from Pro Tools using a macro.

Be careful not to type text that may be interpreted by ADR Manager as a time field. For example, if you enter a keycode such as
123456+12 into the Notes field and then try to change the preferred time format from feet frames to timecode, ADR Manager will
attempt to convert the keycode string to timecode. At best this would flag an error, at worst the keycode would be silently
replaced with a timecode value. If you want to store time strings in text fields but don't want them recognized by ADR Manager,
add a space before or after the colon or plus signs so that they do not have proper time field syntax.



Spell checking cues

ADR Manager utilizes a built-in dictionary to check text for spelling mistakes. The following ADR Cue fields are checked:
e Dialogue
e Public notes

e Private notes

You can check spelling as you enter information about a cue, or highlight multiple cues and spell check all of them at once.

To spell check a text field

In the New Cue or Modify Cue windows, any misspelled words are underlined in red as soon as you stop typing. To fix a misspelled
word, right-click (control-click) on the word and choose a replacement listed at the top of the menu. If you want more options, select
Display spell checker dialog from the popup to open the Spell Checking window. You can also choose Manage > Spell Check
from the main menubar when the cursor is in the field you want corrected. For more information, see Spell Checking.

To spell check multiple cues

In the ADR Cue List window, highlight all of the cues you want to check and choose Manage > Spell check cues.... For each cue
that has a spelling error, the Correct Misspelled Words dialog opens and the first misspelled word is underlined and highlighted:

[ NN ) Correct misspelled words
Cue name JK102 L Modif ) Prev Next | 2
Modify & Next Cancel
Reel 01 dupe 12/31/18 Y
Scene -
Status = Spotted Omitted
Start time End time weleni e
r Medium
12418 | @@ 40+00 Foerchi) 4
Character Public notes
Jack
Dialogue

Is there a doctor in fgh house?
Private notes

Right-click on the word or choose Manage > Spell check to fix the problem, as described in Spell Checking. Click on Previous or
Next to go to the next misspelled cue.



Displaying cues

Cues are displayed in the ADR Cue List window. See List windows for a description of the buttons at the top of the window. Adding, duplicating, deleting, and
modifying cues can be done only when the ADR Cue List Window is active:

0O ADR Cue List
+ & /X < | 2
L Beel Scene  Cue name Start/End Character Dialogue All Notes Status/Prty
o1 8 CSH103 823+15 Carter Cushing Sir Thomas Sharpe. Welcome to our  production nolse Spotted
828+11 fair city. - Medium
o1 8 THMS111 230+04 Thomas Sharpe Sir! It's my pleasure. production nolse Spotted
833+02 - Medium
ﬂ 01 8 CSH104 £33485 Carter Cushing I see you've already met my daughter production nolse Recorded
836+00 b, - Medium
ﬂ 01 8 THMS112 835+15 Thomas Sharpe *inhale/exhale> production noise Recorded
B4@+15 - Medium
01 8 EDTH107J &38+12 Edith Cushing *breaths* production nolse Spotted
843+06 - Medium
01 ] THMS113 297+03 Thomas Sharpe This machine could revolutionize clay maching under DX Spotted
901+14 mining as we know it - Medium
01 ] LG101 934+13 Loop Group Men laughing in background 10 men, older industrialists  Spotted
948+01 - Medium
01 ] LG102 973+04 Loop Group  Men laughing in background 10 men, older industrialists  Spotted
980+14 - Medium
01 2] 976+15 Ferguson *closed mouth laughing™ additional Spotted
ATo.aC - Marfiim

2 of 76 ADR cues selected {329 cues in 'Latest reel dupes' reel set)

To open the ADR Cue List Window, select ADR cues from the Windows menu, or type command-G.

At the bottom of the ADR Cue List Window is some information describing how many cues are currently displayed in the window, how many are selected, and
how many total cues are in the current reel set.

The window displays the following columns as a default. You can customize the window by clicking on the_Customize List button in the upper right corner.
e Locked — Shows whether the cue is locked. If a cue is locked, it cannot be modified except during a conform.
o Reel number — Which reel the cue is in. If the "All reel dupes" set is active, the reel column also displays the reel version or dupe date.
e Scene name — Which scene the cue falls under.
e Cue name — The cue's name, if one has been assigned.
o Start and end time — The start and end time of the cue, in the currently displayed time format.
e Character name — The character to which this cue belongs.
e Dialogue — The first three lines of dialogue for the cue.
o All Notes — The public notes on the first line(s), followed by the private notes on successive lines.
e Status and priority — The status (i.e. "Spotted", "Recorded", etc) of the cue (first line), followed by whether the cue was omitted or not (second line),
followed by the priority of the cue (third line).
The Lock to Transport button lets you locate Pro Tools when you click on a cue. See Locking List windows to Transport Control for more information.

Example: You are working on a feature film, and each reel starts at an hour timecode (i.e. Reel 1 = 01:00:00:00; Reel 2 = 02:00:00:00, etc). You have a Pro
Tools session containing all reels, each at their respective hour. If you lock the Transport Control to Pro Tools, you can jump to a cue anywhere in the film and
play it without leaving ADR Manager.

Use the Customize List button to change the way cues are sorted in the window.

When the ADR Cue List Window is active, the Manage menu will change:



it Windows Help

Add cue... 3EN
Duplicate selected cues... #D
Modify selected cues...
Delete selected cues...

Split cue...
Merge cues

Rename selected cues...
Clear selected cue names...

Lock selected cues L
Unlock selected cues U

Create take for selected cues {+38A
Show related takes

Use these menu items to add, duplicate, modify (including batch modify), delete, split, merge, and spell check cues. You can also rename and lock or unlock
cues. You can also create and find takes for the currently selected cues.




Sorting cues

Cues are sorted by settings in the Customize List dialog. The default sort order is by reel, then by start time (FFOA). However, ADR
Manager allows you to perform a more granular sort on cues that start at the same time (FFOA).

To reorder cues, highlight one or more cues in the ADR Cue List window that have the same start time. Option-drag them up or
down in the list. A rectangle will appear around each row as you drag over it, showing you where the cues will be dropped when you
release the mouse. Drop the cues on another cue that has the same start time. The dragged cues will be positioned before the cue
you dropped it on, shuffling other cues up or down.

You cannot change the start time (FFOA) of a cue by option-dragging it, only the order in which it appears with other cues of the
same start time.

The ability to sort cues within a start time is particularly useful for cues in the WILD reel, which all share the same start time of
NULL.

The new order will appear in the ADR Cue List window and on reports.



Creating cues

You can manually create cues, or import them from various types of files such as Pro Tools session text files or tab delimited text
files. To find out more about importing, such as spotting in Pro Tools then importing the session into ADR Manager, see Importing
and exporting. This section describes how to spot cues manually.

To create a cue, you must have the ADR Cue List Window open and active. Select Add cue from the Manage menu, or type
command-N. The following dialog will appear:

® @ New Cue
Cue name 4 | _ OK & Next ?
Reel 01 | 2  dupe 2/5/22 Carncel
Scene .= __
Status Spotted Omitted
Start Time End Time Dot Medi ~
| 1200 i 5 e S 5
Character 4] Public notes (5]
Dialogue a
Private notes 3]

Enter the cue's name, reel, start and end times, character, dialogue, status, priority, public notes, and/or private notes. For more
information about how to enter values into the various fields, see Entering information for a cue.

The New Cue window can be resized vertically. The dialogue and private notes boxes will grow accordingly.



Entering information for a cue

The New Cue and Modify Cue windows share many of the same fields. This section describes those fields.

Autofill cue name Sticky padlocks
[ ] @® New Cue
Cue name 7| GMCKEMN  okgned 7
Reel ® Cancel
Scene --

Status Spotted Omitted

Start Time End Time o :
Priority Medium |
Character Public notes
»
Dialogue

Private notes

The following fields can be entered for an ADR cue:

e Reel number - The first time you open the New Cue Window for a project, the reel number field will be selected. You can either
enter a valid reel number here, or select "WILD" from the Reel popup menu. If you select "Reel" then you must enter the number
of a reel that is in the current reel set. Type in the reel number, then hit tab or click on another field. The version or dupe date of
that reel appears so you know you are adding this cue to the correct reel dupe. If you select "WILD", the reel number and version
or dupe date fields disappear. Other fields disappear as well; namely the cue start and end time fields, and the scene name and
description fields.

e Cue name - The cue name field can be left blank for now or you can enter a value. You can have ADR Manager automatically
generate a cue name by clicking on the Autofill Name button, or by batch renaming cues from the ADR Cue List window. You
can also have ADR Manager automatically add a cue name by turning on the autofill name preference and setting other fields in
the window. Specifically, if the cue is in the WILD reel, the cue name will be generated once you've entered the character. If the
cue is in a numbered reel, the cue name will be generated once you have entered a valid reel number, start time, end time, and
character. Cue names must follow the naming convention defined in the Cue Naming tab in the Preferences window. Hit tab or
click on another field to deposit the cue name.

e Start time - Enter the start time of the cue (see "Entering times" below). Be sure that the time you enter is between the FFOA
and LFOA of the reel. Hit Tab to go to the next field. The next field is determined by several preferences: If the "autofill end time"
preference is off (see Data entry preferences) then the end time field is selected. Otherwise the character field is selected. Once
you've entered a valid reel and start time, the scene that contains the cue is displayed below the reel.

e End time - Enter the end time of the cue (see "Entering times" below), otherwise leave this field blank if you don't want to specify



an end time. Be sure that the time you are entering is between the FFOA and LFOA of the reel. Hit Tab to go to the next field. If
the "round-off end time" preference is on, the end time will be automatically rounded up to the next nearest whole second or foot.

Character - To enter a character, choose it from the popup beside the field or type its name. As you type, ADR Manager will
automatically fill in the rest of the field with a character name that matches what you have typed so far. If you type the name of a
character that does not exist in the database and hit tab or return, you will be prompted to create the character (remember you
must give it a unique abbreviation as well). You must enter a valid character name in order to save the cue.

Dialogue - Type in the dialogue for the cue. This is exactly what will appear in the reports, so if you want quotation marks or
parentheses around the dialogue in the reports, you must type them in here. Also, if you type a return while in this box, the return
will be entered as part of the dialogue, not as a means to submit the text you've entered. There is virtually no limit to the amount
of dialogue you can enter for a cue. You can enter times in the dialogue that will be updated if the cue ever gets conformed or
converted to a new time format (see Embedded times in cue fields). As you type, spelling is checked by the built-in spell checker
and any misspelled words are underlined in red. To submit the text you've entered, hit tab, click on another field, or hit the enter
key to save the cue.

Status - Choose an initial status for the cue by clicking on the popup menu. As a default, the cue is set to the lowest level of
status: Spotted. You can use the status and omitted fields to monitor the progress of ADR cues while you work on your project.

Omitted - Check the omitted box if you would like to add this cue to the database, but mark it as omitted. Using the omitted
checkbox allows you to keep cues in the database that you don't want included in reports or cue count tables, but still want them
in the database for reference.

Priority - Assign the priority of a cue by choosing a level in the priority popup. You can then search by priority and print this field
in your reports. The default priority for a cue is "Medium".

Public notes - Type in public notes for the cue. They will appear in all reports. This is exactly what will appear in the reports, so if
you want quotation marks or parentheses around the notes in the reports, you must type them here. Also, keep in mind that if you
type a return while entering text, the return will be entered as part of the notes, not as a means to submit the text you've entered.
You can enter as much text into this field as you want. You can type in embedded times in the public notes that will be converted
and conformed with the cues (see Embedded fimes in cue fields). As you type, spelling is checked by the built-in spell checker
and any misspelled words are underlined in red. To submit the text you've entered, hit the tab key to move to another field, or
click on another field, or hit the enter key to save the cue.

Private notes - Type in any private notes for the cue. They will appear in all cue sheets except the actor cue sheet. The
primary use of this field is to allow you to enter text separate from the notes field (i.e. notes about the actor's performance), so
that you can choose not to have the actor see it. If you want quotation marks or parentheses around the private notes in the
reports, you must type them here. Also, keep in mind that if you type a return while entering text, the return will be entered as part
of the notes, not as a means to submit the text you've entered. You can enter as much text into this field as you want. You can
type in embedded times in the notes that will be converted and conformed with the cues (see Embedded times in cue fields). As
you type, spelling is checked by the built-in spell checker and any misspelled words are underlined in red. To submit the text
you've entered, hit the tab key to move to another field, or click on another field, or hit the enter key to save the cue.

Entering times

You can enter times in several ways:

You can enter a time manually, complete with colons or plus signs. Or you can use the shorthand method if you are in the start or
end time field.

You can use Set start time to MIDI or Set end time to MIDI under the Manage menu to put the current time in the start or end
time, even if the cursor is in a different field.

You can paste start and end times from the macOS clipboard using the Paste start time, Paste end time, or Paste start and
end times under the Manage menu. The value(s) are pasted into their respective fields, even if the cursor is in a different field.

You can select Insert current MIDI from the Manage menu to grab the current time and insert it at the current cursor location. If
the cursor is in a text field such as dialogue, public notes, or private notes, and text is already selected in the field, it will be
replaced by the inserted time. If the cursor is not in a time or text field, the command is ignored.

You can use a keyboard shortcut to insert the current time in the start time, end time, or any text field.

You can use a Keyboard Maestro macro to copy and paste the start and end times from Pro Tools Edit window into the start and
end time fields in ADR Manager. See Grab time from Pro Tools using a macro for more info.

For your convenience, the following keyboard shortcuts are available in the New Cue window to quickly enter data:



e Enter = click on OK button
e Option-enter = click on OK & Next button
e Escape = click on Cancel button

You can define your own keyboard shortcuts to insert text into various text fields such as the dialogue and notes fields. See the chapter
on Keyboard shortcuts for more information.



Saving the cue

Once you have entered all the information, you can save the new cue in two ways: by clicking on the OK button, or by clicking on
the OK & Next button. If you click on the OK button, the cue is saved and the New Cue Window closes. If you click on the OK &
Next button, the cue is saved and the New Cue Window remains open, ready for another cue. Previous values in the start and end
times, character, dialogue, cue name, and notes boxes are cleared out, unless their respective sticky checkboxes are turned on.
The ADR Cue List Window will scroll so that the newly saved cue appears in the middle of the window.

If you decide you don't want to save the cue, click on Cancel or type Escape. This will close the New Cue Window without saving
the cue.



"Sticky" values

Padlock buttons next to fields are used to make values "stick" from cue to cue. This is useful if you are adding several cues in
succession using OK & Next, but you don't want to have to retype a certain value each time. To make values "stick", click the
padlock icon located next to the field, or hold the command key and type the number displayed within the icon.

9 New Cue
Cue name | 4. eI  OK&Next  ?
Reel 01 |2 | dupe2/5/22 Cancel
Scene ==
Status  Spotted Omitted
Start Time —~ End Time N P vy abﬂ'
112405 (@) 118406 | ﬁ_{_l rEr el e/
\‘-\-_- \"“. __ o
Character 'KEI ) Public notes 'fﬁ\'
Jack ~ 2 =
: T _H‘w,
Dialogue I_‘ﬁ J
There's only one thing left. - —_
. f’ﬁ‘*-
Private notes | J

Mic bump

This can be useful, for example, if you want to enter several cues that have the same start time, or several cues that are for the
same character:

1. Enter the information for the first cue, then click the padlocks whose values you want to use for successive cues.
2. Click on OK & Next, and the values you've made "sticky" will remain. All other fields will be cleared.

3. When you no longer want a value to stick, unlock its padlock.

Note the reel number is always sticky, and the cue name is never sticky.



Duplicating cues

To duplicate cues, you must have the ADR Cue List Window open and active. Click, shift-click, and/or command-click the cues you
would like to duplicate, then select Duplicate selected cues from the Manage menu. For each selected cue, a new cue will be
added to the ADR Cue List with identical information to the selected cue.

The duplicate cue's name will be cleared, and the cue will be unlocked. You will probably want to modify the duplicate by double-
clicking on it.



Modifying a cue

You can modify cues one at a time, or multiple cues in a batch operation. To change multiple cues, see Modifying multiple cues. To
modify a single cue, double-click on it in the ADR Cue List Window, choose Manage > Modify selected cues, or click on the

Modify button in the toolbar. The Modify Cue Window opens:

o o Modify
Cue name LG101 * Prev MNext 7
Scene 2 -
Status = Spotted T ] Omitted
Start time End time Priori Medi e
106+14 || 115:@2 riority | Medium )
Character Public notes
Loop Group o Add
Dialogue
(Surfer dude riding the virtual waves)
(Vocals and callouts) Private notes

Get efforts too

Change the cue's reel, character, cue name, start and end times, dialogue, status, priority, public notes, and/or private notes. For
more information about these fields, see Entering information for a cue.

The duration padlock between the start and end time fields locks the duration of the cue, which is helpful if you need to re-spot the
cue. If you change the start or end time, the other time will automatically be recalculated to maintain the cue's duration. Click on the
padlock icon or type command-1 to lock and unlock it.

To save and close the cue, click Modify. To save the cue but modify the next cue without closing the window, click on Modify &
Next. The ADR Cue List Window will attempt to scroll so that the last modified cue is highlighted and appears in the middle of the
window.

You can move to the previous or next cue using the Prev and Next buttons. If you have made changes to the cue, a dialog will ask
if you want to save the changes. Hold the option key down while clicking the button to save without asking. If you move beyond
the list (before the first cue or after the last cue), the Modify Cue window will close.

For convenience, the following keyboard shortcuts are active in the Modify Cue window:

e Enter: Same as clicking on Modify button
e Option-enter: Same as clicking on Modify & Next button

e Cmd-left-arrow: Same as clicking on Prev button.



e Cmd-right-arrow: Same as clicking on Next button.
e Escape: Same as clicking on Cancel button
Note the cue lineage will be affected. Descendants of the modified cue will be updated to reflect the changes you make in this

window. Ancestors may be updated depending on your preference settings. However, in order to preserve embedded times in text
fields, ADR Manager will not update a text field in a descendant or ancestor cue if it contains an embedded time.

Take, history, and lineage information is shown by expanding the Modify Cue window. Click on the disclosure triangle at the bottom
left of the window.

® @ Modify
Cue name SHOZ2_1210 Cue is locked Prev Next ?
Reel 12 ~  dupe 3/28/17 Unlock cue Cancel
Scene --
Status = Recorded * Omittec
Start time End time Priorl -
Medium o
518401 8 523+03 rlarity | Me
Character Public notes
Sho v2 &
Dialogue

(Effort as he is dragged backwards)
Private notes

O

Ta History Lineage

Name Mum Sub Dialogue
gl  SHOZ 1210 01 1 (Effart as he Is dragged backwards)
gl  SHOZ_1210 02 2 (Effort as he Is dragged backwards)
£l SHO2_1210 03 3 (Effart as he Is dragged backwards)

For information about viewing and auditioning takes under the Takes tab, see Viewing a cue's takes.
The History tab shows when the cue was created and last modified.

For information about viewing and managing a cue's lineage, see Modifying cue lineages.






Modifying a locked cue

If a cue is locked, you cannot change any of its fields. When a locked cue is displayed in the Modify Cue window, either by double-
clicking on it in the List window or by the Prev or Next buttons, all fields become disabled and the Modify and Modify & Next
buttons are replaced with the Unlock cue button:

| NN ] Modify
Cue name Cue is locked Prev Next ?
Scene 2
Status = Spotted o Omitted
Start time End time Priorit =
| I =
106+14 —f3 115407 rlofity | Mediu
Character Public notes
Loop Group -
Dialogue
(Surfer dude riding the virtual waves)
(Vocals and callouts) Private notes

Add?

Click on the Unlock cue button to unlock the cue. The Modify and Modify & Next buttons will reappear and all fields will become
enabled.



Viewing a cue's takes

You can show a cue's takes in two ways:

e Highlight one or more cues in the ADR Cue List window and select Manage > Show related takes. The related takes will
appear in the Takes List window.

e Open a cue in the Modify Cue window, extend the window by clicking on the disclosure triangle in the bottom left of the
Modify Cue window, and click on the Takes tab.

The Takes area in the Modify Cue window shows all takes related to the cue.

m History  Lineage

Name Num Sub Dialogue
]  SHOZ 1210 01 1 (Effart as he is dragged backwards)
]  SHO2_1210 02 2 (Effort as he Is dragged backwards)
g SHO2 121003 (3) (Effart as he is dragged backwards)

Speaker icons show which takes are currently auditionable. If the speaker icon is filled in, the audio is auditionable. Hollow speaker
icons mean the take has audio, but it is not currently online. No speaker icon means the take has no audio associated with.

If a take has online audio, you can click on it to audition it. An audio player appears below the list. For more information, see
Auditioning audio files.

History Lineage

Name Num Sub Dialogue
o)) KAR106_06_01 1 Light it up.
o)) KAR106_06_01 1 Light it up.
] KAR106_06_02 2 Light it up.
] KAR106_06_02 2 Light it up.
] KAR106_06_03 3 Light it up.

Mono E
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Viewing a cue's history

To see the creation date and modification date of a cue, open the Modify Cue window, extend the window by clicking on the
disclosure triangle in the bottom left of the Modify Cue window, and click on the History tab.

Takes m Lineage

Created yesterday 12:23 PM
Modified today 11:27 PM

A descendant cue always has the same creation date as its ancestor.



Modifying cue lineages

You can add ancestor and descendant cues (see Cue lineage) by opening the cue in the Modify Cue window, extend the window by
clicking on the disclosure triangle in the bottom left, and and opening the Lineage tab.

[ NN Modify
Cue name FK101 _ Prav Next 7
Reel ~  dupe 11/9/19 Modify & Next Cancel
5cene ==
Status = Spotted Omitted
Start time End time Priorit Medi
14412 | _fn— 22405 rority um -
Character Public notes
Frank 2 | |Offscreen
Dialogue
Hey, it's me!

Private notes

As per director

O

Takes Histo Lineage
.D

L  Reel dupe Scene Cue name Start/End Character Dialogue
01 - FK101 12+0@ Frank Hey, it's me!
11/8M19 20+08

Click on the plus sign above the list of current cues in the lineage.

A window appears letting you choose which dupes you would like to add related cues to:



@ Modify cue lineages

Add ancestor/descendant cues in the
following dupes:

Reel Version Dupe
01 vd BfBS17
01 v5 8/1/17
W oo VB S/1R8/17

BOKRY  cancel 2

Check the dupes to which you want to add related cues. Dupes that already contain the original cue, an ancestor cue, or a
descendant cue are already checked. You cannot uncheck these checkmarks.

When done, ADR Manager will create duplicate cues in the reel dupes you selected. The cue(s) will have the same start and end
times as the original cue and be related to the original cue (either as an ancestor or as a descendant). You should adjust the start
and end times of the newly created cues to account for the differences in where they fall in their respective reel dupes.



Batch modifying cues

To modify multiple cues in a single operation, select the cues in the ADR Cue List window by clicking, shift-clicking, and/or control-
clicking. Then choose Modify selected cues under the Manage menu, or click the Modify button in the List window toolbar. The
following window opens:

o o Modify Multiple Cues

L Medifg 7

Cancel
Reel 01 % | dupe 11/8/19
Status = Spotted E B Omitted
Move times by Priority = Medium u
Character Public notes Anpendo Replace
Frank & |Offscreen
Dialogue OAppend Replace

Private Notes () Append | Replace

Common field values are displayed in the window, and any fields that do not have the same value among the selected cues are left
blank. For instance in the example above, all of the selected cues are from reel 1, so the "reel" field is filled in with the number "1".
The "dialogue" field is blank, meaning the selected cues have different dialogue. You may enter values in the blank fields or
overwrite the common fields. If you leave a field blank, that field will not change in the selected cues. You can either append or
replace text in a text field by choosing the appropriate radio button above it.

For example, if you wanted to move the selected cues to a new character (whether or not they all belong to the same character to
begin with), enter the new character name. Another example might be if you've just finished recording a set of cues, you could
select them in the ADR Cue List Window, open the Modify Selected Cues Window, and set the status popup to Recorded.

To move all selected cues by the same amount, enter a time in the Move times by field. Embedded times will be updated by the
same amount.

Descendant cues of the modified cues will be updated to reflect the changes you make in this window. Ancestor cues may be
updated depending on your preference settings (see Cue status preferences). However, in order to preserve embedded times in
text fields, ADR Manager will not update a text field in a descendant or ancestor cue if it contains an embedded time.

Note that if you move cues to a new reel, they will retain their lineage ties to ancestor cues in older dupes of their original reel.

For more information about the fields in the Modify Selected Cues Window, refer to Entering information for a cue.



Splitting a cue

You can split a cue into two cues. This can be helpful, for example, if you want to break up a cue in order to hit multiple sync points within a long stretch of dialogue.

Highlight the cue in the ADR Cue List window.

e ® ADR Cue List
+ %/ X & | (2
Reel Scene Cue name Start/End Character Dialogue All Notes Status/Prty
189404 Recarded for Comicen trailer QAMITTED
Mot in w4 cut - Medium
01 4 WD1905 198+14 Wade In 2045, It's still ranked the fastest Recorded
196+08 growing city on Earth, but it sure Recorded for Comicon traller - pMedium
doesn't seem like it when you live in
the stacks.
01 4 WD1906 204+05 Wade They called our generation the Recorded
208+07 missing millions. Recorded for Comlicon traller - Meaium
1 of 151 ADR cues selected (151 cues in 'R1 test' reel set)

Select Manage > Split cue. The Split Cue window appears:

ecCe Split cue
SRS L selit
Reel 01 dupe 9/18/17 Cancel
Scene 4 )
Start time split time End time
190+14 193+1@ 196+08
Character
Wade

Place cursor where you want to split the dialogue:
Dialogue

In 2045, it's still ranked the fastest growing city on Earth, but
it sure doesn’t seem like it when you live in the stacks.

Enter the time where you want to split the cue, and position the cursor in the Dialogue box where you want the text split. Click OK. The original cue will end at the
split time, and its dialogue will be truncated where you put the cursor. Another cue will be created that starts at the split time, and contains the dialogue after the
cursor position. The second cue's name will be cleared, but the private note, public note, status, and priority will be copied.



E3EPSIES

L Reel ‘Scene  Cue name | Start/End Character Dialogue
Llog+d4

204405 Wade They called our generation the
2 of 152 ADR cues selected (152 cues in 'R1 test' reel set)




Merging cues

You can merge multiple cues into one cue. All of the cues must belong to the same character and be in the same reel.

Highlight the cues in the ADR Cue List window.

o0 ® ADR Cue List
+
+ % 7X & [
L Reel Scene  Cue name Start/End Character Dialegue All Notes Status/Priy
lﬁywq. R il b L ™. 1 A
Not in w4 cut - Medium
a 01 4 WD1905 198+14 Wade In 2045, it's still ranked the fastest Recorded
193409 growing clty on Earth, Recorded for Comicon traller - Medium
a 01 4 193+1@ Wade but it sure doesn’t seem like It when Recorded
196+08 you live in the stacks. Recorded for Comicon trailer - Medium
a 01 4 WD1906 204405 Wade They called our generation the Recorded
2 of 152 ADR cues selected (152 cues in 'R1 test' reel set)

Select Manage > Merge cues. The cues will be consolidated to form a "merged" cue. The merged cue will have the start time of the first cue and the end time of
the last cue. It will also be assigned the first cue's status and priority. The dialogue, private notes, and public notes will be concatenated together separated by a
carriage return. However, if the same text if found in two cues' fields, the text is not duplicated. For example, notice how the public note "Recorded for Comicon

trailer" was not repeated in the merged cue, below:

e ® ADR Cue List
+
+ 47X &M@ 2
Reel Scene Cue name Start/End Character Dialogue All Notes Status/Prty
189404 Recorded for Comicen trailer QAMITTED
Mot in w4 cut - Medium
01 4 WD1905 198+14 Wade In 2045, it's still ranked the fastest Recorded
196+08 growling city on Earth, but it sure Recorded for Comicon traller - Medium
doesn't seem like it when you live in
the stacks.
01 4 WD1906 204+05 Wade They called our generation the Recorded
208+07 missing millions. Recorded for Comlicon traller - Meaium
1 of 151 ADR cues selected (151 cues in 'R1 test' reel set)




Deleting cues

To delete cues, highlight the ones you would like to delete in the ADR Cue List window, then select Manage > Delete selected
cues. If you select any locked cues or a cue that is currently displayed in the Modify Cue Window, they will not be deleted.

Before ADR Manager deletes the cues it warns you that the operation is not undoable. If you proceed, be aware that you won't be
able to "undo" the delete.

If you delete a cue that has both an ancestor and a descendant, ADR Manager will repair the lineage so that the descendant is
directly linked to the ancestor. See Cue lineage for more information.



Renaming cues

When a cue is to be recorded, it is imperative that it has a unique identifier. ADR Manager will generate unique names for cues that
you select in the Cue List window by choosing Manage > Rename selected cues. A dialog confirms that you want to rename all
selected, unlocked cues. Only selected cues that are unlocked will be renamed. Cues are named according the convention you
specified in the Cue Naming preferences (see Cue naming).

You can rename cues at any time, but its usually best to name them before they get recorded, then lock the cues so that they
cannot be renamed on purpose or by accident. This ensures that other things associated with recorded cues, such as takes and
audio files, will always match up properly. Once a cue is named, whether it is locked or not, that name cannot be reused by any
other cue that's not in its lineage. If you want to reuse a cue's name, clear the name first by either highlighting it in the Cue List
window and choosing Manage > Clear selected cue names, or opening it in the Modify Cue window and clearing the name field. If
no other cues are using that name in the database, ADR Manager will reuse the name.

You can manually name cues in the New or Modify Cue window. If you enter a name that is already in use, a warning appears. If
you go ahead and save the cue with the duplicate name, ADR Manager will not guarantee uniqueness - that is left up to you. You
can also have ADR Manager autdfill names in the New and Modify Cue windows as soon as you enter a reel number, character,

and start time.

It is usually easiest and safest, however, to batch rename multiple cues after creating them.



Locking cues

Cues can be locked to prevent accidental modification. An unlocked cue can be renamed accidentally if you select it and choose
Rename selected cues... from the Manage menu, or you change it in the Modify Cue Window.

You cannot change a locked cue's fields directly. This includes the reel, character, start and end time, cue name, status, priority,
dialogue and notes. However, a locked cue's start, end, and embedded times, may still be modified during a conform.

Locking a cue is a good idea, especially if you've already recorded it and are adding more cues to ADR Manager. That way, you can
select all cues for a character/reel (including the locked ones) and rename them without fear of renaming the ones that are locked.
You can have ADR Manager automatically lock cues when they reach a certain status, such as Recorded (see Cue status for more
information).

To lock cues, highlight them in the ADR Cue List Window and select Lock selected cues... under the Manage menu, or type
command-L.

To unlock cues, highlight them in the ADR Cue List Window and select Manage > Unlock selected cues..., or type command-U.

ADR Manager will automatically lock and unlock descendant cues. Ancestor cues will be locked or unlocked according to the update
ancestors preference.



Creating takes

To create a take for the selected cue (or cues), choose Create take for selected cues under the Manage menu, or type shift-
command-A. The New Take window will open and a new take will be created for the highlighted cues. If a new take is already open,

the cues will be added to it.




Showing related takes

You can quickly display the takes that are related to specific cues by highlighting the cues in the ADR Cue List window and
choosing Manage > Show related takes. The results will be shown in the Take List window.

You can also see the takes for a specific cue by opening the cue in the Modify Cue window. Open the disclosure triangle in the
bottom left corner of the window to reveal the Takes tab.



Spotting cues to Pro Tools

You can create clips in a Pro Tools session based on highlighted cues in the ADR Cue List window. See Exporting to an open Pro
Tools session for more information.



Characters

ADR Manager keeps track of all characters in your project. You can enter the character's name, the character's abbreviation to be
used for numbering ADR lines (see Renaming cues), the actor's name, and other information pertaining to recording the character.



Displaying characters

Displaying characters is done in the Character List Window. See List windows for a description of the buttons at the top of the
window.

;MO Character List
(+)#)#)(X) @ @
|Abbr | Name Actor |
AC Adam Chase Mathan Hayes
Ad Alice Jones Dale Dream
AM Alice's Mom
BH Brad Higgins Ashton Maker
1COP Cop 1 Hal McMillan
2C0O0F Cop 2 Steve McMillan
EH Ed Higgins Sam Stevenson
FR Fred Renault Joe Smith
JL Jerry Lantana Jack Jones

LG Loop Group
LGW Loop Group Woman

MR Mister Renault
0 of 21 characters selected
R —

You can open this window by selecting Characters from the Windows menu, or typing command-K. If the Character List Window is
already open, a checkmark will appear beside Characters. If the Character List Window is behind another window or is inactive,
select Characters to make the Character List Window active.

The Character List window can display the following columns. You can customize the window by clicking on the Customize button in
the upper right corner.

e Abbreviation — The character's unique abbreviation.

e Character name — The character's unique name.

e Actor name — The actor who plays the character.

e Picture — A picture of the character

e Lines per hour — The average lines per hour this actor can record
e Type — The character's type (Principal, Minor, or Loop group)

e Description — A description of the character

e Recording notes — Notes pertaining to the recording of this character

As a default, the abbreviation, character name, and actor name columns are displayed.

Adding, deleting, duplicating, and modifying information about characters is done by selecting items in the Manage menu when the
Character List window is active. When the window is active, the menu will look like this:



Windows Help

Add character

Duplicate selected characters
Modify selected character...
Delete selected characters...

Use the menu items in this menu to add, duplicate, modify or delete characters.

3N
#D



Creating characters

To create characters, open the Character List Window. Select Add character from the Manage menu, or type command-N. You
can also open this dialog from the New Cue or Modify Cue window:

806 Modify character

am

Type ( Principal |

e erm—

¢ Cancel ::I

Character Name Deena

Actor Name Quisha Freeman

Abbreviation DN

I— ‘Description -I Recording

Description Dancer in subway

Picture

Store general information about a character at the top of the window, and in fields in the Description and Recording tabs. The
Recording tab looks like this:

[ Description i Recording 1

Estimated cues per hour 10

Recording notes

You can always change these fields later (see Modifying characters).

e Type — Choose what type of character this is: Principal, Minor, or Loop Group. By categorizing your characters, you can sort



and group them in reports (see Character List reports for an example).

Character name — This field is limited to 64 characters. It is required, and must be unique (no two characters can have the
same name).

Actor name — This field is limited to 64 characters. It is optional, and does not need to be unique (i.e. the same actor can
play several different characters).

Character abbreviation — This field is limited to 12 characters. It is required, and must be unique. If character abbreviations
are used in cue names (see Cue name fields) and your cue naming convention uses a delimiter after the character
abbreviation, make sure you don't use the delimiter in any character abbreviation. If you are not using a delimiter, then make
sure your abbreviation cannot be confused with the field that follows the character abbreviation in the cue name. For
instance, if your cue name convention consists of a character abbreviation followed by a reel number, avoid using the
uppercase letter "O", the lowercase letter "I", the uppercase letter "I", or any digits at the end of a character abbreviation.
They could easily be confused with a reel number.

Description — This field is limited to 80 characters. You can enter a description of who this character is (useful for minor
characters), or leave this field blank. The field can be included in character reports.

Estimated cues per hour — This field is required, and must be between 1 and 999. Store how many cues per hour, on
average, you think the actor can perform. This number is used by cue count table reports to estimate how long it will take an
actor to record all of his or her cues.

Recording notes — This field is optional. You can use it to store information about where or when this character will be
recorded. In a cue count table, you can group characters with the same recording notes together to create subtotals. For
instance, if you entered the recording stage for each character, you could generate a cue count table with subtotals for how
much time to book for each stage. See the Cue Count Table report for an example.



Duplicating characters

To duplicate characters, you must have the Character List Window open and active. Click, shift-click, and/or command-click the
characters you would like to duplicate, then select Duplicate selected characters from the Manage menu. If any of the characters
you have selected contain cues, the following dialog will appear:

The selected characters have cues
associated with them. What would
you like to do with the cues?

E’j Duplicate cues in the current reel set only.
: Duplicate cues in all reel dupes.

) Don't duplicate any cues.

r" 3
(—ﬁ*—-) . Cancel }

You can choose to duplicate the character's cues in the current reel set only, duplicate cues in all reel dupes, or don't duplicate any
cues. Choose one of the options and click OK. To cancel the operation, click Cancel. If you click OK, a dialog will let you know what
name and abbreviation the new character was given.

For each selected character, a new character will be added to the character list with information identical to the selected character,
except that the abbreviation and name will be given slightly different values than the original character. This is done because
characters must have unique names and abbreviations. You will probably want to give the new, duplicated character(s) better
names and abbreviations than the randomly generated ones (see Modifving characters).



Deleting characters

To delete characters, you must have the Character List Window open and active. Click, shift-click, and/or command-click the
characters you would like to delete, then choose Delete selected characters from the Manage menu. Before ADR Manager
deletes the characters, it warns you that the operation is not undoable. If you proceed, be aware that you won't be able to "undo” the
delete by choosing Undo from the Edit menu or typing command-Z.

If you are deleting a character that has cues, ADR Manager verifies that you want to delete all of the character's cues as well. A
dialog will appear asking you to confirm that you want to delete the cues associated with the character. Click OK to delete the
character and all of its related cues in all dupes. Click Cancel to abort, leaving the character and its cues untouched. Clicking on
Cancel aborts the entire delete process for the character in question as well as other characters you may have selected to delete.

If the character does not have any cues, ADR Manager will go ahead and delete it without asking you first.

TIP: If you want to keep a character's cues but delete the character, create a new temporary character and reassign the cues to
the new character (see Modifying multiple cues). Then delete the original character.



Modifying characters

To modify a character, simply double-click on it in the Character List Window. The Modify Character Window appears:
806 Modify character

Type ( Principal = H—.}

Character Name Deena

Actor Name Quisha Freeman

Abbreviation DN

I— ‘Description -I Recording

Description Dancer in subway

Picture

Change the character fields (see Creating characters) then click OK. If you change the abbreviation for a character, and the
character has cues that have been named, the following dialog will appear:



You can choose to erase the cue names, replace the old abbreviation with the new abbreviation, leave the cue names as they are,
or abort. This will affect cues in all reel dupes, not just those in the current reel set.



Reels

ADR Manager keeps track of all reels in your project. Each reel consists of one or more reel dupes. When you create a new reel,
you also create a dupe of that reel that has a specific dupe date. A reel dupe is a particular snapshot in time of a reel. Once you've
created a reel (and a dupe), you can create successive dupes, each dupe based on the previous dupe. Each time you create a new
dupe, the cues and scenes from the old dupe of the reel are copied into the new dupe. This lets you modify cues in the new dupe
without touching the cues in the old dupe. Switching back and forth between different dupes is done using reel sets (see Reel sets).

It is important to remember the difference between a reel and a dupe. A reel consists of multiple dupes. So when we
talk about "reel 1" we are talking about all the different dupes of reel 1, whereas "reel 1 dupe 8/28/18" or "reel 1 v3" are
specific reel dupes. Reel sets let you set which dupe we are talking about when we say "reel 1" so you don't have to
use the dupe date or version all the time.

The WILD reel is a special reel that contains cues that have no start or end time. The WILD reel has only one dupe, and has a reel
number of 0.



Displaying reel dupes

Displaying reel dupes is done in the Reel List Window. See List windows for a description of the buttons at the top of the window.

[ NN ) Reel List
+ 47| X £ 2| (?
Reelset: | Latest reel dupes o)
Reel Version Dupe date LFOA
Qg WILD Q0000
01 W1 8M1aM7T @1:55:33:08

1 of 2 reels selected

You can open this window by selecting Reels from the Windows menu, or typing command-R.

If the Reel List Window is already open, a checkmark will appear beside Reels. If the Reel List Window is behind another window or
is inactive, select Reels to make the Reel List Window active. You can close the Reel List Window by clicking on its close box, or
typing command-W or command-period.

The Reel List window displays only the reel dupes in the current reel set. The window consists of the following columns. You can
customize the window by clicking on the Customize button in the upper right corner.

e Number — The reel dupe's number.

e Version — The reel dupe's version.

e Dupe date — The reel dupe's dupe date.

e FFOA — The First Frame of Action for the reel dupe, in the currently displayed time format

e LFOA — The Last Frame of Action for the reel dupe, in the currently displayed time format. This time is inclusive.

Adding, deleting, duplicating, and modifying information about reel dupes is done by selecting items in the Manage menu or clicking
the buttons in the List window toolbar.

The Lock to Transport button lets you locate Pro Tools to the FFOA of a reel by clicking on it. See Locking List windows to
Transport Control for more information.

Example: You are working on a feature film, and each reel starts at an hour timecode (i.e. Reel 1 = 01:00:00:00; Reel 2 =
02:00:00:00, etc). You have a Pro Tools session containing all reels, each at their respective hour. If you lock the Transport
Control to Pro Tools, you can jump to a reel and play it without leaving ADR Manager.



When the window is active, the Manage menu will look like this:

Windows Help

Create new reel... BN
Create new reel dupe... %N
Delete selected dupes...

Conform selected dupe...

Add reel set...
Delete current reel set...
Modify current reel set...

Use the items in this menu to create reels, create and delete reel dupes, and conform.

You can also add, delete, and modify reel sets in this menu.




Creating reels

You may create a new reel as long as it does not have the same number as an existing reel in the database. When you add a reel,
a new, empty reel dupe is added to the current reel set only. To create a new dupe of an existing reel, you must use the Create new

dupe of sel dupe menu item (see Creating reel dupes).

It is important to remember the difference between creating a new dupe and creating a new reel. Creating a new dupe
will automatically copy all of your previously spotted cues and scenes from the original dupe into the new dupe, which
you can then conform. Making a new reel creates a new, empty dupe with no cues.

To add reels, you must have the Reel List Window open and active. Select Create new reel from the Manage menu, or click on the
Add button. The following dialog will appear:

O New resl

Reel number 03 Version —

Dupe date 10/12/19 | ™9 OK &N
ext

Cancel

.--_.L-“Ir-i-' .i. Timelines Media

Brief description:

Full description:

General info

Enter information to define a new reel:

e Enter a reel number. The next available reel number is automatically entered for you as the default reel number. You cannot
have two reels with the same reel number.

e You can enter a version using up to 8 characters, or you can leave this field blank.

e The default dupe date is today's date. Change it to a more appropriate date by typing it in or selecting it from the calendar



popup.

Descriptions tab

The Descriptions tab provides fields for a brief description (limited to 80 characters) and a full description (unlimited length).

Timelines tab

The Timelines tab lets you define two timelines for the reel, one in feet and frames and one in timecode. There are 4 values used to
define each timeline:

e Reel start or FFOS (First Frame of Segment) - This defines where the timeline begins. Typically this should match the start
time of your session in Pro Tools.

e FFOA (First Frame of Action) - This is where the first frame of program content is for the reel. No cues or scenes can begin
before the FFOA.

e LFOA (Last Frame of Action) - This is where the last frame of program content is for the reel. Note that this time value is
inclusive, meaning that it designates where the last visible frame is, not where the first frame of black is. For example, if a
reel had an FFOA of 01:00:00:00 and an LFOA of 01:00:01:00 and the time format was 24 frame timecode, then the reel
would have 25 frames of action, not 24. Cues and scenes can start at the LFOA, but cannot start after the LFOA. Scenes
must end on the LFOA. Cues can end after the LFOA.

e Reel end or LFOS (Last Frame of Segment) - This defines where the timeline ends. Typically this corresponds to the end of
video black. Cues cannot end after the LFOS.
You must enter values for the start, FFOA, LFOA, and end in the project time format.

You must also enter a value for one of the fields in the alternate time format. This will align the two timelines. Click on the link icon to
choose which alternate time field you want to change. The other fields in the alternate time format will be automatically calculated.

You can modify these values at any time (see Modifving reel dupes). ADR Manager will warn you if you attempt to shorten a reel
that would cause one or more cues to get deleted or trimmed.

Media tab
The Media tab lets you add a guide track for the reel. A reel guide track is used when spotting cues or scenes to Pro Tools. You can
add it by dragging a file into the Guide track box, or clicking on the plus button to browse for a file. The file must be:

e A mono audio file

e Atleast as long as the reel, as measured from reel start (FFOS) to reel end (LFOS)

e Its timestamp should match the reel start (FFOS), but this is not required

e You can only have one guide track associated with a reel, currently. To replace a guide track, delete the old one first by

clicking on the minus button.

Data about the guide track is displayed at the bottom of the window. If you move the audio file to a new location, you can edit the
folder path to reflect the new location.

Saving

Once you have entered all the information, click the OK button to close the window, or click OK & Next button to enter another reel.



Creating reel dupes

To create a new dupe of a reel, open the Reel List Window. Select the dupe from which you want to make a new version, then
select Create new reel dupe... from the Manage menu, or click the New dupe button. You can create a new version of only one
dupe at a time, and you can only make a new version of the latest dupe of any particular reel. In other words, you cannot create a
new version that lives chronologically between two existing dupes.

O New reel dupe

Reel number 01 Version vl —

Dupe date 10/13/19 | ]

Cancel

Descriptio Timelines Media

Brief description:
Int. Apt

Full description:
Harry's place

See Creating reel dupes for a description of the fields in this window. You cannot change the timeline fields. They will be modified
automatically when you conform the dupe.

When you click OK, ADR Manager will do the following:

Copy all of the cues from the old dupe to the new dupe.

Create lineage ties between the cues in the old dupe and the cues in the new dupe (see Cue lineages).

Copy all of the scenes from the old dupe to the new dupe.

Give you the option of replacing the old dupe with the new dupe in the current reel set. If you are displaying the "Latest reel
dupes" set, the new dupe replaces the old dupe automatically.

You can now conform the cues in the new dupe without fear of changing the cues in the old dupe (see Conforming).

Note: If you attempt to make a new dupe of a reel that has not been conformed yet, and there is an older dupe, the program will
confirm that you really want to make the new dupe without conforming first.






Deleting reel dupes

To delete reel dupes, you must have the Reel List Window open and active. Click, shift-click, and/or command-click the reel dupes
you would like to delete, then select Delete selected dupes... from the Manage menu. Before ADR Manager deletes the dupes, it
warns you that the operation is not undoable. If you proceed, be aware that you won't be able to "undo" the delete by choosing
Undo from the Edit menu or typing command-Z.

If you are deleting a dupe that has cues, ADR Manager verifies that you want to delete all of the cues as well (scenes are
automatically deleted). Click OK to delete the reel dupe and all of its related cues and scenes.

Note that when you delete a dupe, the copies of those cues will still exist in older dupes. For example, if you want to redo the
latest conform, simply delete the latest dupe, create a new dupe and start the conform process over.

Deleting a particular dupe of a reel does not delete any other dupes of that reel, so if you want to remove all versions of a reel from
your database, you must display each dupe one by one (by switching reel sets) then selecting and deleting each one. Note that
deleting an "intermediary" dupe will not break any lineage ties between cues in the earlier dupe and cues in the later dupe of that
reel. For example, if you had three versions of reel 1 (v1, v2, and v3) and you deleted v2, then the cues in v3 would become direct
descendants of the cues in v1.

TIP: If you want to keep a reel dupe's cues but delete the dupe, create a temporary reel dupe and reassign the cues to the
temporary dupe (using the Modify Selected Cues window). Then delete the original dupe.

You cannot delete the WILD reel.



Modifying reel dupes

To modify a reel dupe, simply double-click on it in the Reel List Window. The Modify Reel Dupe Window appears:

[ ] Modify reel

Reel number 01 Version 1 “

Dupe date 8/16/17 | ™ OK & Next
ax

Cancel

Descriptions it CIL =

Feet and frames Timecode
Reel start @+0@ = @l:00:00:08 "
FFOA 172+8@ 21:00:a8 08
LFOA (inclusive) 1620+00 @l:18:20:08
Reel end (inclusive) 1280+0@ @1:20:00:00

* should equal Pro Tools session start time

A description of each field in the Modify Reel Dupe Window can be found in the Creating reels section. Some notes about modifying
a reel dupe:

e You can only change the reel number for a dupe that has no earlier or later dupes. In other words, you cannot remove a dupe
from a set of related dupes to make a new reel.

e If you want to move cues out of a reel, create a brand new reel and then use the batch modify feature to move the cues into
it.

e You can change the date for a reel dupe as long as it is later than any previous dupes and earlier than any later dupes.

If the reel contains named cues, the cue names will not be affected, even if the reel number changes.

If you are conforming a reel, it is usually best to make a new dupe of the reel, rather than modifying the existing reel. That way,
you can keep the cues in the older dupe intact for historical purposes. See Creating reel dupes for more info.

If you shorten the reel by decreasing its LFOA, you may affect cues and scenes at the end of the reel dupe. ADR Manager will treat
the change as a Delete time (see Conforming). Similarly, if you make the FFOA later and cues that started at the beginning of the
reel dupe are affected, ADR Manager will delete and/or trim the cues similar to Delete time, except that the deletion will not ripple
throughout the dupe. In other words, cues and scenes that are later in the reel will not move earlier in time.

You cannot modify the WILD reel.



Conforming reel dupes

Conforming is done via change lists. A change list is a set of instructions that describe how to move chunks of time in a reel dupe to
match a new version of the project. To conform a reel dupe, open the dupe's Change List window by highlighting it in the Reel List
window, and clicking on the scissors button in the toolbar or selecting Manage > Open change list.

[ NN geel List
+/#)#
| Reel set: Ldtest reel dupes

The Change List window appears:

[ NN | RO2 d2/16/19 to d3/12/19 change list
+/71%X/[& <\ (?
Version Dupe date CurLFOA
From: 10 2/16/19 1437+05 LFOA change a+0@
To: 11 3/12/19 1437+85 Conformed LFOA 1437+@5
v S Start/End Duration Action Affected clips Cumulative chg

0 of 0 change events selected

T ——

Please refer to the Conforming section for information about this window and how to conform.



Reel sets

You can use reel sets to group related dupes together. This is useful if, for example, you have different dupes in your project and
you want to keep the "Version 2" dupes separate from "Version 3". You could create one reel set to group the old dupes together,
and another reel set to hold the new dupes. Reel sets also prevent you from seeing two dupes of the same reel at any given time,
which could be confusing when searching or creating new cues. The exception to this is the "All reel dupes" set (see Default reel

sets). A reel set can hold any number of dupes from different reels in the project - it does not have to have a dupe from every reel. A
reel set could even have no dupes.

There is no limit to the number of reel sets you can create. You cannot delete the "All reel dupes” or "Latest reel dupes" sets. To
change reel sets, click on the popup in either the Search Window or Reel List Window:

Cue Searching

he checked characters and reels:

Reel set: Latest dupes |

AR

| | |Reel | Yersion |Dupe date |

When you change the reel set in one window, the change is global throughout the program. Different dupes are now active. The

Cue Search and Reel List Windows display the new reel set, and the Scene List Window displays the scenes that belong to the
dupes.

When importing, make sure you have the correct reel set active so that imported cues or takes are added to the proper
dupes. Also be sure to have the correct reel set active when conforming.

Reel sets are added, deleted, and modified via the Reel List Window. Open the Reel List window to choose a reel set command
under the Manage menu.



Default reel sets

There are 2 reel sets that always exist:

e All reel dupes - This is a special reel set that cannot be deleted or modified. Every time you create a new reel or reel dupe,
the dupe automatically gets added to the "All reel dupes" set. When this reel set is active, you can perform searches for cues
throughout the entire database. This gives you the ability to find a cue, regardless of what reel dupe the cue is in. The
disadvantage to making the "All reel dupes" set active is that you cannot add, modify, or import cues and scenes, nor can
you perform any conforming operation. You must switch to a normal reel set to do these operations.

o Latest reel dupes - This set contains the latest dupes of every reel in the database. This set cannot be deleted or modified.

Each time you make a new reel dupe, this set will get automatically updated. The "Latest reel dupes" set is the default set for
new databases.



Creating reel sets

To create a reel set, you must have the Reel List Window open and active. Select Add reel set from the Manage menu. The
following dialog will appear:

A ™™ New reel set

Set Name |

Reels in set:

Mame Version Dupe date

0o WILD m
01 w1l0911 11/9/11

01 DCBE_18 12/7/11
01 Do _24 1/5/12
0l Do _25 1/19/12
01 Dlo_27 1/30/12
02 w1l0911 11/9/11
n2? na o 1247111

( OK ){Cancel:} @

This dialog lets you name the reel set and choose which reel dupes belong to it. To add a dupe to a reel set, click on it and a
checkmark will appear. To remove a dupe, click on its checkmark to uncheck it. If you attempt to put a checkmark on a dupe for
which another dupe is already checked, the previous dupe will be unchecked. For instance, if Reel 1 v3 were checked and you
checked Reel 1 v4, then Reel 1 v3 would automatically be unchecked.



Deleting reel sets

To delete the currently active reel set, you must have the Reel List Window open and active. Select Delete current reel set from
the Manage menu. The currently active reel set will be deleted and the "Latest reel dupes” set will be selected as the new active

set.

You cannot delete the "All reel dupes" or "Latest reel dupes" sets.



Modifying reel sets

To modify the currently active reel set, you must have the Reel List Window open and active. Select Modify current reel set from
the Manage menu. The following dialog will appear:

A ™ ™ Modify reel set

Set Name Latest dupes

Reels in set:

Mame Version Dupe date
Yoo wi

01 wll091l 11/9/11
01 DCB_1E 1247111
01 Do 24 1/5/12
0l D9 25 1/19/12
¥ 01 D027 1/30/12
02 wll091l 11/9/11
02 D8_o 1247711

(Hndiﬁr) i Cancel :: @

This dialog lets you rename the reel set and change which dupes belong to it. The reel set name can be up to 32 characters. To add
a dupe to a reel set, click on it and a checkmark will appear. To remove a dupe, click on its checkmark to uncheck it. If you put a
checkmark on a dupe for which another dupe from the same reel is already checked, the previous dupe will be unchecked.

You cannot modify the "All reel dupes” or "Latest reel dupes” sets yourself. These sets are automatically maintained by ADR
Manager.



Scenes

ADR Manager allows you to maintain a list of scenes, or continuity, for your project. You can enter scene information including what
reel it is in, brief and verbose descriptions of it, and what time it starts. Scenes are helpful when entering or modifying cues, since
they are looked up and displayed automatically in edit windows once you enter a reel and cue start time. Scene information can also
be included in reports created for actors, directors, editors, and mixers, so that you have an idea where a cue exists in the project.

ADR Manager makes sure that every frame of a reel is in a scene. When a new reel is created, a scene is automatically created
called "--" that spans from the reel's FFOA through its LFOA. You can insert additional scenes within the default scene by entering
information in the New Scene window. As you enter a new scene, the previous scene automatically gets truncated to end one frame
before the new one. All scenes end one frame before the starting frame of the next scene, or at the reel's LFOA if it is the last scene
in the reel. Scenes do not start in one reel and end in another - you must create separate scenes in each reel.



Displaying scenes

Displaying scenes is done in the Scene List Window. See List windows for a description of the buttons at the top of the window.

[ NON Scene List
+ 7| X & @ (?
Reel Name Start Brief desc Full desc

01 1M1 1262+14 EDITH'S ROOM - LATER Edith researches clay mining in England.
The door opens on Its own.

01 11AA  1311+@@ CUSHING MAMOR - UPPER Edith is again visited by Mother's ghost

FLOOR PARLOR

01 T1AE  1443+11 EDITH'S ROOM The Ghost warns Edith, Maid announces
Thomas Sharpe

02 1A 12+@@  FOYER, CUSHING MANOR Thomas convinces Edith to come to the
reception

02 13 196+87 BALLROOM - NIGHT Lucille performs on the plano. Thomas, Edith
arrive and waltz. Eunice Is rejected.

0z 17 555+@8 GEMTLEMAMN'S CLUB - Mr. Haolly recelved by the Attendant

LOBBY
02 18 561+@9 LOCKER RODM/SHOWERS Cushing pays Holly to Investigate
{CONTINUOUS)

02 19 615+83 PICNIC PARK Edith, Lucille talk butterflies. Alan, Themas
arrive - they discuss Edith's writing and
ghosts

0z 18C 853408 OPTHALMOLOGY Alan shows Edith ghosts. They have both

PRACTICE/DARK ROOM - grown up.
LATER
02 22 978+84 CONFEREMCE ROOM - Thomas impresses the Investors. Cushing Is

SUMSET called away.
0 of 107 scenes selected

You can open this window by selecting Scenes from the Windows menu, or typing command-J. If the Scene List Window is already
open, a checkmark will appear beside Scenes. If the Scene List Window is behind another window or is inactive, select Scenes to
make the Scene List Window active. You can close the Scene List Window by clicking on its close box, or typing command-W.

The Scene List window displays the following columns. You can customize the window, such as showing more lines of text in each
row, by clicking on the Customize button in the upper right corner.

e Reel — The scene's reel number. If the "All reel dupes" set if currently active, this will also show the reel's version or dupe
date.

e Name — The scene's name.

e Start — The scene's start time in the reel, in the currently displayed time format.

e Brief description — A brief description of the scene, such as the location

e Full description — A full description of the scene, which would typically include what happens.
Adding, deleting, duplicating, and modifying scenes is done by selecting items in the Manage menu when the Scene List window is
active.

The Lock to Transport button lets you locate Pro Tools to the start of a scene by clicking on it. See Locking List windows to



Transport Control for more information.

Example: You are working on a feature film, and each reel starts at an hour timecode (i.e. Reel 1 = 01:00:00:00; Reel 2 =
02:00:00:00, etc). You have a Pro Tools session containing all reels, each at their respective hour. If you lock the Transport
Control to Pro Tools, you can jump to a scene and play it without leaving ADR Manager.

When the window is active, the Manage menu will look like this:

Edit Windows Help

Add scene... N
Modify selected scene...
Delete selected scenes...

Split scene 3L
Merge scenes #G

You can use these menu items to add, modify, delete, split, and merge scenes.




Creating scenes

To create scenes, you must have the Scene List Window open and active. Select Add scene from the Manage menu, or type
command-N. The following dialog will appear:

[ NN ] Mew scene
Reel number 01 Version 1 _
Scene name 2 OK & Next

Cancel

Brief description:

INT. Jackie's apartment

Full description:
Lou stops by to see Jackie.

A description of each field in the New Scene Window is listed below. To change the default value of a field, simply type into it then
press the tab key to move to the next field in the window. You can change a value by typing in a new one, or you can modify any of
the values later (see Modifying scenes).

e Select a reel number from the popup menu. The reel number you enter must be in the current reel set. After entering a
number, the version or dupe date of that reel is displayed so you know you are adding this scene to the correct reel dupe.

e The scene name can contain up to 10 characters. You must enter something in this field. Scene names do not have to be
unique. Default scenes have "--" as the name (but you can modify this).

Under the Descriptions tab are fields describing the scene:



Descriptions Timelines |

Brief description:

Full description:

e The brief description field can hold up to 80 characters. This field is displayed in the New Cue and Modify Cue windows to
describe what scene the cue lies in.

e You can enter as much text as you like in the full description field. You can embed time values in the full description by
doing one of the following:

o You can enter a time manually, complete with colons or plus signs.

o You can select Insert current time from the Manage menu to grab the current incoming MIDI time (shown in the
Transport Control window) and insert it at the current cursor location. If text is already selected, it will be replaced by
the inserted time. If the cursor is not in the full description field, the command is ignored.

o You can use a keyboard shortcut to embed the current time.

o You can tell ADR Manager to insert the current time from a macro. See Grab time from Pro Tools using a macro for
more information.

Click on the Timelines tab to specify where the scene starts:

[ Descriptions f Timelines 1

Feet and frames Timecode
FFOA 12+00 01:00:08:00
LFOA 112400 01:01:14:20

e Enter a value in the FFOA field. If you have established MIDI communication with a Pro Tools session, then the scene's reel
and FFOA will automatically be set to the current time. Otherwise, the scene FFOA will be set to the default reel's FFOA. You
can change the FFOA in several different ways:

o You can enter a time manually, complete with colons or plus signs, or you can use the shorthand method.

o You can use Set start time to current time under the Manage menu to put the current time from the Transport
Control window in the FFOA.

o You can put the cursor in the FFOA field and select Insert current time from the Manage menu.

o You can use a keyboard shortcut to insert the current time.

e No two scenes can share the same FFOA in the same reel — if you try to save a scene with the same FFOA as an existing
scene, ADR Manager will give you the option of replacing the old scene or canceling.

e The scene's LFOA will be automatically calculated as one frame before the start time of the following scene. If this is the last



scene in the reel, the end time will be set to the reel's LFOA.

Note that whenever you create a new reel, ADR Manager automatically creates a new scene that starts at the reel's FFOA and ends
at the reel's LFOA. You cannot delete this scene, only modify or replace it.

Once you have entered all the information, you can save the new scene in two ways: by clicking on the OK button, or by clicking on
the OK & Next button. If you click on the OK button, the scene is saved and the New Scene Window closes. If you click on the OK &
Next button, or hit the enter key, the scene is saved and the New Scene Window remains open, with default values for another

scene.

If you decide you don't want to save the scene, click on Cancel or type command-period. This will close the New Scene Window
without saving the scene.



Deleting scenes

To delete scenes, you must have the Scene List Window open and active. Click, shift-click, and/or command-click the scenes you
would like to delete, then select Delete selected scenes from the Manage menu.

Deleting a scene removes it from the scene list and extends the previous scene into the region where the deleted scene existed. If
you delete the first scene in a reel, it will be automatically be replaced by a new scene with name "--".

No cues are deleted when deleting a scene - cues are simply reassigned to whatever scene they fall into after the deletion. Reel
LFOAs are also not affected when deleting scenes.



Modifying scenes

To modify a scene, simply double-click on it in the Scene List Window. The Modify Scene Window appears:

eMme Maodify scene

Reel number 1 3‘ Dupe date 8/2/06 ( oK )

Scene name 7 H*M-;

C Cancel )

l—l‘.‘lu:ﬂ-pﬂnu—l Timelines |

Brief description:

INT. Queens apartment - Might

Full description:

Friends and family await Lec. PO Kiesz is there.

See Creating scenes for a description of the fields in this window.

If you move the scene to a new location by changing its start time and/or reel, cues within the scene are not moved with it, nor are
any reel LFOAs affected. Instead, the previous scene is extended into the region where the modified scene used to be, and cues
are modified to reflect which scene they now lie in.



Splitting scenes

To split a scene into two scenes, highlight it in the Scene List window.

®_ @ Scene List
+ /1% < @ (2
Reel MName Start Brief Full description
description
01 5 @1:@@:18:15 EXT. Queens Leo buys a pack of cigarettes
street - Night
01 ] @1:10:15:0@ INT. Jimmy's Jimmy gets a phone call
apt
a1 7 @1:12:@5:16 INT. Queens Friends and family awalt Lee. PO
apartment - Klesz talks to Leo.
Night
1 of & scenes selected

Choose Manage > Split scene. The Split Scene Window appears:



Enter the time where you want the scene split. Position the cursor in the Full Description box where you want to separate the text for
the two scenes. Two scenes are created. In this example, the cursor was put just after the first sentence:

e Scene List
+ /X S\ (2
Reel MName Start Brief Full description
description
01 ] @1:8@:18:15 EXT. Queens Leo buys a pack of cigarettes
street - Might
01 ] @1:10:15:8@ INT. Jimmy's Jimmy gets a phone call
apt
01 7 @1:12:@5:16 INT. Queens Friends and family await Leo.
apartment -
Night
01 7 @1:18:85:@3 INT. Queens PO Klesz talks to Leo.
apartment -
Niakht
2 of 7 scenes selected




Merging scenes

To merge two or more scenes, highlight them in the Scene List window.

® @ Scene List
+ /X & ) (2
Reel MName Start Brief Full description
description
street - Night
01 & @1:10:15:0@ INT. JIimmy's Jimmy gets a phone call
apt
01 7 @1:12:@5:16 INT. Queens Friends and family await Leo.
apartment -
Night
01 7 @1:1R:@5:@3 INT. Queens PO Klesz talks to Leo.
apartment -
Night
02 - @2 :00:200:08
2 of 7 scenes selected

Choose Manage > Merge scenes. The scenes are combined into one scene. If two consecutive scenes have different Brief
Descriptions or Full Descriptions, the fields are concatenated.

e Scene List
+/71X & | (2
Reel MName Start Brief Full description
description
01 - 21:00:00:02 Logas
01 5 @1:08:10:15 EXT. Queens Leo buys a pack of cigarettes
street - Night
01 & @1:1@:15:0@ INT. Jimmy's Jimmy gets a phone call
apt
01 7 @1:12:@5:16 INT. Queens Friends and family await Leo.
apartment - PO Klesz talks to Leo.
Night
02 = @200 :20: 08
1 of & scenes selected




Spell checking scenes

The built-in dictionary will check the following fields for spelling mistakes:
e Brief description

e Full description

You can check spelling as you enter information about a scene. See Spell Checking for more info.

To spell check a text field

In the New Cue or Modify Scene windows, any misspelled words are underlined in red as soon as you stop typing. To fix a
misspelled word, right-click (control-click) on the word and choose a replacement listed at the top of the menu. If you want more
options, select Display spell checker dialog from the popup to open the Spell Checking window. You can also choose Manage >
Spell Check from the main menubar when the cursor is in the field you want corrected. For more information, see Spell Checking.

To spell check multiple scenes

In the Scene List window, highlight all of the scenes you want to check and choose Manage > Spell check scenes.... For each
scene that has spelling errors, the Correct Misspelled Words dialog opens with the first misspelled word underlined and highlighted:

@ @ Correct misspelled words
Reel 01 - Dupe datedupe 12/31/1 (aModifigy) Prev Next | (?
5cene name Maodify & Next Cancel

Brief description:

Int. Apartmnt

Full description:
Jack wakes up

Right-click on the word or choose Manage > Spell check to fix the problem, as described in Spell Checking. Click on Previous or
Next to go to another misspelled scene.



Takes

You can keep a list of takes for each spotted cue within ADR Manager. A take is distinct from a cue in that it describes an actual
recording, whereas a cue is an intended recording that may not exist yet. Some of the fields of a take may be different than those in
the spotted cue. For instance, the recording may have different dialogue (transcription) than the dialogue that was entered for the
cue. A take record also stores information such as whether the recording was any good or not (i.e. "circled" takes and ratings).

A cue can have multiple takes. For example, if the actor performed a cue 10 times, there would be 10 separate takes. However, a
take does not necessarily represent only one cue. For example, if an actor decides to record several cues together in one
performance, then the resulting take spans several cues.

A take can have audio attached to it, called an audio stream. An audio stream is defined as one or more audio files that all have the
same characteristics such as sample rate, bit depth, timestamp and number of samples, and are meant to be grouped together.
Each audio file contains a separate channel of audio. For instance, in the case of a mono audio stream there is only one audio file; a
stereo audio stream typically has two audio files, etc. ADR Manager recognizes files with matching Pro Tools channel suffixes (i.e.
.L,.C, .R, .Ls, .Rs) and assumes they are one audio stream. All of the audio files in a stream must live in the same folder.

You can rename takes using your take naming preferences by choosing Manage > Rename selected takes. If a take is linked to
cues, the cue names are used to construct the take name. Or if the take has an associated audio stream, the stream name is used.
If the take has no related cues or audio stream, the name is left as is or blank.

If you follow your naming convention when recording and then import the audio files into ADR Manager to create takes, the app
will automatically link each take to the appropriate cues.

A take stores the full pathname to the files of an audio stream. If you mount a volume that contains audio files after starting ADR
Manager, you must update online statuses in order to audition the audio files.

Storing audio files gives you the ability to audition and put the audio into a Pro Tools session. A take can only have one audio
stream attached to it. Takes can also have no associated audio stream.

ADR Manager 7 supports WAV and MXF-wrapped audio files.

You can also create subtakes, which are takes within other takes. See Creating takes for more info.



Displaying takes

Displaying, adding, deleting, duplicating, and modifying takes is done by opening the Take List Window. You can open the Take List
window by selecting Takes from the Windows menu, or typing command-T.

See List windows for a description of the buttons at the top of the window.

In addition to the standard editing buttons, there is a Drag button for dragging takes to another application, such as Pro Tools or a
Finder window. To use it, highlight the takes you want to drag, then drag the Drag button to the destination. The number of audio files to
be copied appears in a red circle underneath the cursor. Keep in mind that even if a take only spans part of an audio file, the entire
audio file is copied.

At the bottom of the window you can audition the currently highlighted take, if it has audio associated with it. Hit the spacebar to
play/pause the audio. The left and right arrows skip backward and forward by 0.5 seconds.

Drag take(s) to Pro Tools Audition take
| NON ) Take List
+ 4/ X m 2
Name Number Subtake Dialogue Note
AD103_01 1 What's with that?
AD103>04_02 2 What's with that? Rocco, what are you doing?  Good prgjection
AD103>04_03 @ What's with that? What are you doing? Nice
AD103>04_04 4 What's up with that? What are you doing? Too mugh
) KAR106_01 1 Light it up
) LGR101_01 1 (Bar walla) Too bu
o) LGR101_02 2 (Bar walla) Some english
4{) LGR101_03 (3) (Bar walla)

1 of 8 takes selected

Mono E
= bt ool U s ot e o 5 bt i (I oo At

The Take List window displays the following columns, as a default. You can customize the window by clicking on the Customize button
in the upper right corner.

e Audition speaker — If a speaker icon appears in this column, then there is audio associated with this take. If the speaker has
sound waves emerging from it, then the audio file's volume is mounted. If the speaker is gray and has no sound waves, then the
take has associated audio but the file's volume is not mounted currently or it no longer exists in the folder.

e Take name — The name of the take. If the take name was generated by ADR Manager, then it will follow the take naming
conventions set up under Edit > Preferences > Take Naming.

e Take number — The number of the take and possibly subtake. If you have checked the "Circled" checkbox in the New Take or
Modify Take windows for this take, a circle will appear around the number. Option-clicking on the take number toggles the circle
on and off.

e Dialogue — The actual dialogue of the take. This may be different than the related cue's dialogue.

e Notes — General recording notes about the take.
You can link cues to takes by option-dragging them from the ADR Cue List window on to a take in the Take List window. You can also
add cues to a take when in the New Take or Modify Take windows. See Linking fo cues for more information.

Changing information about takes is done by selecting items in the Manage menu when the Take List window is active. When the
window is active, the Manage menu will look like this:



Windows Help
Add new take ®N
Duplicate selected takes... 3D
Delete selected takes...

Modify selected takes...

Show related cues

Show sound file in Finder
Spot takes to Pro Tools... 43T

Update online statuses

Use the menu items in this menu to add, duplicate, or delete takes, display related cues, show audio files for the take, export the audio
files to a Pro Tools session, or update the online statuses of audio files.



Creating takes

To create a take, make the Take List Window active and select Add take from the Manage menu, or type command-N. You can also
create a take by selecting cues in the Cue List window and choosing Create take for selected cues under the Manage menu. The

following dialog will appear:

Take Name

Number 1 Subtake

Character

Dialogue

Folder

Files

New Take

4' M OK Cancel ?

Circled take Rating A E

Recording mode

4 v Recording Notes

[ Audio Je¥S

Store general information about a take in the top half of the window, and in fields in the Audio and Cues tabs. When finished, click on
"OK" to save and close the window, or click on OK & Next to save the take and keep the window open for a new take.

If you intend to make another take for the same set of cues (i.e. you are creating takes "on the fly" during a recording session), check

the Recording mode checkbox. This will:

e Create a new take linked to the same cues



Increment the take number

e Retain the dialogue text

Create a new take name using the current take naming convention

Clear the circled setting, rating, recording notes, and attached audio files

The information in the top half of the window is:

e Take name — You can enter any string in this field you wish, but keep in mind you should follow the take naming convention
setup in the Edit > Preferences > Take Naming window. The maximum length of the take name is 80 characters, although you
may want to keep it short if you plan on spotting the take into Pro Tools (see Exporting fo an open Pro Tools session) due to
limits in Pro Tools.

o Autofill name button — Clicking the lightning bolt button next to the take name field will autofill the take name based on other
fields in the form, namely the related cues (if any), or the audio stream (if any). You can lock the autofill button on by clicking on
the popdown menu next to the button. This is useful if you want to keep the New Take window open to add several takes in a
row. You can also batch fill the names of takes later, by highlighting them in the Take List window and choosing Manage >
Rename selected takes.

e Take number — Enter the take number.
e Subtake number — This field is enabled only if a non-zero value has been entered into the Take number field.

e Character — This field is automatically filled in by ADR Manager when you assign one or more cues to a take. If all of the cues
are from the same character, the field gets the character name. If the cues are from different characters, the field is set to
"Various." You cannot edit this field.

e Circled take — Click this checkbox or type option-1 to mark this take as circled. You can search on circled takes in the Search
window (see Searching for takes). If a take is circled, the take number will appear with a circle around it in the Take List window.
Note that you can quickly circle and uncircle a take in the Take List window (without having to open the Modify Take window) by
option-clicking on the number in the number column.

e Rating — You can rate each take for performance, quality of recording, etc. by choosing a rating level in the Rating popup. As a
default, all cues are given an "A" rating. Possible ratings, from highest to lowest, are: "A", "B", "C", "D", "F", and "NG" (stands for
No Good). You can search for takes with particular rating levels in the Search window.

e Dialogue — Takes may have different dialogue than the spotted cues, to allow for cases when an actor says something different
than what was spotted. In these cases it may be helpful to accurately transcribe the actual recorded dialogue so that you can
search for these words later.

o Autofill dialogue button — Clicking the lightning bolt button next to the take dialogue field will autofill the take dialogue based
on the related cues' dialogue (if any). You can lock the autofill button on by clicking on the popdown menu next to the button. This
is useful if you want to keep the New Take window open to add several takes in a row. You can also batch fill multiple takes'
dialogue fields by highlighting them in the Take List window and choosing Manage > Rebuild dialogue for selected takes.

e Recording notes — You can enter remarks about the recording in this field. You can later search for takes with certain keywords
in the recording notes field using the Search window (see Searching for takes). Recording notes appear in a column in the Take
List window.

Audio tab

Under the Audio tab, you can add audio to the take by adding one or more related audio files. Once audio is added to a take, you can
audition it in various places throughout ADR Manager. See Auditioning audio for more information.

Cues tab

Under the Cues tab, you can add and delete the cues that are related to the take.



Adding audio files to a take

The Audio tab shows the audio stream associated with the take:

TN cues

Folder Mac HD:Users:Steve:Documents:ADR Manager
databases:MyProject:Recordings:

Files | G203 02.L.wav T =

LG203_02.R.wav

Left E
—* Ao saats bl it~y e

You can add files to the take's audio stream by clicking on the Add button (+) to the right of the Files list and selecting one or more
files. The file type, sample rate, bit depth, timestamp, duration, and folder path of the selected files must be identical.

You can also scan a folder for audio files. ADR Manager will automatically group audio files into audio streams, then create takes for

each stream, and finally link the takes to cues if their names match your take naming convention. See Importing audio files for more
information.

ADR Manager supports multiple copies of the same audio file in different locations. For example, you might keep some audio files
locally when using the database on a laptop, but want access to the full library when you are connected to a network. You can add
or replace folder paths in the Batch Modify Takes window.

You can audition the audio files in the player that appears below. See Auditioning audio files for more information.



Linking a take to cues

The Cues tab shows what cue(s) the take is linked or related to. A take can encompass more than one cue, provided that all cues
are in the same reel.

Audio
||+ -

Cue name Start/End Dialogue Notes
JN10701 30400 Lightitup Over the shoulder
40+00 Intelligibility

The list displays what cue(s) this take spans. Cues are always listed in order by start time.

There are several ways to add cues to a take:
e You can choose Add selected cues under the Manage tab. Any highlighted cues in the ADR Cue List window will be added.
e You can click on the plus button above the list. Any highlighted cues in the ADR Cue List window will be added.

e You can highlight cues in the ADR Cue List window and select Create take for selected cues (shift-command-A) under the
Manage menu while the ADR Cue List window is active.

Make sure the active reel set is the one in which the take was recorded. When a take is linked to a cue, ADR Manager
assumes the cue's dupe is the dupe to which the take was recorded. The dupe is displayed above the cue list. This is
important if you decide, for example, to export takes to Pro Tools and want them to be placed at the conformed cue's
start, rather than the original recorded start.

For each added cue, a link will be created between the take and the cue. The take is also linked to ancestors of the added cue
according to the "Modify ancestor cues" preference (see Cue status preferences for more info).

If the Autofill name button is locked on, ADR Manager will automatically generate a new take name. If the Autofill dialogue
button is locked on, the take's dialogue is reconstructed based on the cues' dialogue.

To remove cues from the list, select them and click on the minus button. Again, this will affect the name and dialogue of the take if
the Autofill name and Autofill dialogue buttons are locked on, respectively.



Duplicating takes

You can duplicate takes by selecting them in the Take List window and choosing Duplicate selected takes... under the Manage
menu, or typing command-D.

Each selected take will be duplicated, along with the ties to related cues. For each related cue, links will be created between the cue
and the duplicated take, as well as descendants of the cue and the duplicated take. Links between ancestors of the cue and the
duplicated take are created according to the "Modify ancestor cues" preference (see Cue status preferences for more info).



Modifying a single take

You can modify a take individually, or you can modify multiple takes in one operation. To modify multiple takes, see the next section. To
modify a single take, simply double-click on it in the Take List Window. The Modify Take Window opens:

[ NON ) Modify Take

Take Name 4 Modify Prev Next ?

KAR106_06_01
Modify & Next Cancel

Number 1 Subtake 0

Circled take Rating B
Character
Karli
Dialogue + Recording Notes
Light it up.

| Audio SIS

Folder |Mac HD:Users:Steve:Documents:ADR Manager projects:My Show:ADR
recordings:|

Files | AR106 06_01.L.wav [+] -]

~
Mono

Change the take's name and number, circled status, rating, dialogue, recording notes, linked audio files, and linked cues by selecting
them and typing in a new value and using tab or shift-tab to move to another field. See Creating takes for a more detailed description of
these fields.

If you want to save this take and close the Modify Take Window, click on Modify or hit the Enter key. The Modify Take Window will close
and the Take List Window will scroll so that the newly modified take appear highlighted in the middle of the window.

To save this take and modify the next take that is currently displayed below it in the Take List Window, click on Modify & Next. The Take



List Window will scroll so that the newly modified take appears highlighted in the middle of the window.

If you don't want to save any changes to this take, but you would like to modify an adjacent take in the Take List Window, click on the
Next or Previous button. The Take List Window will scroll so that the take to be modified appears highlighted in the middle of the
window.



Batch modifying takes

To modify multiple takes in a single operation, select the takes in the Take List window and choose Modify selected takes under the
Manage menu. The following window opens:

[ NON ) Batch Modify Takes
DG el
Circled take Rating B E
Dialogue Do not change H Recording Notes Do not change B

City call outs, walk-by conversations

Audio [ei
Replace a =

Cue name Start/End Dialogue Notes
LG102 404+01 City call outs, walk-by conversations Daytime
434+06

Any boxes that already have values represent common information among all of the selected takes. For example, if all of the selected
takes have the same dialogue, then the dialogue box will already be filled with the text. All other fields in the window will be left blank.
You may enter values in the blank fields and/or overwrite the common fields that have values. Leaving a field blank and choosing
Append, or leaving a field with common text and choosing Replace, has the same effect as not changing the field.

If some of the selected takes are circled and some are not, the Circled checkbox will display a line. Click on the checkbox to set all
takes to circled or uncircled.

If the selected takes have different ratings, the Rating popup will be blank. Choose a rating to set all selected takes to the same rating.

Under the Cues tab, you can change which cues are linked to the takes by choosing Append or Replace above the list of cues. To add
the cues that are currently highlighted in the ADR Cue List window, click the plus button. To remove cues, highlight them and click the
minus button.

Under the Audio tab, you can change the folder path of the takes' audio, as long as all of the selected audio files are in the same folder.



Enter the new folder path in the text field manually or by clicking on the Choose button. You are given the option of replacing the old
path with the new one, or adding a new path in addition to the old path. If there are other audio files in the old folder besides the ones
you selected, a dialog will ask you if you want to change the other audio files' paths as well.

| NON Batch Modify Takes

GModif  cancel 7
Circled take Rating B B

Dialogue Do not change Recording Notes Do not change

Audio eES

Old folder:
MyShow:Departments:ADR:Library:Loop Group:

New folder: Choose...




Showing related cues

You can quickly display the cues that are related to certain takes by highlighting the takes in the Take List window and choosing
Show related cues under the Manage menu. The results will replace whatever is showing in the ADR Cue List window.



Audio files and audio streams

ADR Manager can store information about audio files used in your project. In version 7, WAV and MXF-wrapped audio files are
supported. Storing audio files gives you the ability to audition takes, as well as place audio files in a Pro Tools session.

It is important to understand the difference between audio files and audio streams. An audio stream contains one or more audio files
that have the same characteristics such as sample rate, bit depth, timestamp and number of samples. The files must all live in the
same directory on disk. In the case of non-interleaved audio, each audio file contains a single mono channel of audio.

For instance, a stereo audio stream might consists of two audio files: one for the left channel and another for the right. In Pro Tools,
the left channel filename would end with .L and the right channel flename would end with .R. Both files share a common filename,
not including the channel suffix. However, ADR Manager supports other ways to associate audio files into streams. For instance, a
multichannel recording in Avid Media Composer produces multiple mono files that do not follow the Pro Tools naming convention.

Audio file information is stored internally and can only be accessed in the Modify Take window.

There is no separate Audio Stream List window to view and change audio file information. Instead, audio files are
accessed through takes.

ADR Manager can store multiple locations for an audio stream.

If you mount a volume that contains audio streams, you must update online statuses in order to audition the streams.



Takes and audio streams

A take may or may not have an audio stream attached to it. This gives you the flexibility of creating takes that you know have been
recorded, but you don't have the audio available to import into the database yet. If the audio filenames match your take naming
convention, then importing the files will automatically link each new take to appropriate cues, based on the take's name.



Auditioning audio

You can audition a take's audio in several places throughout ADR Manager.

Currently ADR Manager only supports mono or multi mono WAV audio. You can only audition one mono channel at a time. The

Channel popup above the waveform strip displays all available channels. Choosing a channel changes which audio file is loaded in the
player.

Once the audio player is in focus (by tabbing to it, or clicking in it), you can hit the spacebar to play/pause the audio. The left and right
arrows skip backward and forward by 0.5 seconds.

The Take List window

In the Take List window, if you highlight a take that has audio attached to it (and the audio is currently online), an audio player appears
at the bottom of the window.

[ ] @ Take List

+ 4%/ % 3 m 2
Name Number Subtake Dialogue Note

o) LG203_02 2

1 of 1 take selected

Left

The New or Modify Take window

You can attach audio to a take in the New or Modify Take windows. Once audio is attached, the waveform appears for the first file
(channel).



[ Audio [ReS

Folder Mac HD:Users:Steve:Documents:ADR Manager
databases:MyProject:Recordings:

Files 116203_02.L.wav [+ -]
LG203_02.R.wav

Left a
—% PR PR

Change channels by clicking on one of the audio files or changing the Channels popup. The channel you select can be stored with the
take if you click on the Modify or Modify & Next button. This lets you preserve the selection for next time and can also be used when

spotting to Pro Tools (see Exporting info an open Pro Tools session).

The Modify Cue window

The takes for a cue are listed under the Takes tab in the Modify Cue window. The Takes tab can be revealed by clicking on the
disclosure triangle at the bottom of the window.

@ History Lineage

Name Num Sub Dialogue

o)) KAR106_06_01 1 Light it up.
o) KAR106_06_01 1 Light it up.
] KAR106_06_02 2 Light it up.
] KAR106_06_02 2 Light it up.
] KAR106_06_03 3 Light it up.

Maono a
R Fow oy

Change channels by clicking on one of the audio files or changing the Channels popup.



Displaying an audio file in the Finder

You can display a take's audio file(s) in the Finder by selecting the take in the Take List window and choosing Show audio file in
Finder under the Manage menu. If more than one take is selected, only the first take's audio files are shown. If there are several
online copies of the take's audio file, ADR Manager randomly chooses one.



Updating the online statuses of audio files

If there are takes with audio files in your database, you can rescan the file system when you mount or unmount drives.

Make the Take List window active and choose Update online statuses under the Manage menu. Drives are scanned automatically
when the application first boots up.



Searching

You can control what records are displayed in the ADR Cue List and Take List windows by using the Search Window. The Search
Window lets you set up search criteria. Search criteria are the attributes you use to determine what records are to be displayed.
You can search for cues and takes based on character, reel, and other search items.

Searching is always limited to records that are in the current reel set. If you want to search across the entire database, make the "All
reel dupes" reel set active.

You can open the Search Window by selecting Search window (command-F) from the Windows menu. The Search Window will
appear:

o Search
Characters Reel set: Latest reel dupes

Abbr Name Reel Version Dupe date
1AN Analyst #1 J 00 WILD -
2AN Analyst #2 J 1011 0416a 4/19/21
3AN Analyst #3 J 1012 0423 4/23/21
4AN Analyst #4 J 1013 0414d 4/19/21
SAN Analyst #5 J 1021 0415A 4/15/21

J AAN Archives Analyst J 1022 0402d 4/8/21

J ARC Archivist J 1023 0414a 4/14/21
BAR Bartender J 1031 19.0 4/26/21

J LKB Boastful Loki J 1032 143  4/12/21
Check all Check none Check all Check none
3 of 64 characters checked All reels checked

W Hide additional options

Add result to currently displayed cues
Cue name is
Dialogue contains
Notes contains
Status is >= spotted

Priority is <= highest

is omitted
is locked
Creation date is exactly 12/18/21

Last modified date is exactly 12/18/21




If the Search Window is already open, a checkmark will appear beside Search window. If the Search Window is behind another
window or is inactive, select Search window to make the Search Window active. You can close the Search Window by clicking on
its close box, or typing command-W or command-period.

You can hide the additional search criteria to make the Search Window smaller. Click on the "Hide additional options" triangle to
shrink the window. Click on it again to grow the window. When shrunk, the window only shows the character and reel lists:

o Search
search forcues [ (ECTNNE
Characters Reel set: Latest reel dupes ﬁ
Abbr Name Reel Version Dupe date

1AN Analyst #1 + 00 WILD -
2AN Analyst #2 4 1011 0416a 4/19/21
3AN Analyst #3 & 1012 0423 4/23/21
4AN Analyst #4 « 1013 0414d 4/19/21
5AN Analyst #5 « 1021 0415A 4/15/21
J AAN Archives Analyst « 1022 0402d 4/8/21
« ARC Archivist J 1023 0414a 4/14/21
BAR Bartender + 1031 19.0 4/26/21
J LKB Boastful Loki + 1032 14.3 4/12/21
Check all Check none Check all Check none
3 of 64 characters checked All reels checked

P+ Show additional options (0 selected)

The "Show additional options" triangle text tells you how many additional options are currently checked, even though they are not
displayed. Checked additional options are always included as search criteria, whether or not they are displayed.

The Search Window can search for both cues and takes. The figure above shows what the window looks like when searching for
cues. To search for takes, change the popup at the top of the window to "takes." The list of characters and reels remain constant in
both modes of the Search window. The additional search criteria in the bottom half of the window changes, however. The additional
criteria for cues and takes are described in the sections below.

Once you've setup your search criteria, click on the Search button or type enter. The results of the search will appear in the ADR
Cue List or Take List Window, depending on what type of records you are looking for. If the appropriate window is not already open,
it will be opened. If the window is already open, it will be brought to the front and the results of the search will be displayed.



Searching by character and reel

You can search for both cues and takes using characters and reels. The left list in the Search Window displays all of the characters
in the project. The right list displays all of the reels in the production. The leftmost column in each list is for checkmarks. A
checkmark next to an item means that that item is to be included in the search. For example, if there is a checkmark next to a
character named Broom, then all of the cues for Broom will be found in the search. If you have several characters checked, then all
of the cues for all of the checked characters will be found in the search.

To place a checkmark next to an item in the list, click anywhere on the item. A checkmark will appear. To remove a checkmark, click
again on the checked item and the checkmark will disappear. To check all items in a list, click on the "Check All" button below the
list. To uncheck all items, click on the "Check None" button. As a shortcut, you can option-click on an unchecked item and all items
will become checked. Similarly, to remove all checkmarks from a list, option-click on a checked item and all items will become

unchecked.

Characters

Abbr Name
J 1AN Analyst #1
J 2AN Analyst #2
3AN Analyst #3
J 4AN Analyst #4

Remember, you cannot modify a character or reel by double-clicking on it in the Search Window. You can only modify a character or
reel in the Character List Window and Reel List Window, respectively.

Since a list is often longer than what will fit in the list's window, remember to keep in mind that there may be some checked items
that would not appear unless you scroll down. For your convenience, a status message appears below each list, telling you how
many items are currently checked.

To change reel sets, use the reel set popup above the reel list. Cues and takes that are currently displayed in the Cue and Take List
windows and are also part of the new reel set will remain in the window. Cues and takes that are not a part of the new reel set are

removed from the display.



Searching for cues
You can search for cues that belong to certain characters and reels by checking items in the character and reel lists in the top half of
the window.

In the bottom half of the window are the additional search criteria for cues (if the "additional options" triangle is pointing down):

W Hide additional options

Add result to a currently displayed cues
Cue name is E
Dialogue contains a
Notes contains a

Status is >= [ spotted s
Priority is <= [ highest s
is a omitted
is BJ locked

Creation date is exactly a 12/18/21

Last modified date is exactly K 12/18/21

The additional options for cues are:

e Join searches — This option lets you combine results from more than one search. After performing the first search, check
this option and set the popup to one of the following:

o Add result to currently displayed cues will add the results of your search to whatever is currently displayed in the
ADR Cue List window (i.e. union).

o Subtract result from currently displayed cues will subtract the results of your search from whatever is currently
displayed in the ADR Cue List window (i.e. difference).

o Search within currently displayed cues will perform the search within whatever is currently displayed in the ADR
Cue List window (i.e. intersection).

If this option is not checked, the results of the search will replace whatever is currently displayed in the ADR Cue List
window.

e Cue name — You can search cues name fields by checking this option and choosing "is", "is not", "contains", or "does not
contain". You can also use the wildcard character "@", which substitutes for one or more characters in a string. Text
searches are case-insensitive.

e Dialogue — You can search dialogue fields by checking this option and choosing "is", "is not", "contains", or "does not
contain". You can also use the wildcard character "@", which substitutes for one or more characters in a string. Text
searches are case-insensitive.

e Notes — You can search the public notes and private notes fields by checking this option and choosing "is", "is not",
"contains", or "does not contain." You can also use the wildcard character "@", which substitutes for one or more characters
in a string. Text searches are case-insensitive.

e Status — You can search for cues with certain statuses by checking this option, choosing the comparison operator ("<", "



<=" "=" ">=" "> "<>") and choosing the status level.

e Priority — You can search for cues with certain priorities by checking this option, choosing the comparison operator ("<",
<=" "=" ">=" "> "<>") and choosing the priority level.

e Omitted — You can search for cues that are or are not omitted by checking this option and choosing "is" or "is not".

e Locked — You can search for cues that are or are not locked by checking this option and choosing "is" or "is not".

e Creation date — You can search for cues by creation date by checking this option and choosing "exactly", "before", "after",
"today", "yesterday", "this week", "this month", or "this year".

e Last modification date — You can search for cues that have been modified since a certain date by checking this option and

choosing "exactly", "before", "after", "today", "yesterday", "this week", "this month", or "this year".

Note that the use of the character "&" in text fields may cause problems when searching.



Searching for takes

You can search for takes that belong to certain characters and reels by checking items in the character and reel lists in the top half
of the window.

In the bottom half of the window are the additional search criteria for takes (if the "additional options" triangle is pointing down):

W Hide additional options

Add result to B currently displayed
Take name contains LG203_02
Dialogue contains
Notes contains

Sound name Ccontains
Rating is <= B A
is E circled

has B cues

The additional options for cues are:

e Join searches —This option lets you combine results from more than one search. After performing the first search, check
this option and set the popup to one of the following:

o Add result to currently displayed takes will add the results of your search to whatever is currently displayed in the
Take List window (i.e. union).

o Subtract result from currently displayed takes will subtract the results of your search from whatever is currently
displayed in the Take List window (i.e. difference).

o Search within currently displayed takes will perform the search within whatever is currently displayed in the Take List
window (i.e. intersection).

If this option is not checked, the results of the search will replace whatever is currently displayed in the Take List window.

e Take name —You can search take name fields by checking this option and choosing "is", "is not", "contains", or "does not
contain." You can also use the wildcard character "@", which substitutes for one or more characters in a string. Text
searches are case-insensitive.

Dialogue —You can search dialogue fields by checking this option and choosing "is", "is not", "contains", or "does not
contain." You can also use the wildcard character "@", which substitutes for one or more characters in a string. Text
searches are case-insensitive.

Notes —You can search the recording notes fields by checking this option and choosing "is", "is not", "contains”, or "does not
contain." You can also use the wildcard character "@", which substitutes for one or more characters in a string. Text
searches are case-insensitive.

o Audio stream name —You can search takes whose audio stream name contains certain text. To search for takes with no
audio, select this option and choose Audio stream name "is" an empty string.

Rating —You can search for takes with certain ratings by checking this option, choosing the comparison operator ("<", "<=",
"=t o>t Ut fes") and choosing the rating level.



Circled —You can search for takes that are or are not circled by checking this option and choosing "is" or "is not".

e Has cues —You can search for takes that are or are not linked to cues by checking this option and choosing "has" or "has
no".



How ADR Manager performs the search

When performing a search, ADR Manager does the following steps:

1. The search sets for each checked character are "ORed" together. In other words, all the records found for the first checked
character are added to all the records found for the second checked character, etc. All of these sets combine to make a final
character set. If no characters are checked, then ADR Manager treats all characters as checked.

2. The search sets for each selected reel are "ORed" together. In other words, all the records found for the first checked reel
are added to all the records found for the second checked reel. All the records found for the third checked reel are added to
the other two sets, etc. All of these sets combine to make a final reel set. If no reels are checked, then ADR Manager treats
all reels in the current reel set as checked.

3. For each checked option in the Additional Options area, ADR Manager looks for all records that have that value. Specifically,
for the cue name, dialogue, and notes boxes, cues are searched that have the entered keyword. For the status and priority
boxes, the program will apply the selected comparison operator when searching. For the omitted and locked options, the
program will look for cues with those attributes.

4. Once the above steps are completed, ADR Manager performs a logical AND between the various sets of records. That is,
only records that are in the final character set, as well as in the final reel set, as well as in the various search options sets,
are considered to be the result.

After all of the above steps are completed, the results are displayed, added, subtracted, or intersected with the records in the
appropriate list window.



Reports

Reports are used to display information about various records such as cues, takes, reels, scenes, and characters. For instance, you
can print all of the cues for an actor so the report can be used on an ADR recording stage. Or you can print a cue count table to
show how many cues each character has in each reel.

Reports in ADR Manager are extremely flexible. For example, if a cue has a lot of dialogue, ADR Manager is smart enough to
"push" any succeeding cues down on the page to make room for the dialogue, rather than cut it off. For advanced users, you can
write scripts to control what records to display and how to display them.

When you run a report, a PDF file is created which you can view onscreen, then print or save to disk.

ADR Manager comes with several default reports, as well as the capability to design your own. The default reports have been
specially designed for actors, editors, mixers, and other target audiences. Click here for descriptions of the default reports.

When you create a new datafile, ADR Manager will automatically import the default reports stored in ~/Library/Application
support/ADR Manager/com.slanecon.adrmanager/Reports/Default/. You can change what reports are in this folder to customize the
default reports for new datafiles. You can also import a report at any time (see Importing a report from a record file for more
information).

You can only run reports that have been imported into your datafile. Reports saved on disk are not usable until they are
imported.

If this is the first time you are using a particular report with a particular printer, you may need to customize the report to fit the
printer's settings. Default reports that ship with ADR Manager were created to print correctly on Slanecon Digital printers, but since
all printers differ slightly in their margins and page sizes, you may need to adjust the report to match your printer's characteristics.

TIP: An easy way to use your customized reports with future databases is to make them "default" reports. Export them to disk,
then move them into ~/Library/Application support/ADR Manager/com.slanecon.adrmanager/Reports/Default/.



Using reports

You can run a report to either view onscreen or save directly to disk. Reports are available for the following types of records:

Cues

Takes

Reels

Scenes
Characters
Change events

Keyboard shortcuts

ADR Manager comes with several dozen default reports. For instance, an Actor Cuesheet is a report designed to be given to an
actor at a recording session. The dialogue text is in a large font, and it does not display private notes you may have made about
each cue. A Cue Count Table report is for characters (think of what records are displayed on each row of the report).

To create a PDF of a report, open the List window that is associated with that report. Depending on the report, you may have to a
search so that the records you want printed are displayed in the window. For instance, to print an Actor Cuesheet, make the ADR
Cue List window active. For a Cue Count Table report, make the Character List window active.



Viewing a report

You can view a report in Preview (macOS), before deciding to save it to disk or print to a printer.
To view a report:

1. Make the appropriate List window active. For instance, to view a master cue sheet, make the Cue List window active. To
view a LFOA list, make the Reel List window active. For cue count tables, make the Character List window active (because
the rows in a cue count table represent characters).

2. Perform a search to display the records you want included in the report. If you want to further hand pick which records are
included, highlight them in the window by shift-clicking or control-clicking.

3. Select File > Preview PDF. Reports appropriate to the List window are shown (unless they have been marked inactive). For
instance, reports such as Actor cuesheet appear for the Cue List window:

Preview reports as PDF
Select the report(s) you wish to preview

Mame Description Separate PDFs

Actar cuesheet Actar cuesheets do not include for each character
private notes.

Actor cuesheet Actor cuesheets do not include for each character
(both formats) private notes. Shows times in both

footage and timecode.
Actar cuesheet Prints without page breaks between for each ree
multichar characters. Cues from different

characters are merged together

Director cuesheet Shows times in both footage and for each character
(both formats) timecode.

© Preview currently displayed ADR cues — 7

Preview currently highlighted ADR cues Cancel

4. Some reports sort and group records so that they appear together on the same page. For instance, a Master Cuesheet sorts
cues by reel, and makes sure there is a page break between each reel. You can choose to make a separate PDF file for
each group of records by checking the Separate PDFs checkbox for each report. If you do not check the box, all of the
records are combined in a single PDF file.

5. Choose whether you want to include all displayed records in the list window, or just the highlighted records.
6. Select which reports you want to view by highlighting them in the reports list. Then click OK.

7. PDF files are created and displayed in Preview. If you selected more than one report, or you chose to create a separate PDF
for each group of records, multiple PDF files will be created. Filenames are dynamically generated using settings stored in
each report.

8. To save a report, choose File > Save from within Preview. To print a report, choose File > Print from within Preview.



Saving a PDF from a report

You can save a PDF of a report, by either viewing it in Preview first (macOS) or writing to disk directly.

To save a PDF file directly to disk:

1.

Make the appropriate List window active. For instance, to save a master cue sheet, make the Cue List window active. To
save a LFOA list, make the Reel List window active. For cue count tables, make the Character List window active (because
the rows in a cue count table represent characters).

. Perform a search to display the records you want included in the report. If you want to further hand pick which records are

included, highlight them in the window by shift-clicking or control-clicking.

. Select File > Save PDF. Reports appropriate to the List window are shown (unless they have been marked inactive). For

instance, reports such as Actor cuesheet appear for the Cue List window:

Save reports as PDF
Select the report(s) you wish to save

Mame Description Separate PDFs

Actar cuesheet Actar cuesheets do not include for each character
private notes.

Actor cuesheet Actor cuesheets do not include for each character
(both formats) private notes. Shows times in both

footage and timecode.
Actar cuesheet Prints without page breaks between for each ree
multichar characters. Cues from different

characters are merged together

Director cuesheet Shows times in both footage and for each character
(both formats) timecode.

o Print currently displayed ADR cues — ?

Print currently highlighted ADR cues Cancel

. Some reports sort and group records so that they appear together on the same page. For instance, a Master Cuesheet sorts

cues by reel, and makes sure there is a page break between each reel. Page numbering starts over at the beginning of each
reel. You can choose to make a separate PDF file for each group, or blend all groups into one PDF, by checking the
Separate PDFs checkbox for each report.

. Choose whether you want to include all displayed records in the list window, or just the highlighted records.
. Select the desired reports by highlighting them (shift-click or control-click to select multiple), then click OK.
. Select what folder you want to save the PDF files in.

. The files are generated and saved to disk. If you selected more than one report, or you chose to create separate PDFs for

each group of records, multiple PDF files will be created. Names for the files are automatically generated using settings
stored in each report. If a file already exists with the same name in the folder you selected, you can decide whether you want
to replace it or not.






Displaying reports

Reports are displayed in the Report List window. Adding, duplicating, deleting, and modifying reports can be done only when the
Report List Window is active. See List windows for a description of the buttons at the top of the window.

O O Report List
+ %7/ X ) (2
Active MName Description
Actor cuesheet Actor cuesheets do not Include private notes.
Actor cuesheet (both formats) Actor cuesheets do not include private notes. Shows times In
both footage and timecode.
Actor cuesheet multichar Prints without page breaks between characters. Cues from

different characters are merged together and listed
sequentlally by start time.

Change list
Character list abbrev Prints a list of characters sorted by abbreviation.

Character list name Prints a list of characters sorted by character name.
Character list pictures Prints a list of characters sorted by type, then character name.
Includes pictures.

- Mhearmntae Tad eos mabon T S | JPSR [

0 of 34 reports selected

You can open this window by selecting Reports (command-M ) from the Windows menu. If the Report List Window is already
open, a checkmark will appear beside Reports. If the Report List Window is behind another window or is inactive, select Reports to
make the Report List Window active. You can close the Report List Window by clicking on its close box, or typing command-W.

The Report List window displays the following columns.
e Active — Whether or not this report is available when choosing to preview or save a PDF for a List window
e Name — The name of the report. Reports do not have to have unique names.

e Description — The first few lines of the report's description.

You can customize the window by clicking on the Customize button in the upper right corner.

Adding, deleting, duplicating, and modifying information about reports is done by selecting items in the Manage menu when the
Report List window is active. When the window is active, the menu will look like this:

Windows Help
Add report 3EN

Duplicate selected reports 3D
Delete selected reports...

Use this menu to add, duplicate, or delete reports.

Use the Import... and Export... menu items under the File menu to save and load reports from disk. This allows you to reuse
reports in other database files (see Importing a report from a record file and Exporting a report to a record file for more information).



Creating reports

NOTE: Creating new reports from scratch requires some knowledge of 4th Dimension™ and Super Report Pro™. If you
would like to create a custom report, it is better to duplicate a default report, then modify it to your liking (see Modifying

reports).

To create new reports, you must have the Report List Window open and active. Select Add report from the Manage menu, or type
command-N. The following dialog will appear:

What type of records do you want to
create this report for?

Cus o ke

Cancel

The types of records you can display in ADR Manager are cues, takes, characters, reels, or scenes. For instance, if you want to create a
cue sheet report - that is, a report that displays the body section once for each cue selected - choose Cues, then click OK. The Edit Report
Window will appear with a blank report:



| NN | Edit report

Sort by:

Description Reel, scene, start, character Fage setup
PDF setup
Cancel
|| Show watermark 2
ADR cues per page: 0 Change... || Show total number of pages in footer .
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Please refer to Modifying reports for information on how to use this window.



Deleting reports

To delete reports, you must have the Report List Window open and active. Click, shift-click, and/or command-click the reports you
would like to delete. Select Delete selected reports from the Manage menu. Before ADR Manager deletes the reports, however, it
warns you that the operation is not undoable. If you proceed, be aware that you won't be able to "undo" the deletion by choosing

Undo from the Edit menu or typing command-Z.



Duplicating reports
To duplicate reports, you must have the Report List Window open and active. Click, shift-click, and/or command-click the reports
you would like to duplicate, then select Duplicate selected reports from the Manage menu.

For each duplicated report, a new report with the word "copy" appended to its name will be added to the report list. The new report
will be an exact duplicate of the selected report.



Modifying reports

You can modify existing reports by using the Modify Report Window. To open the Modify Report Window, double-click on a report in the
Report List Window. The Modify Report Window appears:

5] & Modify Report
Report name Actor cueshest ﬁ
Sort by:
Description Actor cuesheets do not include Character, reel, scene, start a Page setup
private notes. PDF setup
Cancel
Show watermark 2

ADR cues per page: B8 Change... Show total number of pages in footer

File Edit Object View Database

L
|- el
vt_ProjectName : B
i ADH CUE ShEEt Reel:¥s16_Reel\Versio 50
vs80_ActorMame B
Actor's Cop Dupe Date:vs16_DupeDate -
y vs80_CharacterMame P P -
Cue Number Start/End Dialogue Nodes :1 0o
Header] ¢ JEreak Header IBreak Header 2 -
t_FullDescription -
s16_CueName  s14_FFOA  t_Digitguader | +_PublicNotes L1350
s14_LFOA B
W 200
vPagaMum Mmﬂadg.ﬂ:@er fCate B
W SOTEEgar. com -
250
Footer| L300
|}I T T T Isﬁ T T T Ilmﬂl T T Ilsﬂl T T Izaﬂl T T Izsﬂl T T |3¢GI T T |3$Gl T T I4ﬂﬂl T T |4$GI T T Ismol T T ISSGI T T IEmGI T Il_ Pt W
€ b

The window is divided into settings at the top, and a graphical editor on the bottom. See The Design Area for information on how to use the
graphical design area in the bottom of the window. The settings in the top area consist of:

e Name - Enter a unique name for the report
e Description - Optionally enter a description for the report.

e Change records per page - This button lets you define the default number of records per page. See Adjusting the number of records
per page for more info.

e Sort by - You can change the way the report sorts records by selecting an item in the sort method popup. Depending on what kind of



record the report displays, you can choose from different sorting methods. See Sorting records for more info.

e Show watermark - For certain reports, you can display a light grey diagonal watermark across each page. Actor report watermarks
display the actor's name. Director report watermarks display the director's name. Editor report watermarks display the ADR
Supervisor's name. See Modifying characters to modify an actor's name, and Changing project information to modify the name of the
director or ADR Supervisor.

e Show total number of pages in footer - Checking this box changes the "Page X" text in the footer of each page to "Page X of Y".

You can customize other settings as well:

e Page Setup - Lets you adjust the page dimensions to match your printer. If you change the page setup, the guides in the graphical
editing area will change to match.

e PDF Setup - Lets you define how to name PDF files created from the report. See PDF Settings for more info.



Sorting records

For cues, you can sort the records by:

e Reel, scene, start time, character
e Reel, scene, start time, cue name
e Character, reel, scene, start time

e Reel, character, scene, start time

For takes, you can sort the records by:
e Reel, take name, take number

e Character, reel, cue start time, take number

For reels, you can sort the records by:

Reel number, dupe date
Version, reel number

LFOA, reel number

Dupe date, reel number

For scenes, you can sort the records by:
e Reel number, start time

e Continuity index

For characters, you can sort the records by:
e Abbreviation
e Character name

Actor name, character name

Recording info, character name

Type, character name



PDF Settings

PDF files are created when choosing File > Preview PDF or File > Save PDF. Since ADR Manager allows you to "batch print"
multiple reports, and each report can generate multiple PDF files, files are named dynamically based on the records selected and
other settings.

To customize how PDF files are named for a report, click on the PDF Settings button in the Modify Report window. The PDF
Settings dialog appears:

PDF settings

In the Preview/5ave PDF dialog, you can choose to create a single PDF file _
for the report, or separate PDF files for each reel. Choose how you want the

PDF files named for each situation.

Cancel
Single PDF filename
<Project name> <Report type> u
Multiple PDF filenames
<Project name> <Report types E

PDF report type
master

There are two settings saved with each report: one if the report is printed as a single PDF file, and another if the report is broken up
into multiple PDF files. See Viewing a report or Saving a report for steps on how to create single or multiple PDF files from a report.

e Single PDF filename - When printing a report for a single PDF file, choose which fields are used to construct the filename.

e Multiple PDF filenames - When printing a report for multiple PDF files, choose which fields are used to construct each
filename.

e PDF report type - You can enter any text here. If you choose a naming convention that includes <Report type> (see below),
this text will be substituted.

The popups present various naming conventions (combinations of fields) that you can choose to create a filename. The fields are:

e <Project name> - The name of the project, as entered in the Modify Project window.

e <Project abbreviation> - The abbreviation of the project, as entered in the Modify Project window.

e <Character abbreviation> - The abbreviation of the character, as entered in the Modify Character window.
e <Reel name> - The name of the reel, as entered in the New Reel window.

e <Report type> - The type of the report, as entered in the PDF Report Type field.

e <YYMMDD?> - The date at the time of printing. YY is the last 2 digits of the year, MM is the (zero-filled) digits of the month,
and DD is the (zero-filled) digits of the day.



Printing total number of pages in footer

If you wish to print the total number of pages in the report on each page, check the Show total number of pages in footer
checkbox. When you select this option and print or print preview, ADR Manager will first generate the report offscreen in order to
calculate the total number of pages. This may take awhile, depending on the size of the report. The report will then print normally,
with the total pages text printed at the bottom left corner of each page.



Adjusting the report margins

Since every printer has slightly different margin settings, it is important that you click on Page Setup at least once before using a
report. This will adjust the margins saved with the report. It may also give you the option of moving and/or resizing objects in the
report so that they are positioned appropriately, relative to the new margins (this feature is provided courtesy of SuperReport Pro™,
which is the report generation tool used in ADR Manager).

To adjust the report, click on the Page Setup button. The page setup dialog for your printer will appear. Verify the settings in the
page setup dialog and click OK. The red margin lines in the SuperReport Pro area will move to reflect the new printer settings.

If the printer's margins are different than the margins saved with the report, a dialog will appear:

SRPro: Adjust Report
Adjust Object Positions

The report's dimensions have been changed. The
following items can be automatically adjusted for you:

Adjust Object Positions
Adjust Sections
Adjust Guides

Don't Adjust Adjust

This dialog gives you the option of adjusting object positions (such as fields and text), adjusting sections (such as Header and
Body), and adjusting guides (such as the grid lines). Leave all 3 checkboxes checked. Based on the new red margin lines, decide if
you think it necessary to move the report objects. If the red margin lines have moved outward toward the edges of the page, you
might decide not to adjust the object positions by clicking on the Don't Adjust button. If, on the other hand, the red margin lines

have moved inward and some objects now appear to extend beyond the printable area of the page, you should probably click on the
Adjust button.

In any case, check the position of all objects in the report after performing the Page Setup command. Make sure all objects are
completely within the printable area. For those that aren't, move or resize them as necessary.



Adjusting the number of records per page

To adjust a report to fit your printer, follow these steps:

1. Create enough test records in the database to fill an entire page of the report. For example, if you are trying to adjust a
Master Cuesheet report and you want to set the maximum to 15 cues per page, create at least 15 cues from the same reel.
Make sure they are showing in the ADR Cue List window. Be sure the test cues' dialogue and notes fields contain little, if
any, text. This guarantees that the dialogue and/or notes fields won't make the body section of the report grow more than the

minimum, which would produce an inaccurate test case.

2. Open the report in the Modify Report window and click on the Page Setup button to adjust the margins of the report to fit your

printer.

3. Print preview the test records using the report.

4. Count the number of test records that were actually printed on the page.

5. Open the report again in the Modify Report window. If the "Records per page" number does not match the actual number of

records printed, click on the Change... button.

Report name Actor cuesheet

Description Actor cuesheets do not include

private notes.

I ADR cues per page: & Change...

Modify Report

— LS

Character, reel, scene, start E Page setup
PDF setup
Cancel
Show watermark 2

Show total number of pages in footer

File Edit Object View Database

The following dialog will appear:

A N OO S A Hevetia

so0:t P B I U ﬁ —




® O Adjust records per page

Make sure the following number is the number of ADR
cues per page that the report currently displays, based on
your current page setup:

Current ADR cues per page: |8
Set the following number to be the number of ADR cues
per page that you want the report to display:

New ADR cues per page: 8

. Enter the actual number of records printed in your test printout in the top field. Click on the Change button.

. If an adjustment is needed, ADR Manager will automatically resize the Body section of the report, and move and/or resize
objects within the Body section, to accommodate the new settings.

. Save the newly adjusted report by clicking on the OK button in the Modify Report window.

. You may want to export this report to disk so that you can use it next time without having to repeat these steps.



The design area

The design area in the lower part of the Modify Report Window is called a SuperReport Pro™ area. This section briefly describes
the main features you will use to modify your own reports. See the manual Designing Reports for ADR Manager for a more
complete description on all SuperReport Pro features (available from Slanecon Digital).

In all of the following sections, you must first click on an object to modify. Four small boxes will appear on each corner of the object.
To affect multiple objects at once, shift-click on them or draw a rectangle around them by dragging the mouse diagonally across the
objects (starting in a blank area). Common modifications you might make are:

e Changing the look of text objects
e Moving and resizing objects

e Changing an object's appearance at print time

File Edit Object WView Database

% B S Els ===== ==_ &

F
1

]
g
|
7
=
02
by
I 1=
e
mll

L)
| M
vt_ProjectName -
) ADR Cue Sheet Reel:vs16_ReelVersio =50
vsa0_ActorName -
Actor's Copy Dupe Date:vs16_DupeDate -
v380_CharacterMame P P -
Cue Number Start/End Dialogue Moles :lﬂﬂ
Header _cﬁreaﬁ Header IBreak Header £ &
t_FullDescription -
516_CueMame s14_FFOA l_m 1_PublicModes :150
s14_LFOA _
W 200
vPagaMum #egBody Ao otakger #Cate B
LTETe Gy Fe T e -
250
Footer| 300
F350
400
450
500
DI | |5¢I [ Ilal:l! [ |15|:|I LI Izﬂﬂl T T |25|:|! [ |3¢|:|! [ |3$|:|I LI |4¢|:II LI |45|:|! [ |5¢|:|| [ |55|:|I LI Iﬁﬂﬂl T || Pt v

€ >




Changing the look of text objects

To change the look of a text object, select it and choose from the various tools in the toolbar:

Font color
Font family and size  popt style  (option click)

Heorizontal and vertical justification



Moving and resizing objects

To move the object, click in the middle of the object and drag it, or use the arrow keys to move it 1 pixel at a time. To move an
object 10 pixels at a time, hold down the control key while using the arrow keys.

To resize the object, drag one of the four corners to change the object's size, or you can use the arrow keys. Holding down the
control and command keys and using the right and left arrows will move the right border of the object. Holding down the command
key and using the up and down arrows will move the bottom border. To resize an object by 10 pixels at a time, hold down the shift,
control and command keys while using the arrow keys.

The keyboard shortcuts are listed below:

Move object 1 pixel right Right arrow
Move object 1 pixel left Left arrow
Move object 1 pixel up Up arrow
Move object 1 pixel down Down arrow

Move object 10 pixels right

Shift-right arrow

Move object 10 pixels left

Shift-left arrow

Move object 10 pixels up

Shift-up arrow

Move object 10 pixels down

Shift-down arrow

Grow width of object by 1 pixel

Shift-command-right arrow

Shrink width of object by 1 pixel

Shift-command-left arrow

Grow height of object by 1 pixel

Command-down arrow

Shrink height of object by 1 pixel

Command-up arrow

Grow width of object by 10 pixels

Shift-control-right arrow

Shrink width of object by 10 pixels

Shift-control-left arrow

Grow height of object by 10 pixels

Shift-control-down arrow

Shrink height of object by 10 pixels

Shift-control-up arrow

You can also set the exact position and size of an object by selecting the object then choosing Position object (shift-command-P)
under the small Edit menu inside the report layout area.




Changing an object's appearance at print time

You can change the appearance of any object on a report at the time of printing. This can be useful, for instance, if you wanted
some text to appear in bold if a certain condition existed. For example, you might want a cue's "priority" field in a master cuesheet to
appear in red if the priority is above "Medium". To do this, you'll need to be familiar with editing an object's script (see the Designing
Reports for ADR Manager available from Slanecon Digital) as well as some understanding of the 4D language.

The routines RPT_SCRIPT_SET_OBJ_FORMAT() and RPT_SCRIPT_CHOOSE_OBJ_FMT() are used to set the format of an
object based on one or more conditions. They should be called from within an object's script. For more information, please contact
Slanecon Digital. If you're curious and adventurous, check out the script for the vtPriority object in the Body section of the "Master
cuesheet w/status" report for an example of how to use this routine.



The default reports

Default reports are stored in the "~/Library/Application Support/ADR Manager/com.slanecon.adrmanager/Reports/Default” folder
and automatically imported into new databases, but you can import reports at any time. Reports must be imported into your
database in order to use them. To import a report, use the Import command under the File menu when the Reports List window is
active.

Reports can be used to print out any kind of record in the database. One of the default reports is called "Character List", and it is
used to print out the list of characters in your project. There are also reports for reels, which are used to print out the list of reels in
your project. Another set of reports have names that start with the words "Cue Count Table", and they print a cue count table for
various character/reel combinations. However, most of the default reports deal with cues, and are called cue sheets. There are
several types of cue sheets that come as defaults with ADR Manager: Actor, Director, Editor, Master, and Mixer.

The following sections contain a sample screen shot and brief description for each type of default report.



Master Cue Sheet

The Master Cue Sheet is designed to be used before, during, and after recording the ADR. It displays all of the information about
the cues in as condensed a format as possible. You can customize this report to add, delete, or modify various elements. A sample
Master Cue Sheet looks like this:

Wy Bhow MDA Cus Sheet Flend:1 9
Masier Cupe D 1 1404

L * L hai et e O bt B

mENmn Mg ‘Wihal is i thal makes a man, a LI

Pral Bray 1784 0T man? o

Is 1l his anigins, tha way Hings
stari?
Or & isamething eise, samethineg
rerdar o desorbe? For me, tall
began in 1644, Clexsiled missian
af he coasl al Scotand. The
Mazis ware desparae. Sombning
soanoe and black magic, hey
infereded to Lpsai the Batsros of
tha war_ | was 23, Asady 3
parancemal advisar o Pres ident
Facsavetl | couldve resar
suspecied thal whal would
Irarspire et night, would not only
altel tha paurss of e history, bul
Ioraver change my lis

Al Bt Py dbiwis B Bcas i

LEa Loy 1B Zakdar Cal Ouls
Leap Grgap =+
" T. Boedland toees
ETI 15810 [SF L EEil
Gl it DT [EK ToF waning Iaops byl
- EXT_ Gralisnd Chapr! Brma b
Tana 113407 T T
Varang lvay et
minz o Thayll need hese.
Vg Bray 17RO
FT T TTm0T LAughFg]
Gl Sniiman k07
Twins e A you A Cabalc?
Bal Wailmas LTEeT
Pags | ' # B Joy SO e [t L R TR
e T

Scene headers stretch across the page to show where scenes begin.

A page break is inserted between each reel, and page numbering starts over after each break.



Editor Cue Sheet

The Editor's Cue Sheet is designed to be used by the ADR editor while on the recording stage. There is ample space provided for
each cue so the editor can write handwritten notes about each take. You can customize this report to add more space for
handwritten notes or add, delete, or modify other elements. A sample Editor Cue Sheet looks like this:

ADR Cue Shesl N
Ariy: David Mekon

railors Co izt

o T Ahbote D D I

My Bhiw
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Scene headers stretch across the page to show where scenes begin.
A page break is inserted between each reel/character combination, and page numbering starts over after each break.
The "Editor cuesheet takes" report lists all the takes for each cue.

If watermarking is enabled, the ADR Supervisor's name, entered in the Project Info window, appears as a diagonal watermark on
each page.



Mixer Cue Sheet

The Mixer's Cue Sheet is designed to be used by the recording engineer or mixer, and the recording engineer's assistant. It features
a 6 box grid for each cue. The boxes can be used by the mixer/assistant to note which track (i.e. on a multitrack recorder) each take
went on. You can customize this report to remove the grid box or add, delete, or modify other elements. A sample Mixer Cue Sheet

looks like this:
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Scene headers stretch across the page to show where scenes begin.

A page break is inserted between each reel/character combination, and page numbering starts over after each break.



Actor Cue Sheet

The Actor's Cue Sheet is designed to be used by the actor on the ADR recording stage. The text for the dialogue is in a bigger font,
and the text that you entered in the Private Notes box in the New Cue Window or Modify Cue Window is not included. This ensures
that whatever you typed in the Private Notes box won't be seen by the actor, such as a comment on the actor's performance. You

can customize this report to make the font for the dialogue bigger or add, delete, or modify other elements. A sample Actor Cue
Sheet looks like this:

My Bhiw

Acio 'y Copy
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Scene headers stretch across the page to show where scenes begin.
A page break is inserted between each reel/character combination, and page numbering starts over after each break.

If watermarking is enabled, the actor's name, entered in the New or Modify Character window, appears as a diagonal watermark on
each page.



Director Cue Sheet

The Director Cue Sheet is designed to be used by the director. Text that you entered in the Private Notes box in the New Cue
Window or Modify Cue Window is included. A sample Director Cue Sheet looks like this:

Scene headers stretch across the page to show where scenes begin.
A page break is inserted between each reel/character combination, and page numbering starts over after each break.

If watermarking is enabled, the director's name as entered in the Project Info window appears as a diagonal watermark on each
page.



Character List

The Character List report displays the character names, their abbreviations, and the actor names. You can customize this report to
change the spacing or add, delete, or modify other elements. A sample Character List looks like this:
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Reel List

The Reel List report displays information about the reels in the current reel set only. The report includes reel numbers, versions,
dupe dates, start timecodes, LFOAs. and running times. To print preview or print the Reel List, make sure the Reel List Window is
active, then select Print preview or Print under the File menu. A sample Reel List looks like this:

H}I' Show Reel List
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Reel History Table

The Reel History Table report displays all reel numbers, versions, dupe dates, and LFOAs in the database. To print preview or print
the Reel History Table, make sure the Reel List Window is active, then select Print preview or Print under the File menu. The
Print/Preview currently displayed/selected reels radio buttons have no affect on this report. A sample Reel History Table looks
like this:

My Show Reel Dupes Table
Reel
¥3 g ]
1 S/24./00 &f1z5m gfz2ion
TH24412 1810514 1991415
v L] B

2 s/ &MU RN
17TE0+0Z2 1788+00 1&78+01
& il
3 2400 &1
166501 166512
L] will L]
4 S/ &S1%500  &F2RI0N
ITiSedn iTITe0T (R2S0E

Lr 3 w3 Wi
5 S/EmA0 &M0500  BS22/00
1985415  180E+11  1800+05
vE Wl

6 s/ 641150
1820400 1812+00




Cue Count Table

A cue count table report displays a table. The column headings that run across the top of the table list the reel numbers in the
current reel set, while the row headings that run down the left side of the table list the character names. In each cell in the table, the
number of cues for that character and reel is displayed. Total cues and estimated time to record each character's lines run down the
right side of the table, reel totals run across the bottom of the table, and a grand total of cues and estimated time to record is
displayed in the lower right corner of the table.

To print preview or print the cue count table, make sure the Character List Window is active, then select Print preview or Print
under the File menu. The report will automatically adjust the number of columns according to the number of reels in the current reel
set. A sample cue count table looks like this:
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To display reel versions under each reel, open the Modify Report window and do the following:
e Duplicate the form object as4_ReelNumbers and call it as8_ReelVersions

e Move the position of as4_ReelNumbers so it sits above as8_ReelVersions

For more information about editing reports, see Modifying reports.



Keyboard shortcuts

The Keyboard Shortcuts report displays all of the shortcuts defined in the database

that you can refer to them easily while using ADR Manager.

. Use this report to print out your shortcuts so

My Project

Keyboard shortcuts
when pressed in Keystroke Description
any A0F Manager cmd [ Go to previous tabbed page in window
any A0DF Manager cmd ] Go to next tabbed page in window
any A0F Manager F3 Set start time to current transport time
any A0DR Manager F& Set end time to current transport time
any A0DR Manager shift F2 Tell transport to “play”
any ADR Manager shift F3 Tell transport to "stop”
any ADF Manager shift F3 Tell transport to “locate” to start time
Mew or Modify Cue shift-opt F3 Insert "hs per directors" into editor notes




Conforming

ADR Manager will help you conform your reels if you have changes to incorporate. You can insert time, delete time, or remove a
region and insert it elsewhere (in the same reel or a different reel, such as a rebalance).

Before conforming, check the current reel set to make sure you are conforming the proper dupe of the reel ("All reel dupes" cannot
be the active reel set). If the dupe you're looking for is not in the current reel set, modify the reel set to include it, or if the dupe does
not exist yet, create it.

Changes made by conforming are NOT undoable. Therefore, it is a good idea to backup your database file before
starting the conform process, and periodically while conforming.



Conforming using change lists

A change list is an ordered set of instructions, called change events, that can be applied to a reel dupe to move chunks of time
around. Normally you would apply a change list to a new reel dupe in order to conform its cues and scenes to a new version of

picture.

A change event can be an insert, delete, or replace event, and can be applied to leader, a single shot, a part of a shot, or multiple
shots. Change events can be performed, individually or in groups, or they can be skipped. See Performing change events for more

info.

If a change event is a delete, it can utilize a trim bin to save the deleted chunk so that an "insert hold" change event can later insert
the chunk in another location.

[ NN ) RO2 d12/15/18 to d2/16/18 change list
+/7X|C (& <\ (2
Version Dupe date Cur LFOA
From: 9 12/15/18 1437+@5 LFOA change =Z+11
To: 10 2/16/19 1437+@5 Conformed LFOA 1434+18
Selected net change: -1+15
v ¥ Start/End Duration Action Affected clips Cumulative chg
373+08
14 37Z2+@9 -13+@4 Delete 4 shots and hold as SBV.275 -31413
385+12 "Hald 7" SBV.300
15 37Z2+@9 -1+1@ Trim head SBT.005 -33407
374402
16 37Z+09 -2+15 Delete 1 shot and hold as SBT.005 -36+06
375407 "Haold 8"
17 372+@9 -1+@1 Trim head SBV.230 -37407
373+@9
18 373+15 9408 Insert 1 shot from "Hold 6° SBV.220 -27+15
383+06
19 383+@7 13+84 Insert 4 shots from "Hold SBV.2T5 -14+11
396+1@ ™ SBV.300
20 396+11 2+15 Insert 1 shot from "Hold 8° SBT.005 -11+12
399+89

1 of 31 change events selected



Displaying a change list
To open a Change List for a particular reel dupe, highlight the dupe in the Reel List window. Select Manage > Open change list or

click on the scissors button at the top of the Reel List window.

Reel List

<@ (2
pfdupes
Reel Version Dupe date FFOA LFOA
0o WILD 00/00/00
o1 2 31219 12+08 2000+08
02 10 21619 12+08 1437405

1 of 3 reels selected

The Change List window appears:



[ NON ) RO2 d2/16/19 to d3/12/19 change list

+# | X||C & | (2
Version Dupe date Cur LFOA
From: 10 2/16/19 1437+85 LFDA change a+2e
To: 11 3/12/19 1437+85 Conformed LFOA 1437+@5
v ¥ Start/End Duration Action Affected clips Cumulative chg

0 of O change events selected
e

The top of the Change List Window displays information about the previous reel dupe, if any, and the current reel dupe.
e From - The previous reel dupe's version, dupe date, and LFOA

e To - The current reel dupe's version, dupe date, and current LFOA. The Current LFOA will change as you perform each
event in the list.

e LFOA change - The difference between the previous dupe's LFOA and the current dupe's LFOA, as calculated by all of the
change events in the list.

e Conformed LFOA - What the current reel dupe's LFOA should be once all events in the list have been performed. Once you
have performed or skipped all events in the list, this value should match the LFOA change value.

e Selected net change - The sum total of the highlighted events in the list. You can highlight events by shift-clicking on them.
This is an easy way to do quick math on a block of events before you perform them. Unlike performing or skipping events,
you can highlight non-consecutive events.

At the bottom of the Change List Window you can see how many change events are currently displayed in the window and how
many are selected.

The Change List window displays the following columns as a default. You can customize the window by clicking on the_Customize
List button in the upper right corner.

e Status — If the event has been performed, a checkmark appears. If the event was performed as part of a group (using



Perform net change), a checkmark will appear inside a box that will span all the events in the group. If the event has been
skipped, an X appears. If the event has not been performed or skipped, this column is blank.

e Event number — The order of the event in the list.

e Start and end time — The start and end time of the event

e Duration — The duration of the event. This value shows a negative sign if the event is a delete or trim.
e Action — What type of event it is, such as "Insert shot" or "Move shots"

o Affected clips — What clips are affected, as imported from an Avid change list.

e Cumulative change — The total net change of all events up to this point.

Use the Customize List button to change what columns are displayed or the way events are sorted in the window.

When the Change List Window is active, the Manage menu will change:

: Windows Help

Add event... |
Modify event...

Delete events...

Consolidate events...

Start conforming...

Use these menu items to add, delete, modify or consolidate change events. You can also start conforming, which lets you perform
or skip each event in order.

You can import an Avid change list instead of manually entering each event one at a time. To import an Avid change list, see
Importing change events.

Replace shot events

If there are any "replace shot" events in the list, the Hide replace shots checkbox appears. Check the box to show only events that
have a length change. See Creating change events for more info on replace shot events.

LFOA change @+08
Conformed LFOA 1996+04

I Hide *Replace” events

lon Affected clips Cumulative chg



Understanding consolidation

ADR Manager provides the ability to condense, or consolidate, change lists to make the conforming process less destructive. This means
identifying events that can be combined to avoid unnecessary changes. Specifically, ADR Manager attempts to replace as many change
events as it can with Replace shot events. Replace shot events do not insert or delete time during conforming - they simply mark where
picture may have changed content, but not length.

Example

Let's walk through the steps of consolidating an Avid Media Composer change list. Here is a sample change list exported in columnar
format (text file):

(New)RE8 dupe 1/8/19 change list (01d)RE8 dupe 12/18/18 change list

18 events 0ld Duration 968+18
Al 8 insertions New Duration  968+88
- Reel # 2 deletions Total Change a+a2

All Counts Are Inclusive (inside/inside)

At This For This Total
Footage Length Do This Clip Name Change

_ 1. 8924+14 -2881+28 Delete Shot CM52588 _cmp_vB83 888231.mov -g@al+88
Be26+85

_ 2. 8924+14 +2881+28 Insert Shot CM52588 _cmp_vB85 821455.mov +8828+88
Be26+85

_ 3. 8929+12 -2812+89 Delete 7 Shots CM526668 cmp vea2 B8624E8.mov -8@12+89
Ba42+84 CM52828 cmp_vB88 816389.mov

_ 4. 8929+12 +2881+87 Insert Shot CM52668 _cmp_vB83 821457.mov -g@l1i+82
Ba31+82

_ 5. ©8931+83 +2882+12 Insert Shot CM52688 _cmp_vB85 823176.mov -p@aE+B6
pe33+14

_ 6. ©8833+15 +2882+21 Insert Shot CM52798_cmp_veee _822372.mov -B@a6+a5
B@35+15

_ 7. ©B936+80 +2881+87 Insert Shot CM52728_cmp_vBa5 822348, mov -g8e4+14
Ba37+06

_ 8. ©8937+87 +2883+21 Insert Shot CM52788_cmp_vB82_ 889987 .mov -g@el+13
Ba4a+a7

_ 9. ©o48+88 +2881+21 Insert Shot CM52808 _cmp_vB86 821448 . mov -gaea+12
Ba41+088

_ 1. Be41+89 +288e+14 Insert Shot CM52828 cmp_vB89 828332, .mov +88e8+82
Ba42+86

(end of Change List)

We open the Change List window and import the text file:



| NON RO8 d12/10/18 to d1/8/19 change list
+7/X/C) & < [ (2
Version Dupe date Cur LFOA
From: 3 12/10/18 960+18 LFOA change @+02
To: 4 1/8/19 960+18 Conformed LFOA 960+12
Selected net change: 84008
v z Start/End Duration Action Affected clips Cumulative chg
1 24+14 -1+88 Delete 1 shot CMS2580_cmp_v003_008231.mov -1+08
26+85
2 24+14 1+88 Insert 1 shot CMS2580_cmp_v005_021455.mov B+Be
26+85
3 29+12 -12+89 Delete 7 shots CMS2660_cmp_v002_006048.mov -12+09
472 +04 CM32820_cmp_v008_016309.mav
4 29+12 1+@87 Insert 1 shot CMS2660_cmp_v003_021457.mov -11+02
31+82
5 31+@83 2+12 Insert 1 shot CMS2680_cmp_v005_023176.mov -B+06
33+14
(3] 33+15 2+01 Insert 1 shot CMS2T00_cmp_v006_022372.mov -6+05
35+15
7 36+08 1+@87 Insert 1 shot CMS2720_cmp_v005_022340.mov -44+14
37+06
2] 37+@87 3+@1 Insert 1 shot CMS2T80_cmp_v002_009907.mov -1+13
49+87
9 49+08 1+81 Insert 1 shot CM3S2800_cmp_v00&6_021448.mov -B+12
41+08
10 41+89 B+14 Insert 1 shot CMS2820_cmp_v009_020332.mov B+B2
4Z2+06
0 of 10 change events selected

We then select all of the events and click on the Consolidate (blue vise) button to consolidate them. See Consolidating change events for
available options. Insert/delete pairs are replaced with "Replace shot" events:



| NON | RO8 d12/10/18 to d1/8/19 change list

+|.7 & S\ (2
ion Dupe date Cur LFOA
From: 3 12/10/18 960+18 LFOA change @+02
To: 4 1/8/19 960+18 Conformed LFOA 960+12
Selected net change: §4+-07 | Hide "Replace" events
v z Start/End Duration Action Affected clips Cumulative chg

1 24+14 1+08 Replace 1 shot CMS2580_cmp_v003_008231.mov a+0a
26+05 CMS32580 _cmp_v005_021455.mav

2 29+12 1+87 Replace 1 shot CMS2660_cmp_v002_006048.mov B+0a
31402 CM32660_cmp_v003_021457.mov

3 31+83 2+12 Replace 1 shot Unknown clip P+0@
33414 CMS2680_cmp_v005_023176.mov

4 33+15 2+01 Replace 1 shot Unknown clip P+0@
35+15 CMS32700_cmp_v006_022372.mav

5 36+08 1+87 Replace 1 shot Unknown clip 2+00
37406 CMS32720_cmp_v005_022340.mov

6 37+87 3+01 Replace 1 shot Unknown clip B+00
40+07 CMS2780_cmp_v002_009907.mav

T 40+08 1+01 Replace 1 shot Unknown clip 2408
41408 CMS32800_cmp_v006_021448.mov

2] 41+@9 e+14 Replace 1 shot CMS2820_cmp_v008_016309.mov B+0a
42+06 CM32820_cmp_v009_020332.mav

g 42+@7 e+82 Lengthen tail CMS2820_cmp_v009_020332.mov e+82
42+08

9 of 9 change events selected

Check the "Hide replace events" checkbox at the top of the window:




o0e®

RO8 d12/10/18 to d1/8/18 change list

+HIZX)G) &)

E
Iz ~J

[
=

Version Dupe date Cur LFOA
From: 3 12/10/18 960+10 LFOA change B+02
Ta: 4 1/8/19 I60+10 Conformed LFOA 96@+12
Selected net change: @+00 Hide "Replace" events
v £ Start/End Duration Action Affected clips Cumulative chg
g 42487 e+az Lengthen tail CMS2820_cmp_v009 020332 mov B+82
42+08

0 of 1 change event selected

Select the remaining event and perform it. The end result is much less destructive to the reel dupe.




Creating change events

You can manually create change events, or import them from an Avid change note (see importing change events).

To manually add a change event, you must have the Change List Window open and active. Select Manage > Add change event,
click on the plus button at the top of the Change List window, or type command-N.

[ Mew change event
Event number 2 Status Mot done “
Event type Delete shots E OK & Next
Number of shots 1 Cancel
?

Start time 1410+0@ Put shot in trim bin

Duration 2+0@ Trim bin name Hold 2 e

End time 14@9+15

Note

Enter the event's number, type, number of shots, start time, end time, duration, and optional trim bin and note. If you set the type to
Insert shots or Delete shots, you can enter the number of shots, which can be used to determine how events are consolidated.
You can also add, remove, or update a trim bin that is linked to the event.

New events default to the end of the list, but you can insert an event anywhere in the list by changing its event number. However,
the start time must fit chronologically where you are inserting the event.

Possible event types are:

e Insert shots - You can specify how many shots you are inserting. This can be useful when consolidating events. You can
link it to a trim bin to make it an "insert hold" event.

e Insert leader

e Lengthen head
e Lengthen middle
e Lengthen tail

e Delete shots - You can specify how many shots you are deleting. This can be useful when consolidating events. You can
link it to a trim bin to make it a "delete and hold" event.

o Delete leader
e Trim head
e Trim middle

e Trim tail



e Replace shots - Specifies shots that have been replaced but are equal in duration. This type of event does not affect
anything when performed.

Replace shot events are non-standard events that are not supported by other applications such as Avid Media
Composer.

Trim bins
Trim bins are used to store chunks of time between change events. The change events can be in the same list or in different lists.
The events can even be in lists for different reels, such as a rebalance.

If you create an insert or lengthen event that involves shots (not leader), the Get shots from trim bin checkbox appears. Similarly,
if you create a delete or trim event that involves shots (not leader), the Put shots in trim bin checkbox appears. If you check this
box, the trim bin area appears.

Put shot in trim bin

L]

Trim bin name

Enter the name of a new trim bin or choose an existing one from the popup. The trim bin will be linked to the change event. You can
have at most 1 insert event and 1 delete event linked to a bin. Trim bin names must be unique throughout the database. If you
unlink a trim bin from all change events, it will be deleted (you can reuse the name).



Importing an Avid change list

You can manually create change events, or import them from an Avid change list. To import from a change list, make the Change
List window active and select File > Import or drag the text file into an empty Change List window. For more information, see

importing change events. .



Modifying a change event

You can modify a change event by double-clicking on it in the Change List Window. Only change events that have not been done or
skipped can be modified. The Modify Change Event Window opens:

@ Modify change event
Event number 1 Status Mot done “
Event type Delete shots OK & Next
Number of shots 2 Cancel
?

Start time 1410+0@ Put shots in trim bin

Duration 120+17 Trim bin name Hold 12 %

End time 1538+11

MNote Apartment scene

Change the event's number, type, number of shots, start time, end time, duration, and optional trim bin and note. If the event is an
Insert shots or Delete shots event, you can change the number of shots, which can be used to determine how events are
consolidated. You can also add, remove, or update which trim bin it is linked to.

You can move an event to another position in the list by changing its event number. However, the start time must fit chronologically
in the new position (i.e. the start time must be equal to or greater than the previous event, and less than or equal to the following
event).

For more information about the fields in this window, see Creating change events.



Deleting change events

To delete change events, highlight the events you would like to delete in the Change List window, then select Delete selected
events from the Manage menu.

Before ADR Manager deletes the events it warns you that the operation is not undoable. If you proceed, be aware that you won't be
able to undo the delete by choosing Undo from the Edit menu or typing command-Z. Click OK to go ahead and delete the selected
events. If you click Cancel, the event(s) will not be deleted.

You must delete change events from the end of a change list. You cannot delete events from the middle or beginning of
the list.



Consolidating change events

ADR Manager provides the ability to condense, or consolidate, change events to make the conforming process less destructive.
See Understanding consolidation for an example.

To consolidate change events, highlight them in the Change List window and select Manage >Consolidate events. You can
highlight any group of events. A dialog appears:

o Consolidate change list

Apply the following to highlighted “

change events:
g Cancel

— Step 1: Split | .

Split up a multishot delete event If consecutive insert
events follow it, and

the number of shots are egual
the total duration is egual

e .

— Step 2: Reorder | .

Reorder events so that an insert event is next to a
delete event. if:

start times match
durations match

. &

— Step 3: Replace | .

Replace a pair of consecutive insert and delete events
with "Replace shot” if:

if start times match
if durations match

There are several steps the application will take, in order, to consolidate events into Replace shot events. In general, leave all
steps checked unless you do not want to apply specific logic to the consolidation process.

1. Split multishot delete events - Some applications, such as Avid Media Composer, provide an option to combine
consecutive "delete" events when exporting a change list. Combined delete events prevent ADR Manager from identifying
pairs of events that can be replaced. You can split up a multishot delete shot only if there are consecutive insert events that
follow it, starting at the same time. In other words, the first Insert shot event must start at the same time as the multishot
delete event, and there cannot be any gaps between the insert shots.

o The number of shots are equal - If checked, only split up a combined Delete shots event if the same number of
Insert shot events follow the multishot event. For example, a "Delete 3 shots" event would be split if there were 3
"Insert shot" events that followed it.



o The total duration is equal - If checked, a multishot delete event is broken up if its duration equals the total duration
of the insert shots that follow it. For example, a "Delete 2 shots" event with duration 10+00 would be split if it were
followed by several insert events whose total duration was 10+00.

2. Reorder - Some exported change lists, such as those from Avid Media Composer, group consecutive deletions together,
before the corresponding insertions. This can make it difficult to identify which insertion matches which deletion. ADR
Manager will guess at insert/delete pairings and rearrange the order so that an insert event will immediately follow its delete
event. You can choose the following options to help inform the process:

o Start times match - If checked, match an insert event to a delete event if they both start at the same time
o Durations match - If checked, match an insert event to a delete event if they both have the same duration
3. Replace - If an insert/delete pair is identified, both events are deleted and a Replace shot event is put in their place. Pairs
are identified using the following options:
o Start times match - If checked, match an insert event to a delete event if they both start at the same time

o Durations match - If checked, match an insert event to a delete event if they both have the same duration

You can highlight and consolidate events more than once.

If you expected a multishot delete event to be split up and it was not, check to see if it matches the number of insert shots
following it. If not, change its number of shots, highlight the delete and insert events, and click on Consolidate again.



Performing change events

Once you've imported or created a list of change events, you can apply them to your reel dupe.

Each time you perform a change event, it affects all cues and scenes within that range of time and updates the reel
dupe's LFOA.

To conform a reel dupe, click on the Start conform button or choose Manage > Start conform.

From: 3 12/110
To: 4 1/8;

The conform buttons appear, along with the Stop conforming buttong:

Stop conforming

0 ® 08 d12/10/1

+7|X|[G v g}~ @
Version LFOA

Highlight one or more change events in the Change List window and choose an action. As you walk through the list, a checkmark or
dash will appear next to each change event, showing whether you performed or skipped an event. You must perform or skip events
in order. The three types of actions are: Perform, Perform net change and Skip. They are listed under the Manage menu, or you
can use the buttons in the toolbar.

Perform net change

Perform Skip
N v
v |7}~ @

You can also use keyboard shortcuts:

e Option-v = click on Perform button
e Shift-option-v = click on Perform net change button

e Option-x = click on Skip button

You must perform events in order from the beginning of the list to the end. You cannot ignore events or do them out of
order. You must either perform them or skip them in order.

Perform

Perform selected events under the Manage menu or click on the Perform button at the top of the Change List window



As you perform each change event, the following things happen:

Cue times (start, end, and embedded times) will be modified
Scene times (start, end, and embedded times) will be modified

The reel LFOA will be adjusted. You can see what the current LFOA is by looking at the LFOA Change field at the top of the
Change List window.

If the event is a delete event that uses a trim bin (a "delete and hold"), all cues and scenes within the time range will be
saved in the trim bin.

If the event is an insert event that uses a trim bin (an "insert hold"), all cues and scenes in the bin will be inserted and the trim
bin will be deleted. Note that you must perform a "delete and hold" event before you perform the "insert hold" event with the
same trim bin.

Perform net change

You can also perform a net change, which allows you to lump together a block of successive change events and perform them as
if they were one event. In this case, highlight the events by shift-clicking on them in the Change List window and choose Perform
net change. Icons next to the events will show that they were performed together, with the first and last events showing the start
and end of the group. You cannot perform a net change that includes "delete and hold" or "insert hold" events.

Skip

If you decide an event should not be performed, you can skip the event by choosing Skip selected events under the Manage menu
or clicking on the Skip button. Remember, you cannot skip (or perform) events out of order.



Conforming cue scenarios

When ADR Manager performs a change event, it examines the cues that will be affected by the change. If the change occurs within
a cue, the software will pose questions to you about how you want to modify the cue. This section describes the possible scenarios.

All cues in a reel dupe can be moved during the conforming process, regardless of whether they are locked or not.

If you are inserting time, then ADR Manager will do the following:
e If the insertion point is before the cue, the cue is moved later in the reel. Embedded times are updated automatically.
e If the insertion point lies within the cue, the program will let you choose what to do.

e If the insertion point is after the cue, the cue will not be affected.

If you are deleting time, ADR Manager will do the following:
e If the deletion end point is before the cue, the cue is moved earlier in the reel. Embedded times are updated automatically.

e If the deletion region overlaps the cue, the program will let you choose what to do, depending on whether the head of the cue
overlaps the deletion region, the tail of the cue overlaps the deletion region, the deletion region is wholly within the cue, or the
cue is wholly within the deletion region.

e If the deletion start point is after the cue, the cue will not be affected.



If the insertion point is within the cue

If the insertion point lies within the cue, a dialog will come up describing the problem and giving you several options to choose from:

&3] Insert time
The insertion point is within this cue.
What would you like to do?
Inserti
From: = To: '°' Leave the cue untouched.
SZ2+08 62+08
Extend the tail of the cue.
Duration: 10+88
Cue info 1 Maove the cue by the insertion amount.
Start Time End Time -
Trim the head of the cue, then _
1o cha
58+12 34+11 move the cue later in time.

Ll Trim the tail of the cue.

Character
Jack ) Split the cue into two cues, and
Dialogue move the second one later in time.

Good morning! _
Auto apply this choice every time (hold opt to ask)

WO stop conforming

Information about the insertion region and the cue in question is on the left side of the window. If the cue is locked, a padlock icon
will appear next to the cue.

On the right side of the window is a list of actions you can perform. Each action has a description as well as a graphical
representation of what the action will do. Choose the appropriate action by clicking on its radio button, then click OK. The cue will be
affected by the action you choose, whether or not it is locked.

If you wish to abort the entire conforming process while in this dialog, click on the Stop conforming button. A warning alert will tell
you how many cues are left that have not been conformed yet. If you proceed, all changes made to the reel for this particular
conform event will be discarded.

Note that if you split a cue, the pieces may or may not remain in the "family tree" depending on whether the cue is recorded or not
(see Cue Lineages). If the cue has not been recorded yet, the first piece remains in the family tree and the other pieces start new
trees; that is, they are no longer linked to the original ancestor and their cue names are erased. If the cue has been recorded, all
pieces remain in the family tree. In this case, be aware that if you modify a descendant piece and propagate the changes to the
ancestor, the descendant's siblings will not get the change.



If the head of the cue overlaps the delete region

If the head of the cue overlaps the delete region, the following dialog appears, describing the problem and giving you several
options to choose from:

o Delete time
The area to be deleted overlaps the head of this cue. _
Cue o cl
What would you like to do?
Deleting
From: Tao:
16@8+12 161@+09 @ Move the cue earlier in time, but
Dusation: 1413 maintain its duration. - .
Cue info " Trim the head of the cue, then move  [|to chanse
Start Time: End Time: it earlier in time.
1o89+14 1615+82
= ki Leave the cue untouched.
Line number
Character | Delete the cue
Myers
Dialogue

| Auto apply this choice every time (hold opt to ask)
Waste Management Services...

GEGKI  stop conforming

Information about the deletion region and the cue in question is on the left side of the window. If the cue is locked, a padlock icon
will appear next to the cue.

On the right side of the window is a list of actions you can perform. Each action has a description as well as a graphical
representation of what the action will do. Choose the appropriate action by clicking on its radio button, then click OK. The cue will be
affected by the action you choose, whether or not it is locked.

If you wish to abort the process while in this dialog, click on the Stop conforming button. A warning alert will tell you how many cues
are left that have not been conformed yet. If you proceed, all changes made to the reel for this Insert Time will be discarded.



If the tail of the cue overlaps the delete region

If the tail end of the cue overlaps the delete region, the following dialog appears, describing the problem and giving you several
options to choose from:

& Delete time

The area to be deleted overlaps the tail of this cue. From——
What would you like to do?

Deleting
From: Tao:
1614+12 1616+09 (€ Leave the cue untouched.
Duration: 1+13
Trim the tail of the cue.
Cue info
Start Time: End Time:

]
I

1609+14 ~ 1615+@2 | ' Deletethe cue

Line number MY101

Character

Myers

Dialogue | Auto apply this choice every time (hold opt to ask)

Waste Management Services...
GNGKIN  stop conforming

Information about the deletion region and the cue in question is on the left side of the window. If the cue is locked, a padlock icon
will appear next to the cue.

On the right side of the window is a list of actions you can perform. Each action has a description as well as a graphical
representation of what the action will do. Choose the appropriate action by clicking on its radio button, then click OK. The cue will be
affected by the action you choose, whether or not it is locked.

If you wish to abort the process while in this dialog, click on the Stop conforming button. A warning alert will tell you how many cues
are left that have not been conformed yet. If you proceed, all changes made to the reel for this Insert Time will be discarded.



If the delete region is within the cue

If the delete region is contained completely within the cue, the following dialog appears, describing the problem and giving you
several options to choose from:

o Delete time
The area to be deleted is entirely within this cue. _
{Cue o cl
What would you like to do?
Deleting
From: Tao:
1610412  1612+09 (@ Leave the cue untouched.
Ll 1+13 Shorten the cue by the deletion
Cue info amaount.
Start Time End Time . :
Split the cue into two cues, and Cue| cha
1609+14 1615+02 [cue | chanse

move the second one earlier in

Line number MY101 Trim the head of the cue, then

Character move the cue earlier in time.
Myers

Dialogue

Waste Management Services...

change

i

Trim the tail of the cue.

Delete the cue

™

e

[
—

| Auto apply this choice every time (hold opt to ask)

SRR  Stop conforming

Information about the deletion region and the cue in question is on the left side of the window. If the cue is locked, a padlock icon
will appear next to the cue.

On the right side of the window is a list of actions you can perform. Each action has a description as well as a graphical
representation of what the action will do. Choose the appropriate action by clicking on its radio button, then click OK. The cue will be
affected by the action you choose, whether or not it is locked.

If you wish to abort the process while in this dialog, click on the Stop conforming button. A warning alert will tell you how many cues
are left that have not been conformed yet. If you proceed, all changes made to the reel for this Insert Time will be discarded.

Note that if you choose to split a cue, the pieces may or may not remain in the "family tree" depending on whether the cue is
recorded or not (see Cue Lineages). If the cue has not been recorded yet, the first piece remains in the family tree and the other
pieces start new trees; that is, they are no longer linked to the original ancestor and their cue names are erased. If the cue has been
recorded, all pieces remain in the family tree. In this case, be aware that if you modify a descendant piece and propagate the
changes to the ancestor, the descendant's siblings will not get the change.



If the cue is within the delete region

Cues that are completely within the deleted region will be deleted automatically, unless you checked the Ask before deleting cues
checkbox in the Conform window. If you did check the checkbox, then the following dialog will appear for each cue to be deleted:

O] Deleting time

This cue is completely within the delete region.

What would you like to do?

Deleting
From: Tao:
1609+00 1616+08 '°' Leave the cue untouched. I
Duration: 7+0@ 7 Delete the cue I
Cue info
Start Time End Time

16@9+14 le6l5+82

Line number My101
Character
Myers
Dialogue | Auto apply this choice every time (hold opt to ask)

Waste Management Services...
QRO stop conforming

Information about the deletion region and the cue in question is on the left side of the window. If the cue is locked, a padlock icon
will appear next to the cue.

On the right side of the window is a list of actions you can perform. Each action has a description as well as a graphical
representation of what the action will do. Choose the appropriate action by clicking on its radio button, then click OK. The cue will be
affected by the action you choose, whether or not it is locked.

If you wish to abort the process while in this dialog, click on the Stop conforming button. A warning alert will tell you how many cues
are left that have not been conformed yet. If you proceed, all changes made to the reel for this Insert Time will be discarded.



Importing and exporting

ADR Manager can import and export data in a variety of formats, with a tremendous amount of flexibility. For instance, you can
import from a tab separated text file whose columns are in an arbitrary order. Or you can import incomplete data and merge it into
existing records.

Importing and exporting is done by making the appropriate List window active and choosing File > Import or File > Export, then
selecting the type of file. An Options window will open, giving you a preview of the records along with many customizable options.
However, most tasks are accomplished by simply choosing one of the presets under the Settings popup.

See the table of file formats you can import and export to.
For information about the various setup options available, refer to Preparing to import and Preparing to export later in this chapter.

For a more in depth look at each particular record type, see the sections about cues, characters, reels, scenes, change events,
takes, and reports.

Round tripping

ADR Manager gives you the ability to export all of the necessary data from a record to an external file, and then import that data
back into the database without losing any information. This is called round tripping. Round tripping gives you the ability to move data
back and forth between ADR Manager and another application such as Pro Tools. For example, you may want to spot cues in ADR
Manager but conform them in Pro Tools. If you plan on round tripping, you should make sure you are setting up the export and
import options properly so you don't lose any information along the way.



File formats

The following table shows you which records you can import and export and in what file formats:

Table Import file format Export file format

Cues Tab separated text file Tab separated text file
Pro Tools session text file [Pro Tools session
Microsoft Excel

Change events Avid columnar change list [Avid columnar change list
Tab separated text file Tab separated text file
Microsoft Excel Pro Tools session

Characters Tab separated text file Tab separated text file
Microsoft Excel

Keyboard shortcuts Tab separated text file Tab separated text file
Microsoft Excel

Reels Tab separated text file Tab separated text file
Microsoft Excel Pro Tools session

Report AMS report file AM7 report file
AM?7 report file

Scenes Tab separated text file Tab separated text file

Pro Tools session text file [Pro Tools session
Microsoft Excel

Takes Tab separated text file Tab separated text file
Pro Tools session text file [Pro Tools session
Microsoft Excel
Audio files

Here is a brief description of the various types of import and export files:

e A tab separated text file stores individual fields of a record separated by tabs, and individual records separated by carriage
returns. If you intend to modify a tab separated text file to import it into another program such as Microsoft Excel™, be sure
you don't add or delete any tabs or carriage returns in the file.

e A Pro Tools session is the currently open session in Pro Tools. ADR Manager can "export" to a Pro Tools session by
placing clips in the Pro Tools Edit window. The session must be currently open in Pro Tools for this to work.

e A Pro Tools session file is an encrypted file stored on disk. ADR Manager cannot read or write to this file.

e A Pro Tools session text file is a specially formatted text file which can be exported from the currently open Pro Tools
session by choosing File > Export session as text. Be sure to export as a UTF-8 file instead of a TextEdit file to import
special characters properly, like ellipses (...). Pro Tools session text files cannot be opened or imported into Pro Tools.

e An Avid columnar change list is a text file exported from Avid Media Composer™. You can look at an Avid columnar
change list with a word processor, but we recommend you don't modify anything. Avid change lists are typically exported in a
special columnar format, which has a descriptive header and ample spacing between rows and columns. The columnar
format is easily readable by humans but can sometimes be problematic when importing, due to the wide variety of export
options in Media Composer. Note you can export from Media Composer to a tab separated text file, which may have less
problems importing into ADR Manager.

e A Microsoft Excel file contains data as a spreadsheet. Excel spreadsheet files can contain multiple worksheets, each with
its own table of data. For spreadsheets that contain multiple worksheets, ADR Manager will let you choose which worksheet
to import.

e Audio files can be imported individually or in groups. Metadata stored within the audio files is used to create records in the
database.



Common import and export settings

In the Import and Export Options windows, there are certain settings that are common for all record types.

Settings

The Settings popup at the top of the window allows you to save and recall settings:

@ & Import options for "Untitled.tsyv"

- 2
Settings = MySettings u — -

Cancel

m Mappings Defaults Options

o All saved settings are displayed at the top of the popup. The last used setting will be selected in the popup when the window first
opens. If no settings have been previously selected, the "Default" setting is selected.

e Save settings saves the current settings to disk. If the current settings are "Default", you must enter a new name.

e Save settings as... lets you save the current settings under a new name.

e Delete current settings... will delete the current settings. You cannot delete the "Default" settings.

e Import settings... gives you the ability to import settings from a disk file.

e Export settings... lets you export settings to a disk file. You can then move the settings to another computer, for example.

Saved 10 settings are located in various folders within ~/Library/Application support/ADR Manager/com.slanecon.adrmanager/IO
Settings.

Preview

The Preview tab shows what data will be imported from or exported to the external file. You can customize the data by changing the
settings under the Mappings, Defaults, Options, and Text tabs. If you change a setting, it is usually a good idea to come back to the
Preview tab to review what data you expect to import or export, before clicking OK.

Mappings

The Mappings tab displays a list of fields that you can import or export, along with a list of places in the external file that you can draw
those values from or send those values to. See Mapping fields to import and Mapping fields to export for more info.

Defaults

During importing, the Defaults tab displays a list of values that can be automatically inserted into every record, if it is missing that value
in the external file.



Preview  Mappings Defaults Options

Set default values for fields that are not imported

Field Default value

Is omitted
MName
Priority medium
Private notes

Public notes

Reel dupe date

Reel number

Scene brief description
Scene name

Start time

Status spotted
Take names

To automatically assign a value, check the box next to the field and enter a value. During import, if an imported record has a value for
that field, the imported value replaces the default value.

Options

The Options tab varies depending on what type of file you are importing or exporting to. See Importing Excel files, Importing a Pro Tools
session text file, Exporting tab delimited files and Exporting to an open Pro Tools session for more info.

Text

The Text tab provides options for manipulating the text during the importing or exporting process.

Preview  Mappings Defaults Options BRl-ris

| Import style tags in text
Delimiter between items in a list: III

Text substitutions 0ld text New text

Click In column to modify

Use r to represent a line break



Import/export style tags in text - Style tags are invisible characters embedded in text fields that specify changes in font name,
size, color, and style (such as bold and italics). In most cases you don't need to know they are there, except when importing or
exporting to an external file. Turn this option on if you want ADR Manager to preserve and recognize those special characters.

Importing and exporting style tags may add significantly more characters to certain text fields, and may make those fields
harder to read in the external file. Generally you import and export style tags only when you are round tripping.

You can specify a special character to serve as a delimiter between items in a list. For instance, you may want to list all of the
takes for a cue when exporting the cue. This special character should not appear in any other fields of the records you are
exporting.

ADR Manager lets you make text substitutions to preserve formatting. For example, if you are exporting to Pro Tools you may
want to substitute the string '_;' for a colon "' since Pro Tools does not allow colons in clip names. When importing, use the
converse to return to your original formatting.

If you are importing or exporting style tags (see above) make sure you don't substitute characters that are used by style tags,
such as <, >, and /.

ADR Manager will automatically encode and decode line breaks when exporting and importing. However, there may be cases
where an external text file uses a different character to represent a line break. You can define a substite for line breaks by adding
a row to the Text Substitution list, adding "\r' as the Old Text and the special character as the New Text. Note that fields in ADR
Manager store line breaks as \r (a backslash followed by the letter r).

Click on the + and - buttons to add and delete text substitutions. Click in the Old text or New text columns to modify a
substitution.

If you see odd looking characters, you may have imported a text file that was not saved as UTF-8. For example, note the strange
looking characters in this dialogue field:

State Police are considering a ban on all

public gatherings after CDC% announcement
that, ulu season% come early this year.WWell,
I dunno about wou folks, but IN never let fear

UTF-8 is a format that stores characters in Unicode format, which is a format that supports letters from all languages of the
world.Your text file was probably saved in Mac OS Roman, which is an older, less comprehensive format and will not translate to
Unicode properly. Open your text file in a word processor such as BBEdit and re-save it as UTF-8, then import again. If the text
file was exported from Pro Tools, choose UTFE-8 during the export instead of TextEdit.



Preparing to import

You can import files in one of two ways: you can drag a file into the appropriate List window, or you can make a List window active
then select File > Import and choose a file type. Choose the appropriate List window for the kinds of records you want to import.
For instance, to import cues make sure the ADR Cue List Window is active. To import reports, make sure the Report List Window is
active.

TIP: When importing cues, takes and scenes, make sure you have the correct reel set active before you start the import so that
the records are created in the proper reel dupes.

To import a file using the File menu, make the appropriate List window active and choose the Import item, then the type of file you
want to import:

Edit Manage Windows Help

New database...
Open database... #0O
Open recent >

Backup database...
Restore database...

Import > Tab separated text file...
b

Export Pro Tools session text file...

, Microsoft Excel file...
Preview PDF...

Save PDF... FEP

Only file types that are appropriate for the active List window are enabled. An Open File dialog will appear. Select the file that you
wish to import and click on Open. In the case of Audio files and Reports, you can select more than one file.

The Import Options dialog will appear. See Importing tab separated text files, Importing Pro Tools session text files, Importing Excel
files, Importing reports, or Importing audio files for more information.



Mapping fields to import

Under the Mapping tab in the Import Options windows, you can assign or "map" text in the external file to fields in the database. For
example, if you are importing from a Pro Tools session text file, you can parse text from a marker comment and put it in the Notes
field of a take.

The Mappings list

Under the Mappings tab is a list of locations in the import file that are mapped to fields in the database. For instance, a tab
separated text file may contain 12 columns, which ADR Manager labels as columns A through L. Each column can be mapped to a
field in a cue record:

Preview Mappings Defaults Options Text

Fields to import

From Using delimiters To
o Column A Reel number
(/]
Column B Reel dupe date
Column C Scene name
Column D Scene brief description
") Column aracter name
M ColumnE Ch
Column F Start time
") Column nd time
. Col G End ti
Column H Name
") Column ialogue

Col I Dial
¥ Column rivate notes
. Col ] Privat t
Column K Public notes
Colummn L Priority

The order of mappings defines precedence. Mappings are processed from top to bottom. In other words, if more than one mapping
maps to the same field, the lower mapping in the list will overwrite the upper mapping. For example, when importing from a Pro
Tools session text file, you may want to import the character abbreviation from the track name first, but overwrite the character
abbreviation if it is found in one of the track's clip names as well.

Fields to import, from top to bottom =
From Using delimiters To
Track name {CA } Character abbreviation
Clip name {CA } Character abbreviation E|
Clip name {D 3} Dialogue

To change the order of mappings, use the up and down arrow buttons to the right of the list. To remove a mapping, uncheck it or
select it and click the - button. To assign a field to a column, double click on it to open the Edit |0 Mapping window (see below).

Editing an import mapping

To map a column to a field, check the box next to the column name. To change a mapping, double-click on it. The Edit Import
Mapping window appears:



e _ @ Edit |0 mapping

Import data to field

From | column F

To Dialogue

| Extract text from delimiters

Choose the field you want to import and the location you want to import from. In the case of tab separated text files, the locations
consist of the columns found in the import file. In the case of Pro Tools sessions, you can choose from a variety of locations, such
as clip name, track name, marker comment, etc.

Using delimiters

To handle multiple fields embedded within a single imported text field, you can extract the fields using delimiters. See Using import
delimiters for more information.



Using delimiters

Sometimes the import file you are using does not separate data the same way ADR Manager separates its data into fields. In those
cases, you may need to extract multiple ADR Manager fields from a single text field. To distinguish the embedded fields, ADR
Manager uses delimiters. Delimiters are special characters that surround the field, identifying it and separating it from the rest of the
text. This is useful for readability, as well as to allow data to move back and forth between ADR Manager and Pro Tools (round
tripping).

To identify a field within some text, check the Extract text from delimiters box:

e _ @ Edit import mapping

Import data to field

From clip name H

To Dizlogue H
Extract text from delimiters
Delimiters {D } 7]

Parsing pattern (regular expression)

WD LN

. S Cance

A popup appears with a list of pre-defined delimiters to choose from. You can also define your own custom delimiters in the text box
below. Note this requires knowledge of regular expressions.

You should use the same delimiters when both importing and exporting fields, if you plan on round tripping.

Precedence

Under the Import Options > Mapping tab, fields are listed in the order they are parsed. For example, let's look at the following
mappings list used to import a Pro Tools session text file:

Clip name {CA } Character abbreviation
Clip name {D 3} Dialogue

In this case, ADR Manager will look for "{CA }" first. If found, it will remove the delimiters and text inside the delimiters from the clip
name, and put the contained text into the character abbreviation field. Then it will look for "{D }" in the remaining text, remove the
delimiters and contained text, and put the contained text into the dialogue field. You can change the order that ADR Manager parses
fields by moving the rows in the Mappings list up and down. You can preview how text will be parsed in the Preview tab.


https://en.wikipedia.org/wiki/Regular_expression

TIP: Create character abbreviation mappings in track names and cue names, making sure the cue name mapping is after the
track name mapping, as shown in the example above. In Pro Tools, put the character abbreviation in each track name to specify
that all clips on that track belong to the character. Then as you create clips in Pro Tools tracks, you don't have to keep entering
the character abbreviation for each clip. If the delimiters for a field are found in both a clip name and a track name, the text in the
clip name overrides the text in the track name. If you need more than one track for a character (such as loop group), add a suffix
outside the character abbreviation delimiters in the track name (each track name must be unique).

NOTE FOR VERSION 5 USERS:
The default delimiters have changed in version 7. The v5 default delimiters used punctuation characters (like [], //, **,
etc), which posed problems for several reasons:

e They are hard to remember

e They can cause errors if the punctuation mark is within the dialogue or notes.
e There are only so many of them. If future versions of ADR Manager offer more fields, we will run out of unique

punctuation marks to use.

As of version 7, default delimiters use curly braces and a one or two letter code, instead of punctuation marks. If you
want to continue to use v5-style delimiters, simply choose "OId style delimiters" from the Settings popup menu at the
top of the Import Options dialog.



The import process

After you've chosen the file to import and setup the import settings, click OK to begin the import process. ADR Manager looks at
each block of information in the import file and fills a new record using as much information as it can gather from the block. You can
control how that information is gathered in the setup options described above.

Once the information has been gathered, ADR Manager examines the partially filled record to make sure whatever fields were
imported are valid. Then it looks in the database for a record that may already exist with the same properties. If a duplicate is found,
a dialog appears asking you what you want to do. For example:

While importing ADR cue "JK101", a record with the
same name (JK101) and segment ID (6) was
encountered. What do you want to do?

Skip imported record

Replace existing record with imported cne

@0

Merge imported fields into existing record

Import as a brand new record

()

! Apply to all (— oK —) IZ:_' Cancel J

Depending on the situation, you have several options to choose from:

e Skip imported record — You can skip this record and continue importing the other records from the file.

e Replace existing record with imported one — You can replace the record that is already in the database with the imported
one. Note that there must be enough imported information to create a complete record, otherwise an error will occur and the
import process will be aborted (all previously imported records will be cancelled).

e Merge imported fields into existing record — This option lets you merge the imported information into the existing record.
Use this option if you only want to change one or two fields without affecting the other fields. For example, if you export only
cue IDs and cue Dialogue fields into a text file, you can spell check the text file using a word processor then import the file
back into the database using the Merge imported fields into existing record option during the import.

e Import as a brand new record — You can add a new record even though another record already exists with the same
values. Note that certain tables do not allow duplicate records with the same field values — in this case, the option is not
available. If you choose this option, there must be enough imported information to create a complete record, otherwise an
error will occur and the import process will be aborted (all previously imported records will be cancelled).

If you want the same option to automatically apply to all other records in the import file, check the Apply to all checkbox. To
continue, click OK. To cancel importing this and all previously imported records from the file, hit Cancel.

If you chose Import as a brand new record or Replace existing record with imported one, ADR Manager uses the imported
fields to fill in other empty fields in order to "flesh out" the record more. Finally, the program makes sure all of the required fields

necessary to save the new record are filled and valid. If everything checks out, the record is saved and the process is repeated for
the next block of information in the import file.

Note: During importing, ADR Manager tries its best to make sure records are complete and consistent. However if things don't
look correct after the import process, you can check for issues by running diagnostics on the database.



Importing tab separated text files

If you are importing from a tab separated text file, the following dialog appears:

| NON | Import options for “Tab delim 01.txt"
e
Settings | Default
Cancel
m Mappings Defaults Options Text
A-Name B-Segment type  C-Reel number D-Reel dupe date E-Start time
1 |Name Segment type Reel name Reel dupe date Start time

2 |JK101 reel 01 2/24/15 12+00

3 |LG101 reel 01 2/24/15 22400

4 |JK103 reel 01 2/24/15 32400

5 |LG102 reel 01 2/24/15 42+00

See Common import and export settings for an explanation of the Settings popup.

Preview tab

Assign a field to a column by right-clicking on a column header. To skip a column, assign it to "Ignore this column." Check the rows you want to
import. You can check or uncheck all rows by option-clicking on a checkbox.

Mappings tab

The Mappings tab lets you specify which fields are to be imported and in what order.



Preview RRgETlIE Defaults Options  Text

Fields to import

From Using delimiters  To
Column A Name
Column B Segment type
Column C
Column D Reel dupe date
Column E Start time
Column F End time
Column G Is locked
Column H Is omitted
Column 1 Priority
Column ] Status
Column K Take names
Column L Character name
Column M Dialogue

Check which mappings you want to import.
Assign fields to columns by double clicking on the mapping and opening the Edit IO Mapping window.

If ADR Manager recognizes a row of column headers in the import file, it will attempt to automatically create mappings for the columns.
Otherwise, you will need to create and assign mappings for each column.

Defaults tab

The Defaults tab allows you to assign values to fields that are not found in the import file.

Preview Mappings Defaults Options Text

Set default values for fields that are not imported

Field Default value
Ancestor cue ID
Character abbreviation
Character name
Dialogue
End time
D
Is locked
Is omitted
Name
Priority medium
Private notes
Public notes

To assign a default value to a field, check the box and enter the value in the "Default value" column. If the import file does not have a value for
the field, the default value will be used. If the import file does have a value for the field, it will override the default value. Defaults are useful since
often times a row in the import file does not have all of the necessary information to make a complete record in ADR Manager.

Options tab

There are no additional settings under the Options tab.



Text tab

The Text tab provides ways of converting and parsing characters and styles in the imported text. See Common settings for more info.

Preview  Mappings Defaults Options
| Import style tags in text
Delimiter between items in a list: E]

Text substitutions 0ld text MNew text



Importing Excel files

Microsoft Excel files are specially formatted packages that consist of one or more worksheets. ADR Manager treats each worksheet as an
individual tab separated text file.

Options tab

If the spreadsheet contains more than one worksheet, you can choose which worksheet you want to import under the Options tab:

| JoN Import options for "Cues no headers.xlsx"

?
st Lok

Preview Mappings Defaults Options Text

Worksheet = Sheetl

See Importing tab separated text files for a description of the other settings in this window.



Importing a Pro Tools session text file

ADR Manager can import data from Pro Tools session text files to create various records in the database. For instance, clips or markers can be
converted to cues. Be sure to save the text file from Pro Tools with the proper formatting (see Saving a Pro Tools session as text).

You can import information from many different places in a Pro Tools session text file, including:

e Clip names

¢ Clip mute status

e Track names

e Track comments

e Marker numbers

e Marker names

e Marker comments

e Session file name

e Session folder name
Data can be parsed using delimiters so that you can store multiple fields in one location. For instance, a clip name might contain 3 fields: a cue's
character name, dialogue, and a public note. Each piece of information is surrounded by delimiters so that they stay separate from one another.

Make the appropriate List window active and pick a text file using File > Import > Pro Tools session text file. Or drag the text file into the ADR
Cue List window.

The following dialog appears (for ADR cues, in this example):

[ NON Import options for “test A8k.txt"
[T
Settings | Default B
Cancel
Preview Mappings Defaults Options Text
Session start a+0a
Import into reel | 01 B dupe 8/1/18
Tracks to import Fields to import, from top to bottom =
Tracks From Using delimiters  To
Audio 1 Track name {A} Character abbreviation
Audio 2 Clip name {A} Character abbreviation
Audio 3 Clip name IN } MName
Audio 4 Clip name {D} Dialegue
Clip name {B} Public notes
Clip name V3 Private notes
Clip name {P} Priority
Clip name {51} Status
Clip name {0} Is omitted



See Common import and export settings for an explanation of the Settings popup.

Preview tab

The Preview tab displays the records that will be imported.

Mappings tab

The Mappings tab lets you specify what tracks to import and how to parse the track and clip names so that the proper data goes in the ADR cue
fields:

e Import into reel — Choose which reel you want to import the records into. Only the reels in your current reel set are available. If a reel
exists in the current reel set with the same timecode start as the session you are importing, the reel is automatically selected in the popup.
If no reel matches, the first reel in the current set is selected. However, you can always change the import reel. If the time format or start
time of the reel does not match the file to import, a warning will appear in the window.

e Tracks to import — Check which tracks you want to import.

o Fields to import — Check the fields you want filled by parsing text in your track or clip names.

For more information about importing fields, see Mapping import fields.

Since Pro Tools clip names have a limit of about 250 characters, text for a single cue might be spread across multiple clips (see Exporting to Pro
Tools). If ADR Manager encounters a "{+}" string at the beginning of an adjacent clip, it will concatenate the second clip's text to the first.

Defaults tab

The Defaults tab allows you to assign values to fields that are not found in the import file.

Preview  Mappings Defaults Options  Text

Set default values for fields that are not imported

Field Default value
Ancestor cue ID
Character abbreviation
Character name
Dialogue
End time
1D
Is locked
Is omitted
Name
Priority medium
Private notes
Public notes
Reel dupe date 8/1/18

To assign a default value to a field, check the box and enter the value in the "Default value" column. If the import file does not have a value for
the field, the default value will be used. If the import file does have a value for the field, it will override the default value. Defaults are useful when
the import file does not have all of the necessary information to make a complete record in ADR Manager.

Options tab

The Options tab lets you change certain settings:



Preview Mappings Defaults Text

Ignore clips that start before the reel FFOA or after the LFOA

Strip off number suffixes in clip names, such as “-01"

¢ Ignore clips beyond reel — You can choose to ignore clips, such as head or tail pops, that occur before the reel's FFOA or after the
reel's LFOA

o Strip off number suffixes — Removes any trailing number suffix in the clip name, such as "-01". This is the suffix that Pro Tools adds
when you edit a clip.

Time fields must be in the same format as the currently displayed database time format.

Importing a clip that is 1 frame or less in duration will create a cue with no end time (i.e. it will be open ended).

See Importing cues from a Pro Tools session and Importing scenes from a Pro Tools session for step by step instructions on how to prepare and
import clips for cues and scenes.

Text tab

The Text tab provides ways of converting and parsing characters and styles in the imported text. See Common settings for more info.

Preview Mappings Defaults Options

Import style tags in text
Delimiter between items in a list: |II

Text substitutions 0ld text New text

[1]+]

Importing clips with fades

Fade ins and fade outs are considered part of the clip. The start of a clip is considered to be the start of the fade in, and the end of a clip is at the

end of the fade out. Crossfades are handled as a fade out ending at the midpoint of the crossfade and a fade in starting at the midpoint of the
crossfade.

For more information, check out an example.



Saving a Pro Tools session as text

In order to import information from Pro Tools, you must first export the session to a text file, then import the text file.

Due to Avid restrictions, there is no way to import a Pro Tools 12 session directly into ADR Manager. If you want this
functionality, please contact Avid directly and let them know you want them to give Slanecon Digital access to the session file
format.

To export to a text file, choose File > Export > Session info as text within Pro Tools. The following dialog appears:

Export Session Text

Include File List
Include Clip List
Include Markers

Include Plug-In List

Include Track EDL's
O Al Tracks
Selected Tracks Only

Show Subframes
Include User Timestamps

Fade Handling
0 show Crossfades

Don't Show Crossfades
Combine Crossfaded Clips

Time Format:
Feet+Frames

File Format:
UTF-8 'TEXT'

Depending on what types of records you want to import, select Include File List and Include Clip List. See Importing cues from a
Pro Tools session, Importing scenes from a Pro Tools session, and Importing takes from a Pro Tools session for specifics.

It doesn't matter whether Include Plug-In List or Include User Timestamps is checked or not. ADR Manager ignores this
information when importing.

If you are importing clips, Include Track EDLs should be checked. If you are importing markers, Include Markers should be
checked. In the case of creating subtakes from clips and markers, check both.

Choose whether you want to export All tracks or Selected tracks only. Exporting all tracks is fine - you can selectively choose
what tracks you want to import within ADR Manager.

Show Subframes must not be checked.



Fade Handling should be set to Show Crossfades. ADR Manager will merge fade ins and outs with clips and count them as part of
the clip's start and end time inclusively. Crossfades will be split into two equal halves, with the first half added to the end of the

previous clip and the second half added to the start of the next clip.
Time format should match the currently displayed time format in ADR Manager.
The text file format should be UTF-8 'TEXT". If you export as "TextEdit "TEXT™", special characters such as ellipses (...) may not be

imported correctly.

It is a good idea to always export as UTF-8 'TEXT".



Merging adjacent Pro Tools clips during import
ADR Manager can combine contiguous clips on a Pro Tools track to form one cue. To signify that an adjacent clip is a continuation of the previous clip, its name
must start with the special string {+}.
For example, create two adjacent clips in a Pro Tools session with the following names:
e {D Mm, | don't know...
o {+}\nLet's look at the stars}

The first clip has an open-ended delimiter for dialogue {D. The second clip starts with a continuation character {+} followed by a newline \n and the rest of the
dialogue, and ends with the closing delimiter }.

135+00 140+00

{D Mm, | don't know... {+} \nLet's look at the stars}

Import the session text file using the {D } delimiter for dialogue:

{ Preview Mappings Defaults Options Text |

Session start 2+00
Import into reel | 01 a dupe 9/14/20
Tracks to import Fields to import, from top to bottom =
Tracks From Using delimiters To
[ | Markers Track name 1 Character abbreviation
[IK] Clip name 1 Character abbreviation
Clip name {D} Dialogue

The resulting cue will look similar to this:

| NN ADR Cue List
[EAE3ES o)
L Reel Scene Cue name Start/End Character Dialogue All Notes Status/Priy
01 - 121+08 Jack Mm, I don't know... Spotted
156+04 Let's look at the stars - Medium

0 of 1 ADR cue selected (& cues in 'Latest reel dupes' reel set)




Importing audio files

To quickly build or add to a library of media, you can have ADR Manager scan a folder for any recognizable audio files. ADR Manager currently
supports MXF and WAVE (including Broadcast WAVE) audio file formats. The files are "registered" with ADR Manager and are linked to new or
existing takes.

If an audio filename adheres to the take naming convention you have defined for your database, then ADR Manager will parse the audio
filename, create a new take, and automatically link the take to the cue(s) it is related to. See Take naming preferences for more information.

To import audio files, drag them into the Take List window, or select File > Import > Audio Files. The following dialog appears:

| NON | Impert options for multiple files
e °
Settings | Default B
Cancel

m Mappings Defaults Options Text

Importing 4 of 4 rows

Name Number Subtake number  Is circled Rating

1 LGR_101_03 3 False B

2 LGR101_01.1 1 False B

3 LGR101_01 1 False B

4 LGR101_02 2 False B

See Common setting for an explanation of the Settings popup.

Preview tab

Assign a field to a column by right-clicking on a column header. To skip a column, assign it to "Ignore this column." Check the rows you want to
import. You can check or uncheck all rows by option-clicking on a checkbox.

Mappings tab

The Mappings tab lets you specify which fields are to be imported and in what order.



[ NON Import options for multiple files

?
Settings | Default _

Cancel
Preview Defaults Options Text
Fields to import =
From Using delimiters To
Media name MName
Media name Custom Number E|
Media name Custom Subtake number
Media emb...d clip name MName
Media emb...d clip name Custom Number
Media emb...d clip name Custom Subtake number

Check which mappings you want to import.

The clip name stored in an audio file's metadata header can sometimes be different than the filename. When importing, the default is to
override the filename with header metadata, if any is present (the "Media embedded clip name" mappings are listed after the "Media name"
mappings). If you prefer to use the filename as the name for the take, uncheck the mappings for "Media embedded clip name".

Assign fields to columns by double clicking on the mapping and opening the Edit IO Mapping window.

Defaults tab

The Defaults tab allows you to assign values to fields that are not found in the import file.



[ NN Import options for multiple files

?
P Defaut: oK

Cancel

Preview  Mappings BEEFES Options  Text

Set default values for fields that are not imported

Field Default value
Cue names
Dialogue
End sample in media
End timestamp
End timestamp in usecs
ID
Is circled False
Media entity ID
Media entity name
Name
Number
Rating B

To assign a default value to a field, check the box and enter the value in the "Default value" column. If the import file does not have a value for
the field, the default value will be used. If the import file does have a value for the field, it will override the default value. Defaults are useful since
often times the rows in the import file does not have all of the necessary information to make a complete record in ADR Manager.

Options tab

There are no additional options available for importing audio files.

Text tab

The Text tab provides ways of converting and parsing characters and styles in the imported text. See Common settings for more info.






Importing reports
Reports must be imported and stored in the database to be used. Default reports are automatically imported when you first create a
database, but you may have customized reports that you want to import.

Make the Report List window active and choose File > Import > Reports. Or you can import older ADR Manager 5 reports by
selecting File > Import > Reports (ADR Mgr 5). You can select multiple reports to import at the same time. You can also drag and
drop report files into the Report List window.

There are no options available for importing reports.



Preparing to export

Export to files by making the appropriate List window active and highlighting the records you want exported. Select File > Export
and choose a file type:

Edit Manage Windows Help

MNew database...
Open database... ¥0
Open recent [

Backup database...
Restore database...

Import 2

Tab separated text file...
Preview PDF... Pro Tools session...
Save PDF...

You will prompted to enter a name and location for the file you are going to create (unless you are exporting to a currently open Pro
Tools session).

Depending on what you are exporting, an Export Options dialog may appear. See Exporting to tab separated files, Exporting to an
open Pro Tools session or Exporting reports for target-specific information in the Export Options dialog.

After confirming the options, the document will be saved to disk.

Exported time fields will be in the same time format as the currently displayed time format.



Mapping fields to export

Under the Mapping tab in the Export Options windows, you can assign or "map" fields in the database to places in the target file.

The Mappings list

The Mappings tab lists places you can export to, in the target file. For instance, if you are exporting to a Pro Tools session, fields
can be exported to the clip name:

Preview ERuEldl 1 Options  Text
[+] -]

From Using delimiters To
Mame {N 3} Clip name
Dialogue {D?3 Clip name E|
Private notes iV 3} Clip name
Public notes {B3} Clip name
Character abbreviation 1CA Clip name
Status {51 Clip name
Priority {P} Clip name
Is omitted {03 Clip name
Reel number {R} Clip name

If more than one field maps to the same target location, the fields are concatenated together in the order they are listed, from top to
bottom. You can change the order by selecting a mapping and using the up and down arrows to the right of the list.

Editing an export mapping

To add a mapping, click on the + button. To change a mapping, double-click on it. The Edit Export Mapping window appears:



@ _ 0 Edit export mapping

Export data from field
From | dialogue E

To clip name a

Embed text within delimiters

Choose the field you want to export and the location you want to export it to. In the case of tab separated text files, the locations
consist of columns A through how ever many fields you are exporting. In the case of Pro Tools sessions, the only location you can
choose is "clip name".

Delimiters

In the case of exporting to a Pro Tools session, you may want to export more than one field to the clip name. For example, you
might want to include the cue name and the dialogue. In this case, you should use delimiters. Delimiters surround each field with
special characters to differentiate one from another. This is useful for readability, as well as being able to import back in from the
external file (called round tripping). To create delimiters for a field, check the Embed text with delimiters box:



@ _ 0 Edit export mapping

Export data from field
From | dialogue
To clip name

Embed text within delimiters

Delimiters {D }

Composing pattern { 41 is replaced with value)
(DA}

A popup appears with a list of pre-defined delimiters to choose from.

You can also define your own custom delimiter in the Composing pattern text box. Be sure to include the string "\1" in the

composing pattern to show how the field value is surrounded by the delimiters. Remember to use the same delimiters if you import
the same external file.



Exporting tab delimited files

See Common settings and Mappings export fields for general information about exporting.

When exporting to a tab delimited text file, you export each field to a column. You define which fields will go in which column under
the Mappings tab.

Preview Mappings Options Text
|+~

From Using delimiters To

Reel number
Reel dupe date Column A E|
Character name Column B
Start time Column C
End time Column D
Name Column E
Dialogue Column F
Private notes Column G
Public notes Column H
Scene name Column I
Scene brief description Column J
Priority Column K
Status : Column L

To move fields to different columns, use the up and down arrow buttons to the right of the list. To remove a field from a column,
uncheck it, or delete the row by selecting it and clicking on the minus button. To swap a field in a column, double click on it. To add
a new column, click on the plus button. Changing or adding a mapping opens the Edit IO Mapping window (see below).

Options tab

The Options tab lets you set the following options:



[ ] @& Export aptions

Fields W

Put column headers in the first row
Replace line breaks in text fields with | \n
Use | | as a delimiter between items in a list

Export style tags in text

Put column headers in first row — If you want each column to have a header, check this box. By including column headers
in the export file, you can easily import the file into other database applications (or back into ADR Manager) by linking fields
in the file to fields in the database.

Line break substitution — When exporting fields that contain line breaks, such as a cue's dialogue field, it is important to
replace or remove the line breaks, otherwise the exported file will have the wrong format. Check this box and designate the
character you want as a substitute for line breaks.

List items delimiter — Certain fields may contain lists of items, such as the names of the takes for a cue. Those items must
be delimited by a character. You can specify what that delimiter is here.

Export style tags — To preserve any styles you may have applied to text, such as bold or italics, turn on this option. Special
characters will be added to the text during export to preserve your formatting. Be sure to check the same option during import
to read the special characters and re-apply the formatting.



Exporting to an open Pro Tools session

You can create clips in a Pro Tools session for cues, reels, scenes, takes - even change events. Adding clips in a session is called "spotting" in Pro Tools
parlance, not to be confused with spotting in ADR Manager. When you spot in a Pro Tools session, you create a clip on a track whose start and end times
match the ADR Manager record, and whose name contains various fields of the record.

Although the term exporting technically means creating a new file on disk, we use the term in this chapter to refer to adding clips to a currently open Pro
Tools session.

IMPORTANT: Spotted clips are placed on top of whatever happens to exist on the track previously. ADR Manager has no way of knowing what
clips are on the tracks beforehand. Please make sure to spot to blank tracks.

To export ADR Manager records to a Pro Tools session, do the following:

1. Highlight the records in the List window. They must all be from the same reel.

2. If you're exporting cues, scenes, or change events, make sure the reel has a guide track linked to it. In the case of takes, make sure each take has an
audio file attached.

3. Make sure Pro Tools is running, a session is open, and the Edit window is displayed. Make sure the session already contains the audio file(s) from the
step above. If you need to add audio files to the session, add them to the clip bin, save the session and reopen it before continuing. See the NOTE
below.

4. Select File > Export > Pro Tools session.... Clips are created in Pro Tools for each highlighted record. The clip's start and end times match the
record's start and end times. If a record has no end time, a 1 frame clip will be created. Wild records (e.g. cues with no start or end time) are ignored.

5. Review what will be exported under the Preview tab. Make sure you have enough blank tracks in Pro Tools to accommodate all exported clips. Adjust
settings under the Mappings, Options, and Text tabs, as described below.

6. Click OK. If this is the first time you have used ADR Manager to export to Pro Tools, you may get the following message:

“"ADR Manager” wants access to control
"Pro Tools". Allowing control will provide
&'_ access to documents and data in “Pro
*  Tools”, and to perform actions within that
app.

| Don‘tAllow | 0K

This message is from macOS Gatekeeper. Gatekeeper controls how applications communicate with one another, among other things. Once you click
OK, you can verify this setting in the macOS System Preferences > Security & Privacy > Privacy > Automation pane.

If you click on "Don't allow", ADR Manager will not export to Pro Tools, and will not give you an error message that it failed. Furthermore,
Gatekeeper disallows this specific functionality from then on, so if you try to export to Pro Tools again, Gatekeeper will not ask a second time. The
only way to override this functionality is to reset Gatekeeper using the Terminal.

7. Clips are created in the currently open Pro Tools session.

NOTE: If you find that the clip names in Pro Tools are not correct (i.e. they are simply the name of the audio file), save the Pro Tools
session with the audio file(s) in the clip bin and open it again. As of Pro Tools 2021, the audio file(s) must be in the clip bin BEFORE the
session is opened in order for the clip names to be correctly set by ADR Manager.

Preview tab

The Preview tab displays what information will exported, and to what tracks. This area is a good way to check if the fields, delimiters, and options are set up
the way you want them. This tab will update whenever you change something in the other tabs. Take note of how many tracks are needed to export all of the
clips, and make sure your Pro Tools session has enough blank tracks. Make sure the cursor is parked on the topmost blank track before exporting, unless
you designate the start track by number (choose Specific track for the Start track popup under the Options tab).



ON | Export options

Number of Pro Tools

tracks to export to Settings | Default

A
v

2

Cancel
Mappings Options  Text

Exporting 35 clips to|

W End Clip name Media file name
Audio 1 1015+02 1023+10/MSM1011_13 "Just ma...ext available attendant” |GT 01.0...24f.wav
Audio 1 1023+12 1025+10/LG1011_07 "(5-6 men and women)\rAlways" GT 01.0...24f.wav
Audio 1 1066+04 1076+01/LOK1011_01 "(Vocals a...ticket and holds it up)" |GT 01.0...24f.wav
Audio 1 1304+00 1309+08/MOB1011_01 "Go ahead...poral aura (and inhale)" |GT 01.0...24f.wav
Audio 1 1563+14 1570+05/LG1011_08 "(A couple...tries to use his powers)" |GT 01.0...24f.wav
Audio 1 1588+01 1592+07|RSL1011_01 "The court...tence you to be reset." |GT 01.0...24f.wav
Audio 1 1593+01 1594+07|RSL1011_02 "Next case please" GT 01.0...24f.wav
Audio 1 1657400 1657+01/MOB1011_02 "(Whisper...like it. It's appropriate.” |GT 01.0...24f.wav
Audio 2 480+08 518+05/LG1011_05 "(A male hu...such as_;)\rOk.\rGot it." |GT 01.0...24f.wav
Audio 2 518+15 520+12|/15B1011_03 "(Pulling L...p to his feet)\rCome on" |GT 01.0...24f.wav
Audio 2 921+00 928+07/MSM1011_01 "To this...veryone and everything." |GT 01.0...24f.wav
Audio 2 1024+10 1027+12|MSM1011_14 "For all time!" GT 01.0...24f.wav
Audio 2 1568+14 1572+14/15B1011_04 "(Chuckle...i tries to use his powers)" |GT 01.0...24f.wav
Audio 3 492+14 525+06/LG1011_06 "(Male Minu...as_;)\rUh huh. Let's go" |GT 01.0...24f.wav

Mappings tab

You can choose what

fields you want exported to the clip name under this tab.




® [ ] Export options

?
Settings | Default B _ -

Cancel

Preview RRgETllsH Options  Text

From Using delimiters  To

Name Clip name
Dialogue - Clip name

Fields are put in the clip name in the order they appear in this list. You can optionally put delimiters around each field, which can be helpful if you plan on
importing back into ADR Manager. Add fields by clicking on the + button and using the Edit Mapping window. Only fields that are checked will be exported.
See Exporting to ProTools scenarios for some suggestions about what fields and delimiters you should use for different situations.

Long clip text

Pro Tools clip names have a limit of about 250 characters. If a clip's text exceeds that length, ADR Manager will automatically split the clip into multiple clips
and distribute the text between them. The first clip's text will end without a delimiter. The second clip's text will begin with "{+}", which signifies concatenation,
followed by the rest of the text, and so on through successive clips until all of the text is exported. See Mergin jacent Pro Tools clips for more information.

Options tab

The Options tab lets you set up how the clips will be spread across Pro Tools tracks.



L) [ ] Export options

?
Settings = Default E ﬁ -

Cancel
Preview Mappings Text

Place first clip at its absolute time ﬁ Session start 0+0@
Place additional clips @ at their absolute time a

Start track cursor location (first selected track) E Cursor 0+0@
Track pattern Across the start track, then down if clips overlap

Split tracks by none a

Track types maono a

Media channels audition channel only a

e Place first clip - This setting determines where the earliest record is placed.

o At cursor - Places the first record at the current cursor position, ignoring its start time. Be sure to enter the current Pro Tools cursor time in the
Cursor time field.

o At its absolute time - Places the first record at its displayed start time, ignoring the cursor position. The start time must be after the Pro Tools
session start time. Confirm that the session start time is correct in the Session start time field. Also, make sure that the reel timelines for the
record match the Pro Tools session setup.

e Place additional clips - This setting determines where the rest of the records are placed.

o At cursor - Places each record at the current cursor position, ignoring its start time. Clips will be stacked vertically across tracks. Be sure to
enter the current Pro Tools cursor time in the Cursor time field.

o End to end - Places each record one after the other, ignoring their start time, starting with the first clip. Clips will be placed horizontally across
a single track. This option is useful, for example, to quickly audition or view all records in a row.

o At their absolute time - Places each record at its displayed start time, ignoring the cursor position. Clips are spread horizontally across tracks
unless they overlap, in which case they are put on lower tracks. The total number of tracks needed to prevent overlaps is shown under the
Mappings tab.

e Start track - This setting designates what track to start exporting to.

o Cursor location (first selected track) - Clips are placed beginning with the track containing the current cursor. If the cursor selection spans
multiple tracks, the topmost track is used.

o Specific track number: - Enter the absolute track number. Pro Tools track numbers can be displayed by choosing View > Track number in
Pro Tools. Note that clips are spotted to tracks, regardless of whether or not they are hidden.

e Track pattern - Describes how clips will be spread across tracks.

e Split tracks by - This setting lets you place records on a different set of tracks based on certain criteria. The criteria differs based on that records you
are exporting. For example, you can separate cues by character name, priority, or status.

e Track types - Use this setting to specify what types of tracks you have created in Pro Tools.
o Mono - All tracks are mono. Multichannel sound files will be spread across multiple mono tracks.

o Mono and multichannel - Sound files will be separated based on the number of channels they contain, then placed on tracks with matching



channel numbers. For instance, mono sound files will be spotted to mono tracks, and stereo files will be spotted to stereo tracks.
e Media channels - Use this setting to specify which channels you want to spot, if a sound file has more than one channel.

o All - Spot all channels of a multichannel sound file. You should choose mono and multichannel track types if any sound files have more than
one channel.

o Audition channel only - Only a single mono channel will be spotted. Audition channels can be chosen in the Modify Take window.

Text tab

You can set up options to control how text is converted when exporting. See Common Import and Export settings for more information.

Troubleshooting

If you find that clips are not landing in the correct place after exporting, check the following:

e Double check the settings under the Options tab in the Export Options dialog. In particular, make sure the Pro Tools cursor is parked at the position
entered in the "Cursor position" field.

e Make sure the time settings for your project match Pro Tools. In particular, the timecode, feet and frames, and sample rate formats must match the
Pro Tools session setup window.

e For records exported from reels (i.e. cues and scenes), make sure the reel's timelines match the session's timelines. Specifically, the reel start time
must match the session start time, in both timecode and feet and frames.
There is a bug in Pro Tools 12 that will put the audio filename in the clip name, instead of the fields you designated under the Mappings tab. As a

workaround, import the guide tracks into the Pro Tools session first. Close and reopen the session, then export from ADR Manager again.

If you get an error message in Pro Tools complaining about duplicate audio file IDs, you may need to create a fresh session and export to new, blank tracks.
Then import those tracks into your desired session.



Exporting reports

You can export a report in order to use it again in a different database. Note this is not the same as printing a report. Printing a
report generates PDF files with content from currently displayed or highlights records; exporting a report saves the settings of the
report to disk.

When you export a report, ADR Manager automatically names the file with the report name. Therefore, when you export a report, a
"Select folder" dialog will appear, letting you choose a folder but not letting you type in a filename.

Since the report name is used as the filename, you must not use characters in the report name that would make it an invalid
filename for your operating system. In particular, on the Macintosh you cannot use a colon () or forward slash (/). On Windows, you
cannot use a forward slash (/), a backward slash (\), a colon (:), an asterisk (*), a question mark (?), a double quote ("), a greater-
than sign (>), a less-than sign (<), or a vertical bar (|).

You can export more than one report at a time. Shift-click or command-click on the reports you wish to export, then choose Export.
A "Select folder" dialog will appear, as described above. Each report will be saved as a separate file in the folder, with each filename

matching the report name.



Copying record data to the clipboard

Another way to move data out of ADR Manager and into another program is to copy selected records from any window to the
clipboard using Copy under the Edit menu. The data will be stored as text. For each row in the window, the field value in each
column will be put on the clipboard, separated by a tab. A carriage return will be added after each row. You can paste the text from
the clipboard into a word processor or spreadsheet application by using Paste under the Edit menu in that application.

However, there are limitations to what data is copied to the clipboard:

e No style tags are copied

e No text substitutions are carried out (i.e. carriage returns are not replaced with a special character). This may make the text
look wrong when copied into a word processor.

e No column headers are embedded in the clipboard text

You cannot paste record data from the clipboard into an ADR Manager window.



I0 scenarios

This section provides some tips on how to use the export to Pro Tools feature. In each scenario, suggested settings for the import
options and export options dialogs are given. You can save these settings and recall them later using the Settings popup.

Using Pro Tools to conform ADR Manager cues

There are several reasons why you might want to conform ADR Manager cues in Pro Tools. The graphical interface, the ability to
hear other tracks, and the availability of third party conforming tools might lead you to decide to use Pro Tools instead of ADR
Manager's built-in conforming features. Here are the steps you need to take to perform round tripping and make sure you don't lose
or corrupt any information in the process:

1.

Create a new reel dupe — Make a new dupe of the reel you want to conform. This will make copies of all the cues in the
reel, and make them descendants of the cues in the old dupe.

. Assign the old dialogue guide track to the new dupe — Add the old dialogue guide track to the new dupe under the

Media tab of the Modify Reel Dupe window. This is a temporary step to ensure that when you spot cues into Pro Tools, the
clips will play audio from the old guide track. Later, after we bring the conformed cues back in to the database, we will swap
out the old guide track for the new one in the Modify Reel Dupe window.

. Highlight all cues in the new dupe — It's important when you want to display all the cues for a reel dupe that you clear all

search criteria, such as whether or not a cue is omitted or contains a keyword, to ensure that all cues are displayed. Then
choose Edit > Select all to highlight all of the displayed cues.

. Export to Pro Tools — Choose which fields to export carefully. You want to make sure to export the minimum number of

fields so that you don't lose information. There are other fields you may not want to export because they will get new values
when you import back in. Here's a list of fields to export:

o Name

o Character abbreviation or Character name

o Dialogue

o Priority - You do not need to export this field if all cues have the default "medium" priority

o Status - You do not need to export this field if all cues have the default "spotted" status

o Public notes

o Private notes

o Is omitted - You do not need to export this field if no cues are omitted

o Ancestor cue ID
You can choose to leave out the Priority, Status, and Is omitted fields if you know all the cues have default values for those
fields. Leaving certain fields out of the export keeps clip names short. However, if you're not sure, export them just to be safe.
Export the Ancestor cue ID field to maintain cue lineages when importing back in.

If you applied any font styles (bold, italic, color, etc) to the dialogue or notes, check the "Export style tags in text" option under
the Options tab to preserve those styles. However, be aware that this will add more characters to the clip name, and Pro
Tools imposes a limit of 255 characters total.

. Conform the clips in Pro Tools — Conform the clips in Pro Tools, using whatever method you prefer. Delete clips if they

have been conformed out. For remaining clips, make sure to heal any cuts made within clips so as to not create multiple cues
out of a single cue.

. Export the Pro Tools session to a text file — Export the conformed tracks to a text file. Be sure to use the proper settings,

as explained in Saving a Pro Tools session to text.

. Delete the cues in the new dupe — In ADR Manager delete all cues in the new dupe. This ensures that cues that were

deleted during the conform do not persist in the new dupe.

. Modify the new dupe — Manually set the new dupe's LFOA to be the correct value, in case the reel has grown and the


file:///Users/Steve/SlaneconDigital/Dev/ADRManager/_Latest/ADR-Manager/User_manual/HTML/topics/15_Conforming
file:///Users/Steve/SlaneconDigital/Dev/ADRManager/_Latest/ADR-Manager/User_manual/HTML/topics/15_Conforming

9.

conformed cues are now landing after the old LFOA. Also, replace the old guide track you added in step 2 with the new
dupe's correct guide track.

Import the Pro Tools session text file — In the Import Options window, make sure the fields and field delimiters match
what you chose in step 4. Check the "Import style tags in text" option if you chose to include font styles during export.

Exporting to Pro Tools for use on an ADR stage

When preparing a Pro Tools session to be used by a mixer or recordist on an ADR stage, you can leave out information that is not
necessary for the mixer. In some cases, all you need to export is the cue name. This makes it easy for the mixer to copy the clip
name and use it to name the recorded audio file.

Sharing read-only tracks with others

When preparing a Pro Tools session to be used as reference by other people such as the production sound editor or dialogue re-
recording mixer, you can leave out information that is unnecessary. Here's a typical list of fields to export:

Name
Dialogue
Public notes
Private notes

Is omitted

Also, uncheck the "Export style tags in text" option under the Options tab to declutter the clip name.



ADR Cues

This section describes the details of importing and exporting cues. For an explanation of how records are imported in general, see
The import process.

See the list of fields that you can import and export for ADR cues.
Imported cues will not have lineage ties to other cues unless you export and re-import the "Ancestor cue ID" field with
the data. You should include this field if you are importing back into the same database from which you exported.

When importing cues, make sure the cue names you are importing adhere to the cue naming convention you have setup for this
database.



Importing cues from a Pro Tools session text file

You can create clips in a Pro Tools session, then import into ADR Manager to create cues. Do this by creating a clip for each cue, entering cue information into the clip
name, then exporting the session as a text file. ADR Manager will create a cue for each imported clip, parsing the track names and clip names to fill the fields of cue
records.

To import a Pro Tools session text file, follow these steps:

1.
2.

6.

Create a session.

Create "spotting" tracks. You may want to create one track for each character. Or you may want to create several tracks for a particular character, one for lines
that are "To Be Written", one for high priority lines, etc. You don't have to worry about creating too many tracks because you can choose which tracks to import
later.

. Put common information into the track name, such as the character abbreviation. Information in the track name is applied to all clips on that track, as long as the

mappings are setup properly. The information must be within delimiters (see step 8 below).

. On the spotting tracks, create clips or clip regions. Clips can contain online or offline media.

. Enter cue information into each clip name, such as dialogue, priority, or notes. Cue information in the clip name overrides information in the track name. All cue

information must be within delimiters, which you can define during import (see step 8 below).

Here is a sample Pro Tools "spotting"” session. In this example, we have spotted 2 clips for the character Jack (abbreviation JK) and 1 clip for the character Bob
(abbreviation BB). Character abbreviations are delimited by curly braces and the identifier "A". Since the character abbreviation is in the track name, it applies to
all clips on the track and there is no need to enter {A JK} for each clip on the track. Clip names contain other information, namely cue dialog (delimited by {D }),
priority (delimited by {P }), and private notes (delimited by {V }). Note you can have any punctuation within the curly braces except curly braces themselves.

Feet+Frames

As of Pro Tools 12, clip names have a maximum of 255 characters. If you want to enter more dialogue or other info, split the clip into two, and continue the
dialogue in the second clip using the special continuation character. See Merging adjacent Pro Tools clips for more information.

Export the session to a text file. Check Include Track EDLs. You can leave Include File List and Include Clip List unchecked. See Saving a Pro Tools session
as text for more information.



Export Session Text
|

|| Include File List
|| Include Clip List
|| Include Markers
["] Include Plug-In List
Include Track EDL's
() All Tracks
© Sselacted Tracks Only

C] Show Subframes
|| Include User Timestamps
Fade Handling
© Show Crossfades
() Don't Show Crossfades
() Combine Crossfaded Clips

Time Format:

Flle Format:

7. In ADR Manager, make the ADR Cue List window active. Choose File > Import > Pro Tools session to select the file, or drag the text file into the List window.

8. A dialog will appear letting you select the reel you will be importing into, the tracks you want to import, and a list of fields to scan.



See Importing a Pro Tools session text file for information on how to use this dialog.

9. The clips are imported and converted into cues.

t3

. Scene Cue name Start/End  Character

3 of 4 ADR cues selected (3 cues in 'Latest reel dupes' reel set)




Exporting cues to a Pro Tools session

You can export cues to a currently open Pro Tools session. This will create a clip for each cue. See Exporting to an open Pro Tools
session for more information.



ADR Cue fields

The following table shows the default ADR Cue fields that can be imported and exported.

Column name Format Notes

ID Number The cue's record ID. A good use of this
field is when you export cues in order to
process one or more fields, then merge the
changed fields back into the database.

Name Unlimited number of characters Importing: If not blank, should adhere to

database cue naming convention.

Character ID

Number

The cue's character ID.

Character abbreviation

Text

The cue's character abbreviation, as
stored in the cue name.

Character name

Up to 64 characters

Importing: If blank, the cue name is parsed
to see if a character abbreviation is
embedded. If one is not found that
matches a character record, user may
create new character record.

Segment type

Must be set to:
o reel

Segment name

Reel number (use 00 for the WILD reel)

Importing: If blank, the cue name is parsed
to see if a reel number is contained in the
name. If one is not found that matches a
reel record, an error occurs.

Segment dupe date

Date in the format MM/DD/YY

Importing: If not present, uses reel with
matching number in current reel set. If
current set is "All reel dupes"”, an arbitrary
dupe with matching number is chosen.

e spotted

e printed

e recorded

e transferred

e loaded

e cut

e premixed

e final mixed

e printmastered
e QCed

FFOA Time value in the currently displayed Importing: If this field is blank, then LFOA

database time format. must also be blank and segment name
must be 00 (the cue is WILD)

LFOA Time value in the currently displayed Can be blank, which means the cue is
database time format. open-ended.

Dialogue Unlimited number of characters

Public Notes Unlimited number of characters

Private notes Unlimited number of characters

Status Must be one of the following strings: Importing: If blank or invalid, field is set to

"spotted".




e shipped

Is omitted Must be one of the following strings: Importing: If blank or invalid, field is set to
e true "false".
o false
Is locked Must be one of the following strings: Importing: If blank or invalid, field is set to
e true "false".
o false
Is wild Must be one of the following strings: Importing: Currently ignored
e true
o false
Priority Must be one of the following strings: Importing: If blank or invalid, field is set to
e highest "medium".
e high
e medium
e low
e lowest
Segment ID Number The cue's reel ID.
Segment dupe order Number Importing: Currently ignored
Segment continuity index Number Importing: Currently ignored
Ancestor cue ID Number The cue's ancestor cue ID.

Take IDs A list of take IDs, separated by delimiter
Take names A list of take names, separated by
delimiter
Scene ID Number Importing: Ignored. The cue's scene is
determined by the cue's start time and
reel.
Scene name Up to 10 characters Importing: Ignored. The cue's scene is

determined by the cue's start time and
reel.

Scene continuity index

Number

Importing: Currently ignored




Change events

For an explanation of how records are imported in general, see The import process.

For a list of change event fields that you can import, see Change event fields.



Exporting change events as an Avid columnar change list

You can export change events to an Avid columnar-style change list for use in other conforming applications.

When exporting selected change events in this format, be aware that "Replace shot" events are not recognized by Avid and other
manufacturers. To avoid exporting "Replace shot" events, hide them in the Change List window before selecting the events to

export. See Displaying change events for more info.

For more information about the Avid columnar-style change list format, visit www.avid.com.


https://avid.secure.force.com/pkb/articles/User_Guide/Media-Composer-Documentation

Change event fields

The following table shows the default change event fields that are imported.

e insert

e lengthen
e delete
e trim

e shorten
e move

e replace

e no change

Column name Format Notes

Number An integer Order in the list

Start time Time value in the currently displayed Start time of the change event
database time format.

Duration Time value in the currently displayed Duration of the change event
database time format

End time Time value in the currently displayed End time the change event (inclusive)
database time format

Description Any text up to 2 billion characters

Type Must be one of the following strings:

Affected area

Must be one of the following strings:
e leader

e shot
e shots
e head
e middle

o tail

Number of shots affected

An integer

Related change event number

An integer

Trim bin name

A string

Status

Must be one of the following strings:
e not done

e done

e skipped




Characters

For an explanation of how records are imported in general, see The import process.

For a list of character fields that you can import and export, see Character fields.



Character fields

The following table shows the default Character fields that are imported and exported.

Column name Format Notes
ID Number The character's record ID. A good use of
this field is when you export characters in
order to process one or more fields, then
merge the changed fields back into the
database.
Name Up to 64 characters
Abbreviation Up to 12 characters
Actor Up to 64 characters
Description Up to 80 characters
Recording notes Up to 80 characters
Lines per hour Number Set to 10 if not specified during import and
creating a new record
Character type Must be one of the following strings: Set to "Principal” if not specified during
e Principal import and creating a new record
e Minor
e Loop Group




Reels

For an explanation of how records are imported in general, see The import process. For a list of reel fields that you can import and
export, see Reel fields.



Reel fields

The following table shows the default Reel fields that are imported and exported.

Column name Format Notes

ID Number The reel's record ID. A good use of this
field is when you export reels in order to
process one or more fields, then merge the
changed fields back into the database.

Number Number between 0 and 9999

Dupe date Date in the format MM/DD/YY

Version Up to 8 characters

Timecode FFOS

Time value in the database timecode
format.

Reel start time, in timecode

Timecode FFOA

Time value in the database timecode
format.

Reel FFOA, in timecode

Timecode LFOA

Time value in the database timecode
format.

Reel LFOA, in timecode

Timecode LFOS

Time value in the database timecode
format.

Reel end time, in timecode

Feet frames FFOS

Time value in the database feet frames

format.

Reel start time, in feet and frames

Feet frames FFOA

Time value in the database feet frames

format.

Reel FFOA, in feet and frames

Feet frames LFOA

Time value in the database feet frames

format.

Reel LFOA, in feet and frames

Feet frames LFOS

Time value in the database feet frames

format.

Reel end time, in feet and frames

Segment FFOA offset

Time value in seconds (i.e. 8.008)

Actual time between reel start time and
FFOA

Segment duration

Time value in seconds

Actual time between reel start time and
reel end time

Action duration

Time value in seconds

Actual time between FFOA and LFOA

Ancestor segment ID

Number

The ID of the previous reel (direct
ancestor) of this reel

Brief description

Up to 80 characters Ignored.

This field is reserved for future use.

Full description

Up to 2 billion characters Ignored.

This field is reserved for future use.

Parent segment type String Must be "root". This field is reserved for
future use.

Parent segment ID Number Must be "0". This field is reserved for
future use.

Parent segment name String Must be ".This field is reserved for future

use.

Parent segment dupe date

Date in the format MM/DD/YY

Must be "00/00/00". This field is reserved
for future use.




Reports

This section describes the details of importing and exporting reports.



Importing a report from a record file

You can import reports that have been exported from ADR Manager. The reports are stored in a special format that can only be
imported and exported by ADR Manager. There is one report to a record file.

Follow the steps described in Preparing to import. If the import file was created using a different version of ADR Manager than the
one you are using, an alert will tell you if you can open this file, and whether you should re-export the report to save it in the new
format. If that is the case, then re-export the report after you are finished importing it.

If you can import this file, a progress window will appear showing how far along the import is. If the import is a success, the new
report will be given the same name as the filename from which it was imported.



Exporting a report to a record file

To export a report, make sure the Report List Window is active. Click on the report you want to export. You can only export one
report at a time. Then select Export... under the File menu.

Reports stored as record files can be imported into other ADR Manager databases.



Scenes

This section describes the details of importing and exporting scenes. For an explanation of how records are imported in general, see
The import process. For a list of scene fields that you can import and export, see Scene fields.



Importing scenes from a Pro Tools session

You can spot clips in a Pro Tools session, then bring them into ADR Manager to create scenes. You do this by creating a clip for each scene, entering
scene information into the clip name, then exporting the session as a text file. ADR Manager will create a scene for each imported clip, parsing the track
names and clip names to fill the fields of scene records.

To import a Pro Tools session to create scenes in ADR Manager, follow these steps:

1.

6.
7.

Create a session.

. Create a "spotting" track.

2
3.
4

On the spotting track, create clips. Clips can contain online or offline media.

. Enter scene information into each clip name, such as name and brief description. All scene information must be within delimiters (see step 7

below).

Here is a sample Pro Tools "spotting" track. In this example, the clips contain scene names delimited {N }, brief descriptions delimited by {B }, and
full descriptions delimited by {F }:

| Scenes [N {N 20} (B INT. Jack's apt} {F Jack cooks dinner} | {N 22A} {B EXT. Main Streef} {F Jack walks outside}
L 1 5 M

waveform

NOTE: As of Pro Tools 12, clip names have a maximum of 255 characters. If you want to enter more characters for a single scene, enter the
text in contiguous clips and merge the clips together during import.

. Export the session to a text file. To create scenes from clips, check Include Track EDLs, or to create scenes from markers, check Include

Markers. You can leave Include File List and Include Clip List unchecked. See Savin Pro Tool ion as text for more information.
In ADR Manager, select File > Import > Pro Tools session text file, or drag the text file into the Scene List window.

A dialog will appear letting you select the reel you will be importing into, the track you want to import, and a list of fields to scan.



o0 ® Import options for "Spotting session v7 delims. txt"

a
Settings Default _

Cancel
Preview Mappings Defaults Options Text
Session start @+0a
Import into reel | 07 B dupe 1/27/21
Tracks to import Fields to import, from top to bottom =
Tracks From Using delimiters To
LA K Clip name {N3} MName
| {A BB} Clip name {B} Brief description
Scenes Clip name {F} Full description

See Importing a Pro Tools session for information on how to use this dialog.

The clips or markers are imported and converted into scenes.

| NON | Scene List

+).7|[x < [ 2
Reel Name Start  Brief description Full description
o7 20 301+82 INT. Jack's apt. Jack cooks dinner
o7 228 384+@5 EXT. Main Street Jack walks outside

0 of 4 scenes selected

All imported scene fields are optional. Optional fields will be filled with default values (i.e. empty strings) if they are not imported.



Scene fields

The following table shows the default scene fields that are imported and exported.

Column name Format Notes

ID Number The scene's record ID. A good use of this
field is when you export scenes in order to
process one or more fields, then merge the
changed fields back into the database.

Name Up to 10 characters

Parent segment type

Must be the following string:
e reel

Parent segment name

Number between 0 and 9999

Importing: Must be the name of a reel in
the current reel set

Parent segment ID

Number

Record ID of the scene's reel

Parent segment dupe date

Date in the form MM/DD/YY

Dupe date of the scene's reel

Dupe date Date in the format MM/DD/YY Importing: ignored
Version Importing: ignored
Brief description Up to 80 characters

Full description

Up to 2 billion characters

Timecode FFOA

Time value in the database timecode
format

Scene start time, in timecode

Feet frames FFOA

Time value in the database timecode
format

Scene start time, in feet and frames

Timecode FFOS

Time value in the database timecode
format

Reel start time, in timecode

Timecode LFOA

Time value in the database timecode
format

Scene end time, in timecode

Timecode LFOS

Time value in the database timecode
format

Reel end time, in timecode

Feet frames FFOS

Time value in the database feet frames
format

Reel start time, in feet and frames

Feet frames LFOA

Time value in the database feet frames
format

Scene end time, in feet and frames

Feet frames LFOS

Time value in the database feet frames
format

Reel end time, in feet and frames

Segment FFOA offset

Time value in seconds (i.e. 8.0)

Actual time between reel start time and
scene start time

Segment duration

Time value in seconds

Actual time between reel start time and
reel end time

Action duration

Time value in seconds

Actual time between scene start time and
scene end time

Ancestor segment ID

Number

The ID of the previous version (direct
ancestor) of this scene




Takes

This section describes the details of importing and exporting takes. For an explanation of how records are imported in general, see
The import process. For a list of take fields that you can import and export, see Take fields.

Note that if you import takes from a tab separated text file and a take is imported that has no reel information, the take will be put in
the WILD reel automatically.



Importing takes from the Finder

You can import audio files from the macOS Finder into ADR Manager. The audio files are grouped together to make audio streams,
then a take is created for each audio stream. If the audio files follow your take naming convention, the filenames are parsed and
automatically linked to the proper cues. Each cue is marked as recorded, and ADR Manager remembers that each take was
recorded to this particular version of each cue, in case the cues get conformed later. This is helpful if you want to place takes in a
Pro Tools session at the conformed times rather than the original recorded times.

It is important to import takes with the proper reel dupes active, so that ADR Manager knows what version the take was
recorded to.

You can import audio files in several ways:
1. Drag and drop the audio files from a Finder window into the Take List window.

2. Choose File > Import > Audio file... from the Take List window, and select one or more audio files

You can save the import settings using the Settings popup in the Import Options dialog.



Importing takes from a Pro Tools session text file

UNDER CONSTRUCTION

You can create clips in a Pro Tools session, then bring them into ADR Manager to create takes. You do this by entering take
information into the clip name, then exporting the session as a text file. ADR Manager will create a take for each clip, parsing
information to fill the fields of the take records.

Typically you import takes from a Pro Tools session that contains recorded cues.
1. Open the session in Pro Tools.
TIP: As of Pro Tools 12, clip names have a maximum of 255 characters. If you want to enter more dialogue than will fit,

enter the text in contiguous clips and merge the clips together during import.

2. Export the session to a text file. To create takes from clips, check Include File List, Include Clip List, and Include Track
EDLs. To create subtakes from markers, also check Include Markers. See Saving a Pro Tools session as text for more
information.

3. In ADR Manager, make the Take List window active. Choose File > Import > Pro Tools session to select the session text
file, or drag the file into the List window.

4. A dialog will appear letting you select the tracks you want to import, and a list of fields to scan. See Importing a Pro Tools
session text file for information.

5. The clips are imported and converted into takes.

You can save the import settings using the Settings popup in the Import Options dialog.

Importing subtakes from markers

UNDER CONSTRUCTION

You can create subtakes from markers by selecting the "Markers" track and a disk track under the Mappings tab. A subtake will be
created for each marker that intersects a clip on the disk track. For example:



NEFS08B_05

Comments

{D Wanna see somathing totally coal #}
{D Wanna see somathing way cool?}
{D Wanna see somathing way cool?}
{D Wanna see somathing cool ¥}

{D Wanna see somathing cool ¥}

{D Wanna see somathing cool ¥}

{D Wanna see somathing cool?}




Exporting takes to a Pro Tools session

You can export takes to a currently open Pro Tools session. This will create a clip for each take. See Exporting to an open Pro Tools
session for more information.

Takes placed at conformed cue times

When you export takes, they are placed relative to the current cue's time, which may be different than the take's recorded time. This
is because ADR Manager remembers which version of the cue you linked and adjusts accordingly.

For example, let's say you've spotted cue LG101 in reel 1 v6. You go to the ADR stage and record 3 takes of the cue: LG101_01,
LG101_02, and LG101_03. When you return, you want to bring the audio files into ADR Manager to create your take library. You
make sure the current reel set includes reel 1 v6 (i.e. not v5 or v4), then drag the audio files from the Finder into the Take List
window. As the audio files are imported and takes are created, ADR Manager remembers that these takes were recorded to LG101
at v6. Then you conform reel 1 to v7, which winds up moving LG101 to a new time.

Now, to export the take to Pro Tools at the new v7 time:

1. Make sure the current reel set includes the desired reel dupe.

2. Select the takes in the Take List window and export.

The takes are placed in Pro Tools at the new v7 time. Internally, ADR Manager calculates the offset between the cue in v6 and the
cue in v7 and applies that offset to the take's start time.



Creating a library from Avid media

You can create a library within ADR Manager of all the audio files digitized on an Avid Media Composer™ or Film Composer™. You
can then search, audition, and spot the media into Pro Tools. This is particularly useful because audio files on an Avid workstation
usually have non-sensical names when viewed in the Finder, such as "n17a_8.RENA01.B99A13D74C99D.aif".

To create a library of AAF media in ADR Manager, you must dump the information stored in Avid bins to AAF compositions, convert
the AAF compositions to Pro Tools session(s) and then import the Pro Tools sessions into ADR Manager. Follow these steps:

1. Copy the audio files from the Avid drives to your Pro Tools drives using the Finder. Do not copy or "consolidate" the media
using the Avid application; otherwise, the AAF compositions created in step 4 will not link up to the media on your Pro Tools
drives. You can "copy and link" (see Avid documentation), but be sure the filenames and file IDs do not get changed in the
process.

2. On the Avid workstation, select all of the audio files in a bin and drag them into an empty sequence. The Avid will place the
files end-to-end on the track.

3. Export the sequence to an AAF file, composition only.

4. Import the AAF composition file into Pro Tools, linking the media references to the copied media on your Pro Tools
workstation.

5. Export the Pro Tools session as a text file.
6. Import the text file into the Take List window.

When you are done, you will have created a library of all the media on the Avid. The take names in ADR Manager will be the clip
names on the Avid workstation, and each take will point to the appropriate audio file on your Pro Tools workstation.

Tip: This option is better than importing takes via a folder scan because clip names rather than audio filenames are used to
name the new takes.

Note: ADR Manager does not currently support audio files with different sample rates. All sample rates must match the
project sample rate .



Take fields

The following table shows the default Take fields that are imported and exported.

e True

e False

Column name Format Notes

ID Number The take's record ID. A good use of this
field is when you export cues in order to
process one or more fields, then merge the
changed fields back into the database.

Name Up to 80 characters

Number Number between 1 and 50

Dialogue Up to 2 billion characters

Notes Up to 80 characters

Rating Must be one of the following strings:

e A
e B
e C
e D
o F
e NG

Rating index Number between 1 and 6 Corresponds to rating (i.e. 1 ="A", 6 =
IING")

Cue names A list of cue names. Exporting: A delimiter character (specified
in the Export Options dialog) is inserted
between each cue name.

Importing: A delimiter character (specified
in the Import Options dialog) is expected
between each cue name.

Is circled Must be one of the following strings: Importing: If blank or invalid, field is set to

"false".

Audio stream name

Common filename, including the extension
(which may be hidden in the Finder)

Audio stream pathname

Full pathname, including the common
filename and extension (which may be
hidden in the Finder)

Import Text file options. Can be blank.

Is wild Must be one of the following strings: Importing: Ignored
e True
e False
FFOA Time value in the format specified in the Importing: If this field is blank, then LFOA
Import Text file options. Can be blank. must also be blank and segment name
must be 00 (the take is WILD)
LFOA Time value in the format specified in the

Audition channel

Must be one of the following strings:
e MoNo




L
e C
e R
e LC
e .Rc
e s
e Cs
e Rs
o .Lfe

Cue IDs

A list of cue IDs.

Exporting: A delimiter character (specified
in the Export Options dialog) is inserted
between each cue ID.

Importing: A delimiter character (specified
in the Import Options dialog) is expected
between each cue ID.




Transport Control

The Transport Control window lets you interact with Pro Tools via MIDI. You can locate, play, and stop Pro Tools, as well as grab
times, convert them into the proper time format, and insert them into cues and scenes.

You can also grab time values from Pro Tools using macros. See using macros for more information.

You must make sure ADR Manager and Pro Tools are setup to communicate with one another to enable the features in the
Transport Control window.

Even though this manual describes working with Pro Tools, any application that supports MIDI and MIDI timecode will work as
well.

To open the Transport Control window, select Windows > Transport Control or type command-1. The Transport Control window
opens:

Transport buttons Current time Settings
o Transport Control \

&2
Ir*-:clrring MID
Incoming reel - Reel 07 —
« . ’ » Incoming MIDI TC: @7:@1:17:11

Loaded: ADR cue LG5703 Locate in ;| Reel 07 d... a
o Play from 128+83 Pre roll
Play to 131+@3 Post roll
Cue up area

ADR Manager understands where Pro Tools' current time position is by listening to MIDI timecode. However, if you are spotting in
feet and frames, the timecode can only be converted correctly if ADR Manager knows the timecode's context. Context is defined by
the reels in the current reel set. If your preferred time format is feet and frames, a reel's FFOS (First Frame of Segment) timecode
must be subtracted out of the incoming timecode before it can be converted to the correct footage. For this reason, it is important
that you set the FFOS field for each reel correctly (see Creating reels).

The Transport Control window displays the following:

e The current time of the Pro Tools "playhead", in the preferred ADR Manager time format. This time is available to paste into
various time fields.

e The MIDI Enable button turns MIDI communication with ADR Manager on and off. The MIDI Settings button lets you define
how ADR Manager communicates via MIDI.

e ADR Manager will attempt to determine the context by looking at the incoming timecode. If each reel in the current reel set
has a unique start timecode, then the proper reel number can be determined. The reel number field in the New Cue and New
Scene windows will be filled with this number when you grab a start time (see Grabbing start and end times). If the incoming
MIDI timecode is not within range of any reel in the current reel set, Incoming reel will be blank.

e Incoming MIDI TC (timecode) shows what timecode ADR Manager is currently receiving. It is displayed for reference.



e Transport buttons are used to control the motion of the Pro Tools session. They are: fast rewind, stop, play, and fast
forward.

e If you click on a record in a List window and you've enabled the window's Lock to Transport button, the record is loaded into
the Cue Up Area. The start time will be stuffed into the Play from time field and the end time will be stuffed in the Play to
field. You can cue up cues, scenes, reels, and change events in this way.

e You can manually enter a locate time by selecting a reel in the Locate in popup and entering a time in the Play from field.
e The Locate button and Play from time field locates Pro Tools to the specified time.

e The Play to field, if enabled, will tell Pro Tools to stop playing once the designated time is reached.

e The Pre roll time, if enabled, will be subtracted from the Play from time when locating.

e The Post roll time, if enabled, will be added to the Play to time when determining where to stop playing.

Note that several functions in the Transport Control window can be accessed using keyboard shortcuts. See Creating shortcuts for
more information.



Setting up MIDI

There are several ways ADR Manager can communicate with external applications such as Pro Tools. You can use an automation
utility to grab the start and end times of a selected clip, or you can use MIDI.

This section describes how to use MIDI, or more specifically, MIDI Timecode (MTC) and MIDI Machine Control (MMC). MIDI
Timecode gives ADR Manager the ability to read the current time in Pro Tools and MIDI Machine Control lets you control Pro Tools
by sending play, stop, locate, and other commands from ADR Manager.

To enable this functionality, you will have to check the settings in three places:
e macOS

e ADR Manager
e Pro Tools

The following sections describe how to setup MIDI communication for ADR Manager v7 and Pro Tools v12 running on macOS
10.13.

Even though this manual describes working with Pro Tools, any application that supports MIDI Machine Control and MIDI
Timecode will work.



Enabling MIDI in macOS

MacOS has a built-in feature that allows programs to talk to one another using MIDI, but you have to specifically enable this feature
using a utility that ships with the operating system.

1. Open the Audio MIDI Setup utility. The utility can be found in the /Application/Utilities folder.

Audio MIDI Setup utility in MacOS

2. Make sure the MIDI Studio window is showing by selecting Window > Show MIDI Studio. Double-click on IAC Driver (Inter
Application Communication Driver) and turn it online by checking the Device is online box. Make sure at least one port is
defined (the default is "IAC Bus 1"), then click Apply.

) IAC Driver Properties

Device Name: |AC Driver

Manufacturer:
4]
\ Model:
Device is online
| _Ports |

You can set up the MIDI device's port structure here. First, set the number of ports on
the device. Then indicate the number of MIDI in and out connectors for each port.

Ports Connectors for:
IAC Bus 1
MIDI In: 1 z
MIDI Out: 1 G
4= (|= Add and Remove Ports
? Revert QLIS

3. Quit and relaunch ADR Manager so it recognizes the new MIDI port.

4. Set up ADR Manager and Pro Tools to talk to one another.



Setting up MIDI communication with Pro Tools

To set up MIDI communication between ADR Manager v7 and Pro Tools v12, follow these steps.
1. Enable MIDI inter-application communication using the Audio MIDI Setup utility (see Enabling MIDI in macQOS).
2. If you changed anything in the Audio MIDI Setup utility, quit and relaunch ADR Manager, then open the Transport Control window by choosing Windows >
Transport Control. Click on the gear icon to open the MIDI Settings dialog.

@O Transport Control

20,
48+12 Q&
Reel 04 Auto-select

« ] ' » Incoming MIDI TC:  @4:0@:24:17

a Play from 149483 | | Pre roll
B Play to

3. Select the port you defined in the Audio MIDI Setup utility ("IAC Driver, IAC Bus 1") in the Receive and Send popups. Set the Receive Device ID to 1. Set the
Send Device ID to 2.

@ ) MIDI Settings

Open Audio MIDI Setup oK  cancel ?

Receive MIDI Timecode (MTC) and

MIDI Machine Control (MMC) from: IAC Driver IAC Bus 1
Device ID: 11 |

Send MIDI Machine Control (MMC) to: IAC Driver JAC Bus 1
Device ID: 2
Latency: 0.6 seconds

4. In Pro Tools, open the Setup > Peripherals window and select the Synchronization tab. Set the MTC Reader Port and Generator Port to the ones you specified

in the previous step ("IAC Driver, IAC Bus 1").

Peripherals

MTC Reader Port: [IAC Driver, IACBus 1 T
MTC Generator Port: [IAC Driver, IAC Bus 1 7




5. Still in the Pro Tools Peripherals window, select the Machine Control tab.

o Check Enable under the heading MIDI Machine Control (Master), and choose the port you defined in the Audio MIDI Setup Utility ("IAC Driver, IAC Bus
1"). This tells Pro Tools to send location information to ADR Manager. Enter 1 for the ID. This number must match the Receive Device ID in step 3.

o Check Enable under the heading MIDI Machine Control Remote (Slave). This tells Pro Tools to receive location information from ADR Manager. Enter 2
for the ID. This number must match the Send Device ID in step 3.

Peripherals

Machine Control

Close the Peripherals window.

MIDI Machine Control {(Master)

Enable |IAC Driver, iACBus1 7 0 ) Precol:

LI frames

MIDI Machine Control Remote (Slave)

Enable

o [

6. In Pro Tools, open the Setup > Preferences window and select the Synchronization tab. Check Machine Chases Memory Location if you want to send
messages when you locate using a memory location. Check Machine Follows Edit Insertion/Scrub to send current location messages to ADR Manager when

you move the cursor by clicking or scrubbing.

Pro Tools | Ultimate Preferences

|| Ignere Track Arming
|| Set Serve Lock Bit at Play

e e

Machine Chases Memory Location
Machine Fallows Edit Insertion/Serub

Synchronization

|| Machine Cues Intelligently
|| Stap at Shuttle Speed Zero
[:] Non-Linear Transport Error Suppression

[:] Allow 9-Pin Track Arm Commands in Local Mode
[:] Allow 9-Pin Transport Commands in Local Mode

Punch In Frame Offset: [ frames
Punch Out Frame Offset: [ rames

7. Finally, you need to make sure Pro Tools is sending MIDI timecode continuously to ADR Manager while Pro Tools is playing. Otherwise, timecode is only sent
when Pro Tools is stopped or when you move the Pro Tools cursor to a new location. In Pro Tools, you can do this in 2 places: the Edit window or the Transport

window.

o In the Edit window, right-click in a blank area at the top of the window and check the Synchronization pane. Turn on the MTC button.

# Zoom Controls
# Transport

MIDI Controls
¢ Bynchronization
# Qutput Meters

¢ Expanded Transport

I

o Open the Transport window by choosing Windows > Transport. Display the Synchronization pane by clicking on the menu in the upper right corner of the
window and choosing Synchronization. Turn on the Gen MTC button.



9_. faTa)

g + Counters
MIDI Controls

: UUSQSE + Synchronization

Output Meters

+ Expanded Transport

8. Quit and relaunch both ADR Manager and Pro Tools.

9. Open ADR Manager's Transport Control window and click on the MIDI Enable button to turn on MIDI communication.

@O Transport Control

48 > P»

Reel 01 Auto-select

° Play from 631+13 | | Preroll
| Play to Post ro

ADR Manager settings are saved, so you won't have to reset them each time. MIDI settings in Pro Tools are saved with each session but can be clobbered if the
session is opened on another workstation that does not have the same MIDI setup. If MIDI isn't working with your Pro Tools session, double check the settings under
the Setup > Peripherals > Synchronization tab (step 4) and Setup > Peripherals > Machine Control tab (step 5), and make sure the MTC button is on (step 7).



Aligning timelines

In addition to setting up MIDI as described previously, you will also need to make sure your timecode and timeline settings match the settings in ADR Manager.

A common workflow is to create a Pro Tools session for each reel in your film. Each session starts at a different timecode number, typically every hour on the

hour, where the hour equals the reel number. Using this technique lets ADR Manager differentiate between reels based on incoming timecode. The following
steps explain how to set this up.

e Make sure the Pro Tools session Timecode Rate and Feet+Frames Rate match the timecode and feet and frames settings of your ADR Manager

project.
@ Modify Project
Project name: Apply changes ?
|My Show I @ Session Setup
Code name:
Deep Purple [
Sample Rate: 48 kHz Audio Format: | BWF (.WAV) B Session Start: 02:00:00:00
Abbreviation: Director: ADR Supervisor: P —— -
Bit Depth: | 24 Bit 2 Interleaved: | | Session Length Limit:
DP Steve
Clock Source: ~ See Control Panel Timecode:
Notes System Delay: 449 samples Timecode Rate: 24 M|
. — Pan Depth: | -3.0 dB % Feet+Frames Rate: |24 M|
Preferred time format:  Feet frames —
Timecode 2 Rate: |24 M|
Timecode format: 24 frame timecode running at 24 fps
Feet and frames forma 35mm feet and frames running at 24 fps -
Sample rate: 48 kHz 2 =

e Make sure the Pro Tools session start timecode matches the corresponding reel's start timecode number in ADR Manager. Note that the reel start is not
the same as the reel FFOA.

(] New Reel
Reel number 02 Version _
Dupe date 2/11/22
H ual OK & Next
[ Session Setu
Cancel L
?
Descriptions Media Sample Rate: Audio Format: | BWF (.WAV) v gssion.Sta
Bit Depth: | eavEd: Session Length Limit:
Feet and frames Timecode -
Clock Source:  See Control Panel Timecode:
Reel start 0+00 02:00:00:00' 4 v
System Delay: 449 samples Timecode Rate:
FFOA 12+00 02:00:08:00 T — —
Pan Depth:
LFOA (inclusive) 2000:00  02:22:13:08 on Depth: (008 T FootsFrames ato: (G NS
Reel end (inclusive) 2020400 ©2:22:26:16 Timecode 2 Rate

* should equal Pro Tools session start time
SYNC Setup & Timecode Offsets

Timecode Settings

o Check the alignment of the timelines in your Pro Tools session by locating the cursor to the FFOA of the reel and displaying timecode and feet+frames in
the "Main" and "Sub" location indicators at the top of the Edit window, as shown:

9+00 ~| S
st 01:00:06:00 | Lorgt

Cursor B (@ Diy

e Compare these values in Pro Tools with the timecode and footage values for the reel's FFOA in the New/Modify Reel window in ADR Manager. Adjust the
values in ADR Manager to match your Pro Tools times. Or you can change the timelines in Pro Tools by using the Redefine Current Timecode
Position... and Redefine Current Feet+Frames Position... items under the Setup menu (refer to Pro Tools documentation for more info).



Redefine Current Feet+Frames Position

Current Timecode Position: 02:00:00:00

Desired Feet+Frames Position:

If you are having trouble getting the footages in ADR Manager to match the footages displayed in Pro Tools, try this:

e First, double check to make sure you have followed the instructions in this chapter carefully.

e Next, try changing your timecode rate in Pro Tools and ADR Manager to be 24 frame timecode running at 24 fps (if your feet and frames rate in Pro Tools
and ADR Manager is 24 fps) or 24 frame timecode running at 23.976 fps (if your feet and frames rate in Pro Tools and ADR Manager is 23.976 fps). This
means that there will be a one-to-one correspondence between a frame of video and a frame of film. Then, even if the timecode burn-in on your digital
video may not match Pro Tools or ADR Manager (because it is non drop frame timecode, for instance), at least the footage burn-in should match.



Locking List windows to Transport Control

ADR Manager lets you send locate, play, and stop commands to Pro Tools from the ADR Cue, Reel, and Scene List windows.

Make sure the Transport Control window is setup properly and MIDI is turned on, then click the Lock to Transport button at the top
of the List window or type shift-command-T:

Lock to
trarl.SFlClrt
I'I,I
@ @ ADRCue List \
+/ 47X < () (2

When this button is enabled, several functions become active:

e Locate — Selecting a cue, reel, scene, or change event will immediately locate Pro Tools to its start time. You can select
records in List windows by single-clicking on them or using the up and down arrow keys. If a preroll is set in the Transport
Control window, it will be accounted for when locating.

e Play/Stop — Hitting the spacebar will play Pro Tools (if it is stopped) or stop Pro Tools (if it is playing). If the "Play to"

checkbox is checked in the Transport Control window, playing will stop roughly when the end time of the cue, reel, scene, or
change event is reached. If a postroll is set in the Transport Control window, playing will stop after the Play From time plus

the post roll.
e Nudge — You can move the current cursor in Pro Tools by 1 frame (in timecode or feet and frames) by typing the plus or
minus keys.

Using the Lock to Transport button is a great way to quickly make sure cue times are correct after a conform. Simply arrow
down through each cue in the ADR Cue List window, hitting spacebar each time to hear the beginning of the cue.



Keyboard shortcuts

ADR Manager gives you the ability to perform actions based on keyboard shortcuts you define. You can add and delete text from
fields, send transport control commands, and change field values using shortcuts. Default shortcuts are created automatically when
you make a new database, but you can add, delete, or modify them at any time. Shortcuts are saved in the database, so if you
move the database to another computer with a different keyboard layout, you may need to modify the keys to press for the shortcut.
You can print out a list of shortcuts to use as a reference while using ADR Manager (see The default reports).

TIP: If you want to use your customized shortcuts with databases you create in the future, select them all in the Keyboard

Shortcut List window and export them to a XML file. The next time you create a new database, delete the default ones and
import the custom ones from the XML file.



Displaying shortcuts

Displaying shortcuts is done in the Keyboard Shortcut List Window:

ano Keyboard Shortcut List
(+(&)(7)(x) @@
| When pressed in | Keystroke |Descriptior1 |
any ADR Manager cmd [ Go to previous tabbed page in window
window
any ADR Manager cmd ] Go to next tabbed page in window
window
any ADR Manager F5 Set start time to current transport time
window
any ADR Manager F& Set end time to current transport time
window
anv ADR Manaaer shift F2 Tell transport to "play” b

0 of B keyboard shortcuts selected
S ——"

You can open this window by selecting Keyboard shortcuts from the Windows menu. If the Keyboard Shortcut List Window is
already open, a checkmark will appear beside Keyboard shortcuts. If the Keyboard Shortcut List Window is behind another
window or is inactive, select Keyboard shortcuts to make the Keyboard Shortcut List Window active. You can close the Keyboard
Shortcut List Window by clicking on its close box, or typing command-W.

The Keyboard Shortcut List window displays the following columns, as a default. You can customize the window by clicking on the
Customize button in the upper right corner.

e When pressed in (Context) — This column shows what window needs to be open and frontmost in order for the shortcut to
work.

o Keystroke — The key(s) that need to be pressed in order to invoke the shortcut.

e Description — A description of the action that will be performed.

Adding, deleting, and modifying shortcuts is via the Manage menu when the Keyboard Shortcut List window is active, or using the
toolbar buttons at the top of the Keyboard Shortcut List window. When the List window is active, the Manage menu looks like this:

ULEGELEE Windows Help

Add shortcut %N
Duplicate selected shortcuts... #D
Modify shortcut...

Delete selected shortcuts...

Use these menu items to add, duplicate, modify, and delete shortcuts.



Creating shortcuts

To create shortcuts, you must have the Keyboard Shortcut List Window open and active. Select Add shortcut from the Manage
menu, click on the toolbar button, or type command-N. The following dialog will appear:

Edit keyboard shortcut

Description : |Z[ Enabled

Insert ™ into current field

When in  any ADR Manager window ﬂ
and you press f S——
S
then insert text into field ﬂ
Field:  current field ﬂ

Text to enter:

( QK ) ;i Cancel :: @

You can always change these fields later.

Description — A description of the shortcut. This is automatically filled in when you change any of the other fields in the
window, but you can re-enter your own description if you like.

Enabled — Controls whether the shortcut is active or not.

Context — The context field (labeled "When in") lets you choose in which context the shortcut is available. The context is
the window in which you can invoke the shortcut. If the window is not open or in the background, then pressing the shortcut
has no effect.

Keystroke — You can set what keystroke to use by pressing the "Set..." button next to the keystroke area. You must assign
a keystroke in order to save the shortcut. Be aware that certain key combinations may also trigger other actions in addition to
the shortcut you've defined. For instance, in the default macOS installation, pressing command-space in any application
opens Spotlight. If you define an ADR Manager shortcut with command-space, then anytime you invoke the shortcut,
Spotlight will also appear. It is up to the user to find a key combination that doesn't conflict with other system or application
shortcuts.

Action — Once you choose the context, the action popup changes to show what kinds of actions your shortcut can take. For
contexts within ADR Manager, you can choose to:

o Insert text into field — Inserts text into the field selected under the "Field" popup. You can direct the text into a
specific field, or choose "current field." You specify what text to enter in the "Text to enter" field. If you choose a
specific field, the shortcut will append the text into the field without moving the cursor, if the cursor is in another field in
the window. If you choose "current field", the text is entered at the current cursor location (replacing the currently
highlighted text, if any). For instance, say you've defined a shortcut that inserts the word "Offscreen" into the Notes



field in the New or Modify Cue window. If the cursor is in the Reel Number field when you invoke the shortcut, the
word "Offscreen” is appended to the Notes field and the cursor remains in the Reel Number field.

o Delete text from field — Finds the first occurrence of the text specified in "Text to delete" and removes it from the
field specified in the "from" popup. If the cursor is not in the target field, it remains in its current location.

o Increment field — Increments a popup or toggles a checkbox. Note that some fields increment in the opposite
direction to what you might expect — you should experiment to make sure the field changes the way you want.

o Decrement field — Decrements a popup or toggles a checkbox. Note that some fields decrement in the opposite
direction to what you might expect — you should experiment to make sure the field changes the way you want.

o Put current transport time — This will grab the current time displayed in the Transport Control window (although the
window need not be open) and stuff it into the specified field. If the window you are stuffing the value into also displays
a reel number, the reel number will change to match the context displayed in the Transport Control window.

o Tell transport to play/stop/locate/fast forward/fast rewind — Effectively pushes a button on the Transport Control
window to send the specified MIDI message. You must have setup the proper external communication preferences
(see Using MIDI) for this to work. For the "locate" message, you can choose which target field you want to use as the
location value, or you can choose "current selection" for cases when you've highlighted text in a field and you want the
Transport Control to locate to that position. If no text is highlighted, then whatever value is in the "Locate" field in the
Transport Control window is used.

o Go to next / previous tab — This command is used in windows that contain multiple tabbed pages. Normally you
would have to click on the tab to go to another page. This command lets you traverse the tabbed pages without
having to click on them.

e Target — The "recipient" of the shortcut action. The list of targets consists of popup of fields that can be found in the
shortcut's context window.

o Text to enter — The text to enter, in the case of an "Insert text into field" action.



Deleting shortcuts

To delete shortcuts, you must have the Keyboard Shortcut List Window open and active. Click, shift-click, and/or command-click the
shortcuts you would like to delete, then choose Delete selected shortcuts from the Manage menu. Before ADR Manager deletes
the shortcuts, however, it warns you that the operation is not undoable. If you proceed, be aware that you won't be able to "undo”

the delete by choosing Undo from the Edit menu or typing command-Z.



Modifying shortcuts

To modify a shortcut, simply double-click on it in the Keyboard Shortcut List Window. The Modify Shortcut Window appears:

Edit keyboard shortcut

Description : @ Enabled
Insert ™ into current field

When in [ any ADR Manager window I :]
and you press
then | insert text into field | :]

Field: | current field | :]

Text to enter:

E oK 3 ( Cancel :| @

Change the shortcut fields then click OK, or click Cancel if you decide you don't want to change anything.

See Creating shortcuts for an explanation of the fields in this window.



Grab times from Pro Tools using a macro

ADR Manager ships with a macro that you can use to grab the current start and end time from Pro Tools. It requires Keyboard Maestro

(www keyboardmaestro.com). To install the macro, go to Preferences > Software updates.

Click on the Install KM macro button to install the macro. In the Keyboard Maestro Editor window, enable both the macro and the Pro Tools group by checking
the box on the right.

th 5 < ® Q
Groups v Macros v
[ All Macros Ty Grab start and end tim... F13 [ —
m Enabled Macros m Pro Tools V
9 clipboards ) )
B Global Macro Group Z Available in these applications: ?
 ProTools 00 2@ Pro Tools
B9 switcher Group £ Available in all windows
o Always activated.
1of 6 1 macro Edit ?
[ EON | #; Keyboard Maestro Editor
i % < ® > , Q ]
Groups A J Macros vV

[E Al Macros ¥ Grab start and end tim... F13 [

T "‘ Grab start and end times

[P clipboards . . .

B Global Macro Group Triggered by any of the following {(when Pro Tools is at front):

|71 Pro Tools ©© < This hot key:

[ switcher Group F13 ~ 2ispressed

2 Or by script.
Or via the web server but all remote access is disabled.
Will execute the following actions:
& + = v/ 1eof6 |+ —| | 1selected + [ Try Record 7

Assign a hot key that does not conflict with other shortcuts in ADR Manager or macOS.

Once installed, you can type the hot key to copy the start and end times displayed in Pro Tools and paste them into the time fields in an open ADR Manager edit
window, including the New or Modify Cue windows, New or Modify Reel windows, New or Modify Scene windows, and the New or Modify Change Event
windows.


http://www.keyboardmaestro.com/

ADR Manager shortcuts

Below is a list of shortcuts that are used by ADR Manager. You should avoid using them when defining your own keyboard

shortcuts for the same window:

Keyboard shortcut Command Used in:
Command-O File > Open database Any window
Command-I File > Import Any List window
Command-E File > Export Any List window
Command-P File > Save PDF Any List window
Command-Z Edit > Undo Any Edit window
Command-X Edit > Cut Any Edit window
Command-C Edit > Copy Any Edit window
Command-V Edit > Paste Any Edit window

Option-Shift-Command-V Edit > Paste and match style Any Edit window
Command-A Edit > Select all Any Edit window

Control-command-space

Edit > Emoji & Symbols

Any Edit window

Command-N

Manage > New

Any List window

Command-D

Manage > Duplicate

Any List window

Shift-Command-S

Manage > Spell check

ADR Cue Edit windows; Reel Edit
windows; Scene Edit windows; Take Edit
windows

Shift-Command-1

Manage > Insert current MIDI

ADR Cue Edit windows; Reel Edit
windows; Scene Edit windows

Shift-Command-2

Manage > Set start time to MIDI

ADR Cue Edit windows; Reel Edit
windows; Scene Edit windows

Shift-Command-3

Manage > Set end time to MIDI

ADR Cue Edit windows; Reel Edit windows

Shift-Control-Command-2

Manage > Paste start time

ADR Cue Edit windows; Reel Edit
windows; Scene Edit windows

Shift-Control-Command-3

Manage > Paste end time

ADR Cue Edit windows; Reel Edit windows

Shift-Control-Command-4

Manage > Paste start and end times

ADR Cue Edit windows; Reel Edit
windows; Scene Edit windows

Shift-Command-T

Lock to Transport button

Any List window

Command-L

Manage > Lock selected cues

ADR Cue List window

Command-U

Manage > Unlock selected cues

ADR Cue List window

Shift-Command-A

Manage > Create take for selected cues

ADR Cue List window

Shift-Command-L

Manage > Split cue

ADR Cue List window

Shift-Command-G

Manage > Merge cues

ADR Cue List window

Option-V Perform button Change List window

Shift-Option-V Perform Net Change button Change List window

Control-Shift-Option-V Skip button Change List window
Command-R Windows > Reels Any window
Command-J Windows > Scenes Any window
Command-G Windows > ADR cues Any window
Command-T Windows > Takes Any window
Command-K Windows > Characters Any window
Command-R Windows > Reports Any window




Command-F

Windows > Search window

Any window

Command-1

Windows > Transport Control

Any window




Preferences

There are several preferences that control the behavior of ADR Manager. Preferences fall into two categories:

e Project: Saved in the database itself. Project preferences control cue naming, cue locking, take naming and reel versioning.

e User: Saved in ~/Library/Preferences/ADR Manager preferences. User preferences include the last used search criteria for
cues and takes, data entry settings, and MIDI settings.

Preferences are automatically saved when you do any one of the following:

make changes in the Preferences dialog

perform a search in the Search Window

customize a List Window

quit ADR Manager

There are some preferences that are saved automatically when you perform certain actions, and some that you can set explicitly.
The preferences that are set automatically include:

e The current reel set
e List window customization
e The last used search criteria in the Search Window

Preferences that you can set explicitly are accessed by choosing Preferences... under the Apple menu. The Preferences dialog
appears with several tabs to choose from. The following sections describe the tabs.



Data entry preferences

To setup preferences for data entry in various windows, choose the Data entry tab:

O ADR Manager preferences

W Cue naming Cue status Take naming Software updates

When creating or modifying a cue, autofill its name.

When creating a new cue, set the cue end time to:

O Blank

Cue start time
Add 00:00:00:00 to cue start time

Round up cue end time to nearest whole unit
Mormalize time values

Enable spell check in text fields

G | Cancel | 7

The following preferences can be set:

Autofill cue name - If you want cue names to be automatically generated as you enter new cues in the New Cue Window,
check this checkbox. Once you enter a valid reel number, start time, and character name into the New Cue Window, ADR
Manager will automatically generate a cue name based on the renaming method you chose (see below). Remember, you
can always rename cues later by using the rename feature.

Set cue end time - When entering a new cue in the New Cue window, you can choose to leave the end time blank, set it to
the start time of the cue as soon as it is entered, or add a specified amount of time to the cue start.

Round up cue end time - You can have ADR Manager automatically round up the end time of a cue in the New Cue
Window. The end time is rounded up to the next nearest whole second or foot, depending on your time format.

Normalize time values - If you type an invalid value in a time field, ADR Manager will display an error and disallow the
value. If you'd rather have the application attempt to correct the value by recalculating subfields, check this preference. For
example, if you are spotting in non drop timecode and you enter 01:00:00:45, ADR Manager would display an error. If this
preference were turned on, the value would be replaced with 01:00:01:15 and no error would be posted.

Enable spell checking - This turns on the auto spell checking feature when you are typing in a text field. See Spell checking
for more information.



Cue naming preferences

You can customize how ADR Manager generates unique cue names. Click on the Cue naming tab:

M, N ADR Manager preferences

i External sources Data entry Cue naming | Cue status Take naming General '

Generate cue names using the following fields:

e R TR Options for Character abbrey:
~ Reel number () Fixed length field: 0| characters
Scene name (will be padded with leading zeroes)
+ Counter ® Dynamic length field
[ Use delimiter after field:

Example: M Counter resets for each character
Char abbrev = CH; Reel = 5; Scene = 43a;

37th cue W Counter resets for each reel/scene
CH527A E'l Try to keep counter numbers ordered

by cue start time (use suffixes if needed)

( OK ) !':Cancel :: téj

Add fields to your cue naming convention by putting checkmarks next to the ones you want to include. Highlight a field to set its
options. You can also specify how the counter is generated. See the following sections for explanations of the options in this pane.

Cue name settings are applied only to cue names created in the future. ADR Manager will not go back and
automatically change existing cue names in your database (but you can manually rename them yourself; see Renaming
cues). Therefore, it is usually a good idea to spend some time before you start naming cues and think about the
requirements of your project, then set the preferences carefully.

ADR Manager will use the cue naming convention when importing cues from a file. Imported cue names are parsed
according to the convention you have set up here.



Cue name fields

Click to the left of the field name to include it as part of a cue name. A checkmark appears next to the field name. The fields that you
can include in a cue name are:

e Character abbreviation
e Reel number
e Scene name

e Counter &emdash; This field is required in all cue names

Currently, you cannot change the order in which fields appear in a cue name.



Cue name field options

If you highlight a field name in the list on the left side of the Cue Naming tab, the options in the right side of the window display the
field's options.

Field options are:

) Fixed length field: 0| characters
(will be padded with leading zeroes)
f®) Dynamic length field

] Use delimiter after field:

Field length You can choose to make certain fields a dynamic length or a fixed length. If a field is fixed length, then zeros
will be added to the beginning of a field's value if the value is too short to fill the field. For instance, if you choose to make
the reel number a fixed length field of 3 digits, and a cue’s reel number is "6", then the reel number component of the cue's
name will be "006." If you don't impose a fixed length to a field, then the field will have a dynamic length.

Click on the radio buttons next to "Fixed length field" or "Dynamic length field" to choose what field length you want. If
you choose "Fixed length field", enter the number of digits you want displayed.

Delimiter Each field can have a trailing delimiter. This can be useful to differentiate where one field ends and the next one
starts. For instance, you could have an underscore "_" between the character abbreviation and reel number so that you
know where a character abbreviation ends and the reel number begins. This could be particularly helpful if a character
abbreviation ends with a number.

To add a delimiter to a field, put a checkmark in the "Use delimiter after field" checkbox and enter the delimiter in the box
beside it. You can enter as much text as you like, but be careful not to use text that may be a part of another field, such as
a character abbreviation. It is usually best to use delimiters that consist of a single punctuation character, such as an
underscore.



Counter options

The "Counter" field is required in all cue names and is simply a number (and possibly a letter, if you want ordered counters - see
below). This number helps to create a unique name for each cue. ADR Manager manages this counter internally, but you can
control how the counter increments using the options in the Cue Naming tab:

| Counter resets for each character
M Counter resets for each reel/scens

E Try to keep counter numbers ordered
by cue start time (use suffixes if needed)

These options let you specify the naming "domain." When creating a new cue name, ADR Manager gathers named cues with
matching subcomponents, such as character abbreviation, and creates a naming domain. Then within that domain, ADR Manager
looks at the counter numbers in use and chooses a new counter number. In other words, the counter number distinguishes cues
with the same subcomponents. The checkboxes in this section let you designate which subcomponents should be considered.

Counter resets for each character If you want to have a separate counter for each character, check the "Counter resets for
each character” checkbox. This means that when ADR Manager is renaming a cue, it examines what character it belongs
to. It then looks at all named cues for that character, determines the highest counter number among them, and increments
the number by 1.

Counter resets for each reel/scene If you want to have a separate counter for each reel or scene, check the "Counter resets
for each reel/scene” checkbox. If the reel number is included in the cue name but not the scene name, then the reel is
used. If the scene name is included in the cue name but not the reel number, then the scene is used. If both the reel
number and scene name are included in the cue name, then the scene is used. This means that when ADR Manager
renames a cue, it examines what reel or scene it belongs to. It then looks at all named cues for that reel/scene, determines
the highest counter number among them, and increments the number by 1.

If you want a separate counter for each character and reel/scene combination, check both boxes. This means that when
ADR Manager renames a cue, it examines what reel/scene and character it belongs to. It then looks at all named cues for
that reel/scene and character, and determines a new unique counter among them.

Ordered counter numbers You can also ask ADR Manager to try to keep counter numbers ordered according to cue start
time by using letter suffixes. In this case, ADR Manager does not find the highest counter within the naming "domain."
Instead, it attempts to number cues based on their chronological order in the reel or scene. Letter suffixes can be used to
differentiate two cues that would otherwise have the same counter number. For example, if you have two cues called
BB101 and BB102 and add a new cue whose start time is between them, then it will be impossible to generate a new cue
name whose counter is between them (ADR Manager uses only whole integers for counter numbers). By adding the letter
"A" to the new cue's name, this solves the problem and the new cue is given the name BB101A.



Counter options example

To demonstrate what affect the counter options have on cue names, suppose we want to name the following cues for characters
Bob and Jim:

| Reel |5cene| Cue name | Start/End |l.':haracter |
ol == 15+11 Bob
16+00
o1 s 24+00 Jim
25+00
oz == Z6+01 Bob
Z6+H15
0z s EATHZ2 Jim
25+04

Assume we have included the character abbreviation, reel number and counter in our cue naming convention. The following
examples illustrate what cue names would be generated, depending on the counter options selected.



Resetting by character only

E Counter resets for each character

] Counter resets for each reel/scene

Reel |Scene| Cue name | Start/End |[:haracter

o1 -—  BB101 15+11 Bohb
16+00

o1 -—  JHM101 24400 Jim
25+00

oz -—- BB2D2 Z6+01 Bob
IE+15

oz -—  JHM202 I7H12 Jim
5+04

Note that the counter did not care what reel a cue was in, only which character it was in. Numbering started over for each character,
but continued incrementing across reel boundaries.



Resetting by reel/scene only

] Counter resets for each character

™ Counter resets for each reel/scene

Reel |Scene| Cue name | Start/End |[:haracter

o1 -—  BB101 15+11 Bohb
16+00

o1 -—  JHM1D2 24400 Jim
25+00

oz -—- BB2DO1 Z6+01 Bob
IE+15

oz -—  JHM202 I7H12 Jim
5+04

Note that the counter did not care what character a cue was in, only which reel it was in. Numbering started over for each reel and
continued incrementing, regardless of which character each cue was in.



Resetting by both character and reel/scene

E Counter resets for each character

™ Counter resets for each reel/scene

Reel |Scene| Cue name | Start/End |[:haracter

o1 -—  BB101 15+11 Bohb
16+00

o1 -—  JHM1D2 24400 Jim
25+00

oz -—- BB2DO1 Z6+01 Bob
IE+15

oz -—  JHM202 I7H12 Jim
5+04

Numbering started over for each character within in each reel. This is the most commonly used naming convention, because it
shows at a glance that a cue is the Nth spotted cue for a particular character in a particular reel.



Cue status preferences

To control features dealing with reel versioning and cue statuses, click on the Cue status tab:

MO ADR Manager preferences

[ External sources Data entry Cue naming Cue status Take naming General |

To distinguish reel dupes, use: {*) dupe date

() version

Automatically lock cues that are:

1| omitted h
¥ | Recorded '+ or greater
When modifying cues, | ask whether to 5 ] modify ancestor cues as well.

( OK ) i Cancel ) (j;'

Reel dupes can be distinguished by version or dupe date. In several places throughout ADR Manager, such as the Modify Cue
window, you can select from a list of all the dupes for a reel. This preference designates how multiple dupes of the same reel are
differentiated.

If you choose to differentiate reels by version, then each time you create a new dupe of a reel you will be forced to give it a unique
version number. Note that a blank string is considered a version number, so there can only be one dupe with a blank or empty
version. If there are already two or more dupes of a reel with the same version, an error message will appear if you try to set this
preference. If you choose dupe date, reel dupes are distinguished by date (ADR Manager always requires you to give a unique date
for each new dupe anyway).

You can have ADR Manager automatically lock cues when certain attributes are set by checking the appropriate checkboxes
under "Auto-lock cues" message. You cannot manually change any fields in the Modify Cue window for a locked cue (see Locking
cues for more information). Choose which attributes you want to use as the "threshold" for locking. For example, if you want to lock
cues once they've been recorded, set the popup to "Recorded" and check the box. The next time you set the status of a cue to
recorded, ADR Manager will automatically lock it.

When you create a new dupe of a reel, ADR Manager keeps copies of each cue in the reel in both the old and new reel dupes (see
Cue lineage). When you make a change to a cue, the changes are automatically propagated to the cue's copies in later reel
dupes (except for changes to text fields with embedded times). However, ADR Manager gives you the choice whether you want to
propagate the changes to copies in earlier dupes. You can choose to always update ancestor cues, never update them, or ask each
time. For example, you may not want to modify a cue in an earlier dupe if you want to keep a sort of "paper trail" of the cue . In this
case, you would choose "never." The fields that may or may not be propagated to ancestors are:

e Character
e Dialogue

e Public notes



Private notes

Omitted status

Cue status

Priority

Locked status

Note that cue name changes are always propagated, regardless of this setting.



Take naming preferences

Takes can span multiple cues. For this reason, take names contain information about all the cues they span. Take naming
conventions are rules that are added to cue naming conventions to create names for takes. You can set the take naming
convensions in the Take Naming tab of the Preferences window:

MO ADR Manager preferences

i External sources Data entry Cue naming Cue status Take naming General |

Delimiter that appears between counter —_—
numbers to represent a range of cues: =

Delimiter that appears between counter o
numbers to represent non-consecutive cues:

Delimiter before the take number:

Example:
Take consists of the cues CH527A, CH528, CH529, and CH532,
and is take number 4

CH527A>29,32_04

Fa N
o9 (Cancel ) (?)

Take names are similar to cue names, except that they allow for ranges of counter numbers as well. A take name begins with the
full name of the first cue it includes (ordered by start time). For any other cues that the take spans, only the counter number is used.
Note that all cues for a given take must be from the same character and reel.

It is usually a good idea to make sure that your take naming convention does not conflict with your cue naming
convention. For instance, you should not use the same delimiters for take naming as you do for cue naming.

You can specify what delimiters you want to use between consecutive and non-consecutive cue name counters. It is usually best to
use delimiters that consist of a single punctuation character, such as an underscore or comma.

¢ Consecutive cue name delimiter — This is the delimiter inserted between consecutive cue name counter numbers. If it is
more than one character, it cannot start with an alphanumeric character.

o Non-consecutive cue name delimiter — This is the delimiter inserted between non-consecutive cue name counter
numbers. If it is more than one character, it cannot start with an alphanumeric character.

e Take number — This is the delimiter that is inserted before the take number.



Software updates

This tab allows you to check for updates to the application, and install a macro for use with Keyboard Maestro™.

o ADR Manager preferences

Data entry Cue naming Cue status Take naming Software updates

Automatically check for software updates

Check for updates

Click to install a Keyboard Maestro macro that will grab the start
and end times from Pro Tools and stuff them in the ADR Manager
edit window.

Install KM macro

WOk el

To automatically check each time ADR Manager is launched, check the Automatically check for software updates box. You can
manually check to see if there are any updates by clicking the Check now button. If there is no network connection when ADR
Manager attempts to check for updates, the check is skipped.

If an update is found, a window is displayed showing what version is available and what new features or bug fixes it contains. You
can then click on the Go to website... button to launch your web browser, go to the Slanecon Digital support page, and download
the installer. You should quit ADR Manager before installing the new version.

A special keyboard macro ships with ADR Manager that is designed to be used with the automation utility Keyboard Maestro
(www.keyboardmaestro.com). Make sure you have Keyboard Maestro installed before clicking on the Install KM macro button. See
Keyboard Shortcuts > Macros for more information on how to install and use the macro.


http://www.keyboardmaestro.com/

Working with other applications

ADR Manager has been designed to work with other applications, such as Avid's Pro Tools, to make spotting and editing ADR
smoother and faster.

There are several ways to interact with other applications:

e Using MIDI

e Building a library of recordings

e Using the Finder

e Adding takes to a Pro Tools session



Building a library of takes

You can build a library of takes by importing Pro Tools sessions that represent bins on an Avid. You can include ADR takes as well
as production dialogue and other audio files. See Creating a library from Avid media for more information and instructions on how to
deal with media generated from an Avid.

You can also scan folders on disk to build the take library. See Importing audio files for more information.



Displaying audio files in the Finder

Once you've linked an audio stream to a take, you can display the audio stream's files in the Finder by selecting the take in the Take
List window and choosing Show in Finder under the Manage menu.



Importing and exporting to Pro Tools

ADR Manager gives you the ability to export cues, takes, scenes, and change notes into a currently open Pro Tools session.
Conversely, you can also import clips, markers, track names, and track comments from a Pro Tools session text file to create cues,

takes, and scenes in the data file.



Glossary

Active window

A window that is in front of all other windows. To make a window active, simply click on it anywhere. If a window is not open, you
can open it by choosing the appropriate menu item under the Windows menu.

Ancestor cue

A copy of a cue that exists in an earlier reel dupe. For instance, if there were a cue called JK101 in reel 1 v1 and another copy of
JK101 in reel 1 v2, then the cue in v1 is considered the ancestor of the cue in v2. Likewise, the copy in v2 is considered the
descendant of the copy in v1.

Audio stream

A set of audio files that share common characteristics, specifically: sample rate, bit depth, timestamp, number of samples, folder
location, and common base name (different suffixes). For instance, two files named "Audio_01.L" and "Audio_01.R" with the same
characteristics and disk location form a stereo audio stream.

Avid change list

An Avid change list is a text file exported from an Avid non-linear editing system, such as Avid Media Composer™. Avid change lists
are typically exported in "columnar" format, which has a descriptive header and ample spacing between rows and columns. The
columnar format is easily readable by humans but can sometimes be problematic when importing, due to the wide variety of options
when exporting in this format from Media Composer. Another format, tab delimited text file, is more reliable to import but less
readable by humans. ADR Manager can import both formats.

Change event

An instruction that describes where to move a chunk of time to match a new picture dupe. A change event can be an insert, delete,
or replace event, and can be applied to leader, a single shot, a part of a shot, or multiple shots. If a change event is a delete, it can
utilize a trim bin to save the deleted chunk. This is called a "delete and hold" event. The chunk can then be used in another location
by a "insert hold" event that uses the same trim bin. When using trim bins, you must always perform the "delete and hold" event
before its corresponding "insert hold" event.

Change list

A list of instructions, or change events, that describe where to move cues so that they match a new picture dupe.

Columnar

A type of Avid change list format. See Avid change list.

Command key

The command key on the Macintosh is either of the two keys with the apple and the swirly design on it, just to the left and right of
the space bar on an extended keyboard. When the manual says to use a command key you must hold down one of these two keys
while typing the appropriate key. For example, if the manual says to "type command-period", hold down one of these special
command keys while typing a period.



Conform action

A conform action is a single action in a list of actions called a conform note. In ADR Manager, conform actions insert and delete time
in reels to match edits made to picture. You can enter conform actions using the Conform window (available under the Manage
menu when the Reel List window is active).

Conform note

A list of conform actions that, when applied to a reel dupe, adjust the edits and locations in a reel dupe to match a new picture
dupe.You can enter conform actions using the Conform window (available under the Manage menu when the Reel List window is
active).

Cue sheet

A cue sheet is a type of report that displays cues. ADR Manager comes with many predefined cue sheets, as well as other types of
reports. The predefined cue sheets have been designed for ADR editors, mixers, assistants, and actors.

Current time

The time value that ADR Manager maintains via MIDI communication with an outside source. The current time can be inserted in
various time and text fields using menu commands, keyboard shortcuts, and applescripts.

Database

All of the information for a project lives in a single database. The database is separate from the ADR Manager application. It
consists of a collection of files, namely the data file (.4dd), the index file (.4DIndx), and the recovery file (.Match). You can force the
Finder to treat these separate files as one file ("package") by putting them in a folder with the .4dbase suffix. This term is used
interchangeably with the term data file.

Data file

The file that contains all of the record data. A data file name ends with ".4dd". It is part of a database (see above). This term is used
interchangeably with the term database.

Descendant cue

A copy of a cue that exists in a later reel dupe. For instance, if there were a cue called JK101 in reel 1 v1 and another copy of
JK101 in reel 1 v2, then the cue in v2 is considered the descendant of the cue in v2v1 Likewise, the copy in v1 is considered the
ancestor of the copy in v2.

Dialog

A dialog is a Macintosh term for a window that appears on your screen. A dialog usually requires you to click on an OK button
before continuing. Do not confuse the term "dialog" with the term "dialogue".

Dialogue

Dialogue is the words that an actor says. A cue consists of dialogue, a start and end time, and various other information. Do not



confuse the term "dialogue" with the term "dialog".

Export

Exporting is a way of getting a subset of information out of your database and into another file. Typically you export certain
information out of your database in order to import it into a new database so that you don't have to retype it all over again in the new
document.

Field

A field is a term used in the database world to refer to a single piece of data of a particular type. It can be a number, text, or any
other types. You might have to type something in a box to fill in a field, or check a checkbox, or click on a radio button. A record
consists of several fields. For example, a "character” record contains a "character name" field, an "actor name" field, and an
"abbreviation" field.

FFOA

The First Frame Of Action. This is where onscreen content begins for the reel, scene, cue, or take. See FFOS for an example.

FFOS

The First Frame Of Segment. Reels and scenes are considered segments of time in your project. The FFOS is where the timeline
begins for the segment. For example, if you are working on a TV project you might define a reel to have an FFOS of 00:59:50:00
and an FFOA of 01:00:00:00, which means there is 10 seconds of leader before program content begins. If you are working in film,
the settings might be FFOS of 0+00 and FFOA of 12+00. Only segments, such as reels and scenes, have FFOS and LFOS times
(in addition to FFOA and LFOA times) - cues and takes only have FFOA and LFOA times.

Hold region

You can hold a region after deleting (removing) it from a reel. Usually, you hold a region so that you can insert it later. Deleting,
holding, and inserting regions is typically done when rebalancing reels or changing the order of scenes within a reel.

Import

Importing is a way of getting a subset of information into your database. Typically you import a file that was the result of a previous
export. Importing and exporting is done so that you can copy information from one database to another without retyping it all over
again.

Index file

A file that contains the indexes for a database. Indexes are used to search and sort records. An index file name ends with ".4DIndx".
Itis part of a database (see above).

LFOA

The Last Frame Of Action. This is the end time of program content in a reel, scene, cue, or take. By industry convention, the LFOA
is inclusive, meaning that the frame refered to by the LFOA is included in the range of time. For example, if a reel FFOA is
01:00:00:00 and its LFOA is 01:00:00:01, then the program content is 2 frames long (it consists of frames 01:00:00:00 and
01:00:00:01).



LFOS

The Last Frame Of Segment. This is the last frame of a segment (a reel or scene). The LFOS is the last frame of black or slug for a
segment (as opposed to the LFOA which is the last frame of program content). By industry convention, the LFOS is inclusive,
meaning that the frame refered to by the LFOS is included in the range of time. For example, if a reel FFOS is 01:00:00:00 and its
LFOS is 01:00:00:01, then the segment is 2 frames long (it consists of frames 01:00:00:00 and 01:00:00:01).

Lineage

The chronological order of the copies of a particular cue in different reel dupes. Copies in earlier reel dupes are considered
ancestors of the copies in later dupes.

Project

A project can be a film, TV show, commercial, video game, or any other entity that is contained within its own creative world. It
typically has a set of characters, and a set of reels, episodes, or other types of segments that break down the project into
manageable chunks of time or story logic. Also called "show" or "production”.

Project time

Values that represent locations in a project's timeline. Project times include cue start and end times, reel LFOAs, and scene start
times. Project time is formatted as either timecode or feet and frames time, as opposed to normal clock time which is always defined
in hours, minutes and seconds.

Record

A record is a term used in the database world to refer to information about an object, like a character, reel, or cue. A record consists
of several fields. For example, a "character" record contains a "character name" field, an "actor name" field, and an "abbreviation"
field.

Record file

A record file stores records in a special format that is readable and writable only by the ADR Manager program. A record file may
contain only one record, as in a report record file, or it may contain many records, as in a cue record file. Record files can only be
created by exporting, and only be read by importing.

Reel dupe

A reel dupes is a particular version of a reel. Reel dupes are created as the picture department makes changes to the reels in a
project. ADR Manager requires that all reel dupes have unique dupe dates.

Reel dupe status

The reel dupe status field in a cue keeps track of the reel dupe in which a particular cue's status changed. For instance, if a cue was
recorded to v2.0 of a reel, then the reel dupe status is 2.0. Reel dupe status is independent of which reel dupe the cue actually lives
in, so in our example the cue may live in v3.0 of the reel but still display "recorded to v2.0" as its status.

"Remove" reel

When performing a move using the Move Time dialog, the remove reel is the reel you will be removing the region from. The region



will be inserted into the "insert" reel.

Report

A report is a list of records that is printed to a printer. Cue sheets are reports, as are Reel Lists and Cue Count Tables.

Round tripping

The ability to export out of the datafile, then import it back in without losing any data.

Run a report

Create a PDF file which can be used either for onscreen viewing or saving to disk

Segment

A linear section of time in a project. Segments can be nested; in other words, segments can live within other segments. For
instance, scenes are segments within reels, which are, in turn, segments within a project.

Session

A Pro Tools session, which is a composition file containing lists of tracks, clips, and audio files.

Session text file

A file that is exported from Pro Tools using the File > Export Session As Text menu item. The file contains general session
information and lists of tracks, clips, and audio files.

Show

The entire film, television show, video game, or other media project for which an ADR Manager database is created. Also called
"project”.

Status

A cue always has a particular status, like spotted, recorded, or cut. You typically change the status of a cue after you spot, record,
or cut it. This lets you do searches and print reports based on cues' statuses.

Structure file

The ADR Manager application file. Structure file is a term used by 4th Dimension, which is the database program ADR Manager is
based upon.

Style tag

Style tags are invisible characters embedded in text fields that specify changes in font name, size, color, and style (such as bold and
italics). In most cases you don't need to know they are there, except when importing or exporting to an external file and you want to
preserve those font characteristics.



Table

Records representing the same kind of object all live in the same table. For instance, character records live in the "character" table,
whereas ADR cue records live in the "ADR cue" table. Also called record type.

Tag

(An advanced term) Some of ADR Manager's records are variable in length, so in order to find them their location is stored in an
address table. If an address table is damaged, 4D Tools uses markers, or "tags", stored in the header of every record to rebuild the
address table.

Take

A recording of a cue. A cue typically has several takes, each of which may refer to an audio file on disk. Some takes span more than
one cue if, for instance, the actor decided to perform several cues together in one long recording.

Text file

A text file is file that consists of readable letters. You can look at or change the information in a text file by opening it up in a word
processor.

Trim bin

A chunk of time from a reel dupe that was deleted using a change event. Once filled, a trim bin can then be inserted in another
location with an "insert" change event.

XML

Stands for Extensible Markup Language. XML files are text files that are specially formatted to allow, among other things, easy and
accurate transfer of information between computer programs.
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